Search found 87 matches

by BOT-Brad
Tue Dec 29, 2015 7:47 pm
Forum: Support and Development
Topic: [Solved - Graphics Driver Bug] Weird Canvas Issue
Replies: 14
Views: 2077

Re: Weird Canvas Issue

slime wrote:I plan to have a workaround in love itself for 0.10.1, for affected systems.
Ooh, very nice. Great work all around, keep it up. :crazy:
by BOT-Brad
Tue Dec 29, 2015 7:36 pm
Forum: Support and Development
Topic: [Solved - Graphics Driver Bug] Weird Canvas Issue
Replies: 14
Views: 2077

Re: Weird Canvas Issue

Yeah, that'll do as a workaround - although performance might not always be as good. To make sure it has the best possible performance when doing that, set the blend mode so that it won't do any blending: love.graphics.setBlendMode("replace", "premultiplied") You could also probably do something li...
by BOT-Brad
Tue Dec 29, 2015 7:17 pm
Forum: Support and Development
Topic: [Solved - Graphics Driver Bug] Weird Canvas Issue
Replies: 14
Views: 2077

Re: Weird Canvas Issue

I was testing in Mac OS X before - after booting into Windows it seems my AMD Radeon 6750m has the same graphics driver bug. :( It happens for me regardless of whether I use 64 bit or 32 bit versions of 0.9.2 or 0.10.0 though. Ah yeah you are correct, I just realised I was using the edited version ...
by BOT-Brad
Tue Dec 29, 2015 5:40 pm
Forum: Support and Development
Topic: [Solved - Graphics Driver Bug] Weird Canvas Issue
Replies: 14
Views: 2077

Re: Weird Canvas Issue

Hmm, nope, still just pauses on the single first randomly generated colour. EDIT: I am stumped, I actually just got the 0.9.2 version of the code to work by running it in the 64-bit version of LOVE and everything changes colour every frame, however the 0.10.0 version still does not work either in th...
by BOT-Brad
Tue Dec 29, 2015 5:18 pm
Forum: Support and Development
Topic: [Solved - Graphics Driver Bug] Weird Canvas Issue
Replies: 14
Views: 2077

Re: Weird Canvas Issue

Yes, in 0.9.2 the same thing happens, just a single colour and then nothing. I am glad it seems to be an issue on my machine then. Here are all the version mumbo-jumbo from CCC. Packaging Version: 12.104-130328a-157485C-ATI 2D Version: 8.01.01.1295 D3D Version: 9.14.10.0969 OpenGL Version: 6.14.10.1...
by BOT-Brad
Tue Dec 29, 2015 4:57 pm
Forum: Support and Development
Topic: [Solved - Graphics Driver Bug] Weird Canvas Issue
Replies: 14
Views: 2077

Re: Weird Canvas Issue

They do indeed both behave the same, however maybe I am misunderstanding how canvas:clear (or graphics.clear in 0.10.0) works. In love 0.10.0, I would expect the following code to randomly show a new colour every frame. canvas = love.graphics.newCanvas() function love.draw() love.graphics.setCanvas(...
by BOT-Brad
Tue Dec 29, 2015 3:41 pm
Forum: Support and Development
Topic: [Solved - Graphics Driver Bug] Weird Canvas Issue
Replies: 14
Views: 2077

Re: Weird Canvas Issue

OK, pretty sure something with love.graphics.clear(...) is dodgy. replacing this; love.graphics.setCanvas(g.game_canvas) love.graphics.clear(0, 0, 0, 255) with this; love.graphics.setCanvas(g.game_canvas) love.graphics.setColor(0, 0, 0, 255); love.graphics.rectangle("fill", 0, 0, width, height) Fixe...
by BOT-Brad
Tue Dec 29, 2015 3:16 pm
Forum: Support and Development
Topic: [Solved - Graphics Driver Bug] Weird Canvas Issue
Replies: 14
Views: 2077

[Solved - Graphics Driver Bug] Weird Canvas Issue

So I am porting my football project over to 0.10.0, and I have come across a bizare issue. I have a gamestate system which draws to a canvas. This drawing works fine and everything appears correctly, however when I attempt to clear the canvas (no longer using canvas:clear(), but love.graphics.clear(...
by BOT-Brad
Mon Oct 05, 2015 9:08 pm
Forum: General
Topic: Hacktober Fest
Replies: 10
Views: 1948

Re: Hacktober Fest

Really cool idea. :) I'm going to upload my current projects to github so you guys can send pull requests. I really hope that everyone joining into this "event" sends real pull requests with helpful content - at least I will. :) Update: https://github.com/MadByteDE/Air-Taxi https://github.com/MadBy...
by BOT-Brad
Mon Oct 05, 2015 8:25 pm
Forum: Support and Development
Topic: Wrong size font
Replies: 4
Views: 516

Re: Wrong size font

It seems the correct display size for that specific font is actually 13pt, 26pt, 39pt, etc... Try 13pt and 26pt and they display correctly. Oh yes, this is working! Sorry, it was probably a dumb question... I should have tried! Just curious, how did you noticed that? No problem. It's a pretty commo...