Search found 42 matches

by ac3raven
Sat Jul 07, 2018 7:48 pm
Forum: Support and Development
Topic: Find nouse position out of bounds
Replies: 7
Views: 580

Re: Find nouse position out of bounds

This is a great little library and It'd be great if you could provide a small tutorial on how to use it. At least for me, it's not self-evident. Thanks!
by ac3raven
Sat Jun 16, 2018 4:39 am
Forum: Support and Development
Topic: [Solved]Using a timer to iterate through a table
Replies: 1
Views: 385

Re: Using a timer to iterate through a table

Okay, well I figured out. So here is the solution. I was using the wrong timer function, mainly. First, I added Timer.update(dt) to love.update. Then I changed my keypressed function to look like this: function love.keypressed(key) if key == "z" then for i,v in ipairs(player) do Timer.after(player[i...
by ac3raven
Sat Jun 16, 2018 4:23 am
Forum: Support and Development
Topic: [Solved]Using a timer to iterate through a table
Replies: 1
Views: 385

[Solved]Using a timer to iterate through a table

I have a player table. Inside that player table is multiple "horse" tables. The horses are lined up by offsetting their x position based on the x of the previously added horse. When the player jumps, I need the lead horses to jump in sequence from the lead horse to the last horse, such that the arc ...
by ac3raven
Wed Jul 30, 2014 12:24 am
Forum: Support and Development
Topic: Very strange pathfinding issue (Jumper)
Replies: 3
Views: 1071

Re: Very strange pathfinding issue (Jumper)

I subtract 1 from y and x in the two functions where it's appropriate (Obstacle:draw() and Obstacle:collision_load()), and I am still getting similar pathing issues. See screenshot. https://imgur.com/d1YMAim This is the code that generates a map: nx,ny = 14,14 local scale = 1/love.math.random(4,6) l...
by ac3raven
Tue Jul 29, 2014 12:24 am
Forum: Support and Development
Topic: Very strange pathfinding issue (Jumper)
Replies: 3
Views: 1071

Very strange pathfinding issue (Jumper)

I am using Jumper for path-finding in my game. The game features a random-level generator that produces tile-based obstacles. I am having a very strange issue with the discovered paths. see screenshot: https://imgur.com/jQvdUZZ I thought it might be an offset issue, but there's nothing out of the or...
by ac3raven
Sat Mar 22, 2014 1:03 am
Forum: Support and Development
Topic: Reading from a Tiled map and printing values
Replies: 1
Views: 629

Reading from a Tiled map and printing values

So I made a 2-layer map in Tiled and exported the lua file so that STI could handle it. I am trying to read the value of each position in the obstacle table, and print each value. Simple right? Apparently not for me. :( Here's a sample of what I've tried: for x,y in pairs (map.layers.obstacle.data) ...
by ac3raven
Wed Dec 04, 2013 7:01 pm
Forum: Support and Development
Topic: Guidance for path-finding with ATL and ATC
Replies: 16
Views: 3102

Re: Guidance for path-finding with ATL and ATC

I have reached an impasse. I can't seem to figure out how to draw the path that is being calculated, and I also don't know why the enemy's movement is so wonky. I suspect it's because I'm doing the pathfinding incorrectly as well as the movement, but I don't know what I'm doing wrong. the previously...
by ac3raven
Wed Dec 04, 2013 1:46 am
Forum: Support and Development
Topic: Guidance for path-finding with ATL and ATC
Replies: 16
Views: 3102

Re: Guidance for path-finding with ATL and ATC

Thanks Roland. People on the IRC channel helped me figure this out. I'm making progress!

Nothing truly works yet, but I got an enemy to spawn and move toward the player in a very buggy way that makes little sense. But that's much better than whee I was a few days ago.
by ac3raven
Tue Dec 03, 2013 7:24 pm
Forum: Support and Development
Topic: Guidance for path-finding with ATL and ATC
Replies: 16
Views: 3102

Re: Guidance for path-finding with ATL and ATC

I've made some progress implementing jumper in a fresh game (I think), but I'm running into a problem where when I launch the game, and it errors out with "invalid location".

I'm not sure why. I based much of the code off the demo that Roland linked to.