Search found 98 matches

by randomnovice
Wed Apr 04, 2018 7:02 pm
Forum: Games and Creations
Topic: Lord of the Rings Battlecards
Replies: 20
Views: 7137

Lord of the Rings Battlecards

Hi folks! Complete amateur with Love2d here but for quite a while now(!) I've been playing around with making a card game with CCG-type mechanics (e.g. Hearthstone) but based on the characters and world of Lord of the Rings (because hey, I love that!). Up until now it's been completely for my own en...
by randomnovice
Sun Jun 18, 2017 4:10 pm
Forum: Support and Development
Topic: [SOLVED] Debugging using ZeroBrane Studio
Replies: 14
Views: 4528

Re: Debugging using ZeroBrane Studio

Okay, quite simple in the end then. Just changed love.load() to love.load(arg).

Don't know where arg is defined... but gonna go with what I think works..!
by randomnovice
Sun Jun 18, 2017 4:05 pm
Forum: Support and Development
Topic: [SOLVED] Debugging using ZeroBrane Studio
Replies: 14
Views: 4528

Re: Debugging using ZeroBrane Studio

(..and the reason for having a custom love.run() function was having this loop at the "base" level)
by randomnovice
Sun Jun 18, 2017 3:58 pm
Forum: Support and Development
Topic: [SOLVED] Debugging using ZeroBrane Studio
Replies: 14
Views: 4528

Re: Debugging using ZeroBrane Studio

Thanks, Probably I'm not supposed to...? But I have. Here's my edited version of love.run() which is calling love.load() near the start? function love.run() -- Randomness! if love.math then love.math.setRandomSeed(os.time()) end -- Load things in love.load() -- Big loop for everything while true do ...
by randomnovice
Sun Jun 18, 2017 3:49 pm
Forum: Support and Development
Topic: [SOLVED] Debugging using ZeroBrane Studio
Replies: 14
Views: 4528

Re: Debugging using ZeroBrane Studio

Shall I change the call of
love.load()

in love.run() to

love.load({"-debug"}) ??
by randomnovice
Sun Jun 18, 2017 3:47 pm
Forum: Support and Development
Topic: [SOLVED] Debugging using ZeroBrane Studio
Replies: 14
Views: 4528

Re: Debugging using ZeroBrane Studio

Thanks both. I did try that line before but I actually get an error:

Error
main.ua:64: attempt to get length of local 'arg' (a nil value)

Traceback

main.lua:64: in function 'load'
main.lua:8: in function <main.lua:3>
[C]: in funtion 'xpcall'
by randomnovice
Sat Jun 17, 2017 7:19 am
Forum: Support and Development
Topic: [SOLVED] Debugging using ZeroBrane Studio
Replies: 14
Views: 4528

Re: Debugging using ZeroBrane Studio

Thanks both, The problem with testing step-by-step is in this case it's an AI and the issue is sporadic. Sometimes it runs absolutely fine multiple times in a row. Other times the AI just gets stuck somewhere. I'll just have to re-check all the loops and try to find one that could somehow get stuck....
by randomnovice
Fri Jun 16, 2017 2:53 pm
Forum: Support and Development
Topic: [SOLVED] Debugging using ZeroBrane Studio
Replies: 14
Views: 4528

[SOLVED] Debugging using ZeroBrane Studio

Hi folks, I'm running into an occasional spinning wheel of death bug (infinite loop somewhere!?) and my programme is long enough and (probably unnecessarily) complicated enough that it's not easy to spot exactly where/how. I wrote it using TextEdit before discovering the wonders of ZeroBrane (which ...