Search found 147 matches

by TurtleP
Sun May 11, 2014 10:09 pm
Forum: Support and Development
Topic: Image angled direction
Replies: 2
Views: 439

Image angled direction

Hey all, I have a problem with the AI of one of my entities. It's supposed to calculate the angle it should "attack" at for the nearest player. So far, I have this: local angofattk -- angle of attack for attacking the player local attk --attack, should I? function AI:updatePhaseTwo(dt) local nearest...
by TurtleP
Wed May 07, 2014 4:32 am
Forum: General
Topic: Saving a stat
Replies: 2
Views: 978

Re: Saving a stat

player = {} player.points = 0 e = love.filesystem.exists("points.lua") if e then chunk = love.filesystem.load("points.lua") chunk() elseif not e then pp = love.filesystem.newFile("points.lua", "w") --open for writing end success = love.filesystem.write("points.lua",table.show(player, "playerpoints"...
by TurtleP
Tue May 06, 2014 9:45 pm
Forum: Support and Development
Topic: Low fps?
Replies: 6
Views: 1501

Re: Low fps?

I figured out what was wrong: too many for loops during the game_update method. It's all fixed up and runs smooth as butter now :D. If anyone wants, I might set up this as a public beta and release things every now and then.
by TurtleP
Tue May 06, 2014 9:02 pm
Forum: Support and Development
Topic: Low fps?
Replies: 6
Views: 1501

Re: Low fps?

When phoenix's health bar reaches zero I got this: Error: classes/hpbar.lua:50: Can't set scissor with negative width and/or height. stack traceback: [C]: in function 'setScissor' classes/hpbar.lua:50: in function 'draw' entities/spacephoenix.lua:174: in function 'draw' states/game.lua:188: in func...
by TurtleP
Tue May 06, 2014 8:49 pm
Forum: Support and Development
Topic: Low fps?
Replies: 6
Views: 1501

Re: Low fps?

micha wrote:It runs smoothly on my computer. Which part is it, that is to slow? The main game?
When I do love.timer.getFPS() in love.update or print it on screen, it shows 43 as the FPS. Yeah, it also seems to be the main game that feels the slowest.
by TurtleP
Tue May 06, 2014 7:54 pm
Forum: Support and Development
Topic: Low fps?
Replies: 6
Views: 1501

Low fps?

Hi all, I am working on updating an old game one of my group's beta testers and I made together. One of my current issues is that even with VSync on, I only get ~43FPS. I'd like to make that number a lot higher, say 60 FPS. This is after porting it over to Love 0.9.1. I am not sure if it's the game,...
by TurtleP
Thu Apr 17, 2014 12:56 pm
Forum: Games and Creations
Topic: Turtle: Puzzles
Replies: 42
Views: 14696

Re: Turtle: Puzzles

Can't check website :/ Don't understand me wrong i like your game and etc but why menu background looks like made with ms paint? Don't worry, a lot of the game graphics (not just entities and tiles) are getting updated. But it's that way because the game needed something for the menu background. (A...
by TurtleP
Thu Apr 17, 2014 12:32 pm
Forum: Games and Creations
Topic: Turtle: Puzzles
Replies: 42
Views: 14696

Re: Turtle: Puzzles

It's been two months since I said anything about the game. So, I don't recall whether or not I said what has happened recently. For starters, Turtle: Puzzles is far from scratched. I'm working on improving the graphics with my graphical designers as well as rewriting the level editor and entities. I...
by TurtleP
Thu Feb 27, 2014 8:42 pm
Forum: Games and Creations
Topic: Turtle: Puzzles
Replies: 42
Views: 14696

Re: Turtle: Puzzles

When I try to run the game, I get this error: Loaded messages! Image 'Man, we ain't found shit!' - some guy from Spaceballs Error: extras/dlc.lua:9: bad argument #1 to 'exists' (string expected, got nil) stack traceback: [C]: in function 'exists' extras/dlc.lua:9: in function 'init' class.lua:41: i...
by TurtleP
Thu Feb 27, 2014 8:32 pm
Forum: Support and Development
Topic: Sublime Text 2 and Love2D Boot Errors
Replies: 4
Views: 594

Re: Sublime Text 2 and Love2D Boot Errors

slime wrote:Does your LÖVE build system for Sublime Text have "shell":true in it? The [wiki]Sublime Text 2[/wiki] wiki page has an example.
It didn't. Last time I even saw that, it had no "shell":true in the code. Thanks!