[DEPRECATED] Experimental iOS port (LÖVE 0.9.2)

Discuss any ports of LÖVE to different platforms.
TripleXero
Prole
Posts: 4
Joined: Tue Jul 14, 2015 9:12 pm
Location: Wisconsin

Re: Experimental iOS port (LÖVE 0.9.2)

Post by TripleXero » Fri Jul 17, 2015 9:35 pm

I spent the last few days since I made that post trying to get OS X in Virtual Box after a few failed attempts, finally got it and Xcode, had some failed attempts at Xcode and finally got the app out of it, but now I have a blank app named "love" that says "Installing..." on my phone, even though it was put on through iTunes and it's done syncing, and trying to run it before making the .ipa in Xcode worked fine. I don't know. At this point I just need a break from attempting to get this to work with no knowledge of this stuff beforehand. I'll try that site a bit later on, but thanks for bringing it up

User avatar
deathbeam
Prole
Posts: 39
Joined: Mon Mar 30, 2015 5:57 pm
Location: Slovakia
Contact:

Re: Experimental iOS port (LÖVE 0.9.2)

Post by deathbeam » Sat Jul 18, 2015 3:55 pm

You need to own Mac. End of story.

User avatar
undef
Party member
Posts: 434
Joined: Mon Jun 10, 2013 3:09 pm
Location: Berlin
Contact:

Re: Experimental iOS port (LÖVE 0.9.2)

Post by undef » Sun Jul 19, 2015 10:42 am

TripleXero wrote:I spent the last few days since I made that post trying to get OS X in Virtual Box after a few failed attempts, finally got it and Xcode, had some failed attempts at Xcode and finally got the app out of it, but now I have a blank app named "love" that says "Installing..." on my phone, even though it was put on through iTunes and it's done syncing, and trying to run it before making the .ipa in Xcode worked fine. I don't know. At this point I just need a break from attempting to get this to work with no knowledge of this stuff beforehand. I'll try that site a bit later on, but thanks for bringing it up
If you manage to get it running without a Mac make sure to write a tutorial on it!
Good luck!
twitter | steam | indieDB

Check out quadrant on Steam!

User avatar
T-Bone
Inner party member
Posts: 1492
Joined: Thu Jun 09, 2011 9:03 am

Re: Experimental iOS port (LÖVE 0.9.2)

Post by T-Bone » Mon Jul 20, 2015 7:58 pm

What about a Hackintosh?

User avatar
slime
Solid Snayke
Posts: 2700
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: Experimental iOS port (LÖVE 0.9.2)

Post by slime » Mon Jul 20, 2015 10:03 pm

Anything that runs OS X 10.9 or newer and has Xcode should work (in theory.)

User avatar
spill
Prole
Posts: 27
Joined: Thu May 07, 2015 1:53 am
Contact:

Re: Experimental iOS port (LÖVE 0.9.2)

Post by spill » Tue Aug 11, 2015 1:00 am

I'm fairly consistently getting an EXC_BAD_ACCESS in lj_vm_growstack_l. Any ideas why that could be happening?
[Edit] To clarify, this is when running on an iPhone 6.
Screen Shot 2015-08-08 at 5.10.53 PM.png
Screen Shot 2015-08-08 at 5.10.53 PM.png (211.26 KiB) Viewed 1902 times

User avatar
slime
Solid Snayke
Posts: 2700
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: Experimental iOS port (LÖVE 0.9.2)

Post by slime » Sat Aug 15, 2015 6:13 pm

spill wrote:I'm fairly consistently getting an EXC_BAD_ACCESS in lj_vm_growstack_l. Any ideas why that could be happening?
It might be a bug in the version of LuaJIT 2.1-alpha that LÖVE for iOS uses.

I just rebuilt the LuaJIT library for iOS using the latest code from LuaJIT's repository, so maybe you could try the updated version (replace the 'include' and 'libraries' folders in love/platform/ios/ with the ones in this download: https://dl.dropboxusercontent.com/u/421 ... raries.zip ).

User avatar
spill
Prole
Posts: 27
Joined: Thu May 07, 2015 1:53 am
Contact:

Re: Experimental iOS port (LÖVE 0.9.2)

Post by spill » Tue Aug 18, 2015 11:58 pm

slime wrote:
spill wrote:I'm fairly consistently getting an EXC_BAD_ACCESS in lj_vm_growstack_l. Any ideas why that could be happening?
It might be a bug in the version of LuaJIT 2.1-alpha that LÖVE for iOS uses.

I just rebuilt the LuaJIT library for iOS using the latest code from LuaJIT's repository, so maybe you could try the updated version (replace the 'include' and 'libraries' folders in love/platform/ios/ with the ones in this download: https://dl.dropboxusercontent.com/u/421 ... raries.zip ).
That seems to have fixed the problem! Thank you very much! :awesome:

covetiii
Prole
Posts: 6
Joined: Mon Sep 21, 2015 12:39 am

Re: Experimental iOS port (LÖVE 0.9.2)

Post by covetiii » Sat Sep 26, 2015 4:18 pm

This is pretty cool!

I am having trouble with my sound sources. They seem to always loop even when I set them to not loop. The love file works fine on my mac (the sound sources don't loop), but on my iPad the sources always loop. This is the lua code I use to set up the sound:

Code: Select all

   local node = {}
    node.src = love.audio.newSource(sound)
    node.obj = obj
    node.callbox = callback

    node.src:setPosition( obj.p.x, obj.p.y, 0 )
    node.src:setVelocity( obj.v.x, obj.v.y, 0 )
    node.src:setLooping( loop or false )
    node.src:setVolume( volume or 1 )
    node.src:setPitch( pitch or 1 )
    node.src:play()
    _.push(q, node) 
If you want to try the love file it's here: http://s5plot.com/Racing.love. It's a game I am making for my kids (ages 3 and 5). The above source code is in sound.lua. I'm not sure if it's something I am doing wrong or a bug with the port. I would appreciate any help.

User avatar
Ulydev
Party member
Posts: 401
Joined: Mon Nov 10, 2014 10:46 pm
Location: Paris
Contact:

Re: Experimental iOS port (LÖVE 0.9.2)

Post by Ulydev » Sat Sep 26, 2015 4:36 pm

covetiii wrote:I am having trouble with my sound sources. They seem to always loop even when I set them to not loop.
I've been getting this issue too from the very beginning, but I've never been able to get an answer. Here's the workaround I use in my published games :

Code: Select all

  sounds = {}
  sounds.time = {}
  sounds["test"] = love.audio.newSource("test.wav")
  sounds.time["test"] = 0.2 --the length of your audio file

  function playSound(sound)
    local time = sounds.time[sound]
    if iOS then flux.to(sounds, time, {}):oncomplete(function() sounds[sound]:stop() end) end
    return sounds[sound]:play()
  end
  local testSound = playSound("test")

Locked

Who is online

Users browsing this forum: No registered users and 1 guest