Love2D on Ubuntu-Enabled Samsung Chromebook

Discuss any ports of LÖVE to different platforms.
User avatar
BlazingSpirit
Prole
Posts: 5
Joined: Thu Nov 19, 2015 1:22 pm
Location: The Internet

Re: Love2D on Ubuntu-Enabled Samsung Chromebook

Post by BlazingSpirit » Tue Feb 02, 2016 12:14 pm

bartbes wrote:That's because 0.8.0 still used SDL 1.2, if I remember correctly.
Alrighty, then. Attempting to follow these instructions now to install SDL 1.2. I'll let you all know whether it all works or not. http://www.upubuntu.com/2012/01/how-to- ... imple.html

EDIT: Came across an error during building the SDL_image, I'll post it here.

Code: Select all

/bin/bash ./libtool --tag=CC   --mode=link gcc  -g -O2 -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/local/include/SDL     -o showimage showimage.o libSDL_image.la -Wl,-rpath,/usr/local/lib -L/usr/local/lib -lSDL -lpthread  
libtool: link: gcc -g -O2 -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/local/include/SDL -o .libs/showimage showimage.o -Wl,-rpath -Wl,/usr/local/lib  ./.libs/libSDL_image.so -L/usr/local/lib /usr/local/lib/libSDL.so -lm -ldl -lpthread
/usr/local/lib/libSDL.so: undefined reference to `_XGetRequest'
collect2: ld returned 1 exit status
make: *** [showimage] Error 1
EDIT 2: Okay, nothing past the first set of instructions is working. It all shows the same basic error above. Love still isn't running.
I am Blazing Maximus Spirit. And I. AM. A SUPE- nap time! *Starts Snoring*

bobbyjones
Party member
Posts: 664
Joined: Sat Apr 26, 2014 7:46 pm

Re: Love2D on Ubuntu-Enabled Samsung Chromebook

Post by bobbyjones » Tue Feb 02, 2016 7:30 pm

Are you following the instructions for 0.8.0? 0.8.0 has different dependencies than 0.9.0 or 0.10.0 iirc.

User avatar
BlazingSpirit
Prole
Posts: 5
Joined: Thu Nov 19, 2015 1:22 pm
Location: The Internet

Re: Love2D on Ubuntu-Enabled Samsung Chromebook

Post by BlazingSpirit » Tue Feb 02, 2016 8:01 pm

bobbyjones wrote:Are you following the instructions for 0.8.0? 0.8.0 has different dependencies than 0.9.0 or 0.10.0 iirc.
BlazingSpirit wrote:I tried building Love 0.8.0, but some of the dependencies aren't downloading: libluajit-5.1-dev and libsdl2-dev.
Are these of the dependencies that I require? And is there a way to get them other then "sudo apt-get install"?
I am Blazing Maximus Spirit. And I. AM. A SUPE- nap time! *Starts Snoring*

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest