[POLL] Do you like "then,do,end" or "{ }"?

General discussion about LÖVE, Lua, game development, puns, and unicorns.

Do you like "then,do,end" or "{ }"?

"then,do,end" is just fine
36
82%
"{ }" would be better
8
18%
 
Total votes: 44

jjmafiae
Party member
Posts: 1333
Joined: Tue Jul 24, 2012 8:22 am

Re: [POLL] Do you like "then,do,end" or "{ }"?

Post by jjmafiae » Tue Aug 06, 2013 3:04 pm

what about use unrelated words instead of "end" and "{}" like:

Code: Select all

if a = b then
     draw()
cat

LuaMaster
Prole
Posts: 13
Joined: Tue Jan 01, 2013 2:33 am

Re: [POLL] Do you like "then,do,end" or "{ }"?

Post by LuaMaster » Tue Aug 06, 2013 7:23 pm

{ }s are confusing, and just don't don't look neat. then,do,end is the best way to go in my opinion

User avatar
T-Bone
Inner party member
Posts: 1492
Joined: Thu Jun 09, 2011 9:03 am

Re: [POLL] Do you like "then,do,end" or "{ }"?

Post by T-Bone » Thu Aug 08, 2013 4:04 am

jjmafiae wrote:what about use unrelated words instead of "end" and "{}" like:

Code: Select all

if a = b then
     draw()
cat
I think you meant

Code: Select all

if a == b then
     draw()
cat
:neko:

User avatar
Helvecta
Party member
Posts: 167
Joined: Wed Sep 26, 2012 6:35 pm

Re: [POLL] Do you like "then,do,end" or "{ }"?

Post by Helvecta » Thu Aug 08, 2013 4:07 am

if then cat?
"Bump." -CMFIend420

jjmafiae
Party member
Posts: 1333
Joined: Tue Jul 24, 2012 8:22 am

Re: [POLL] Do you like "then,do,end" or "{ }"?

Post by jjmafiae » Thu Aug 08, 2013 8:24 am

depends on the langue i referred to in basic its just If a = b then
but yes in lua its if a == b then

it was kinda a joke.

User avatar
XHH
Citizen
Posts: 76
Joined: Thu Jun 20, 2013 6:43 pm
Location: US
Contact:

Re: [POLL] Do you like "then,do,end" or "{ }"?

Post by XHH » Fri Aug 09, 2013 4:59 am

jjmafiae wrote:

Code: Select all

if a = b then
     draw()
cat

Code: Select all

if(a.getValue().parseInt().toString().isEqual(b.getValue.parseInt().toString()){
      doNothingReally();
}
Just thought I should turn that into Java to make it more readable.

(random burn on Java)
I like to draw and program :)

SeducingOrange
Prole
Posts: 30
Joined: Tue Feb 12, 2013 7:45 pm

Re: [POLL] Do you like "then,do,end" or "{ }"?

Post by SeducingOrange » Wed Aug 14, 2013 3:23 pm

XHH wrote:
jjmafiae wrote:

Code: Select all

if a = b then
     draw()
cat

Code: Select all

if(a.getValue().parseInt().toString().isEqual(b.getValue.parseInt().toString()){
      doNothingReally();
}
Just thought I should turn that into Java to make it more readable.

(random burn on Java)
What about C++?

Code: Select all

#include <iostream>

using namespace std;

int main(int argc, char *argv[]) {
    int a = 5;
    int b = 5;
    if (a == b) {
        cout << "Hello, World" << endl;
    }
    return 0;
}

User avatar
XHH
Citizen
Posts: 76
Joined: Thu Jun 20, 2013 6:43 pm
Location: US
Contact:

Re: [POLL] Do you like "then,do,end" or "{ }"?

Post by XHH » Thu Aug 15, 2013 1:27 am

simple C++ if statements like that are great. But once you really get into C++.... omg...
I like to draw and program :)

User avatar
Eamonn
Party member
Posts: 550
Joined: Sat May 04, 2013 1:29 pm
Location: Ireland

Re: [POLL] Do you like "then,do,end" or "{ }"?

Post by Eamonn » Thu Aug 15, 2013 9:02 am

XHH wrote:But once you really get into C++.... omg...
I agree. I don't like C++, but I do like Java! Java's a great language.I like the fact that you can string stuff like this together:

Code: Select all

obj = new ClassThingy()
obj.isTrue = doThis().doThat().doOther().box2d().libgdx()
It makes code more readable IMO. I've been trying to setup LDT for LÖVE because I really like Eclipse. Any videos I find don't help or any docs don't help, so it's a real pain in the butt to do. But ctrl-spacebar to see all the options you have... WONDERFUL.
"In those quiet moments, you come into my mind" - Liam Reilly

User avatar
Robin
The Omniscient
Posts: 6506
Joined: Fri Feb 20, 2009 4:29 pm
Location: The Netherlands
Contact:

Re: [POLL] Do you like "then,do,end" or "{ }"?

Post by Robin » Thu Aug 15, 2013 10:15 am

Eamonn wrote:I like the fact that you can string stuff like this together:

Code: Select all

obj = new ClassThingy()
obj.isTrue = doThis().doThat().doOther().box2d().libgdx()
That's not really a property of Java, you can do that in any language. (Except maybe PHP.)
Help us help you: attach a .love.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests