LÖVE sites issues

General discussion about LÖVE, Lua, game development, puns, and unicorns.
Post Reply
User avatar
richapple
Citizen
Posts: 65
Joined: Sun Dec 25, 2011 10:25 am

LÖVE sites issues

Post by richapple » Fri May 04, 2012 12:26 pm

This gathered in me for quite a long time and now I decided to tell you all the bugs I found in LÖVE sites at once.



1. The simplest one. I think you can recognize the site.
pic 1.png
pic 1.png (7.94 KiB) Viewed 2757 times
Maybe it should say something like: "Advanced search" or "Search all boards"? I lack creativity but that tooltip always annoys me.



2. From nekogear:
pic 2.png
pic 2.png (14.63 KiB) Viewed 2757 times
Whenever I try to visit love2d.org from another computer, firefox starts complaining about invalid security certificate. I can't provide screenshots from my workstation, but here's one from phone: Looks like we can't do anything about this one.
Last edited by richapple on Sat May 05, 2012 10:06 am, edited 1 time in total.

User avatar
nevon
Commander of the Circuloids
Posts: 938
Joined: Thu Feb 14, 2008 8:25 pm
Location: Stockholm, Sweden
Contact:

Re: LÖVE sites issues

Post by nevon » Fri May 04, 2012 1:33 pm

The last one is really weird, because according to my browser, the SSL certificate is valid.

User avatar
Roland_Yonaba
Inner party member
Posts: 1559
Joined: Tue Jun 21, 2011 6:08 pm
Location: Ouagadougou (Burkina Faso)
Contact:

Re: LÖVE sites issues

Post by Roland_Yonaba » Fri May 04, 2012 2:28 pm

Certification works for me too.
Both with Firefox and Chrome.
Attachments
Untitled 1.png
Untitled 1.png (14.23 KiB) Viewed 2734 times

User avatar
kikito
Inner party member
Posts: 3133
Joined: Sat Oct 03, 2009 5:22 pm
Location: Madrid, Spain
Contact:

Re: LÖVE sites issues

Post by kikito » Fri May 04, 2012 2:33 pm

Browsers check the SSL certifiers against an internal list. This list is not standard - each browser has its own. The "big guys" are in all the lists, but smaller approvers are not.

In my case, the site works just fine in Chrome(desktop), but Android gives me the ssl warning - "The entity who provides this SSL is not on my list!".

Certificates from "big guys" cost lots of $$$, though.
When I write def I mean function.

User avatar
richapple
Citizen
Posts: 65
Joined: Sun Dec 25, 2011 10:25 am

Re: LÖVE sites issues

Post by richapple » Sat May 05, 2012 10:07 am

Ok, I guess we can't do anything about the last one. But what about the others?

huryepwl
Prole
Posts: 1
Joined: Thu May 10, 2012 12:26 pm

Re: LÖVE sites issues

Post by huryepwl » Thu May 10, 2012 12:29 pm

kikito wrote: In my case, the site works just fine in Chrome(desktop), but Android gives me the ssl warning - "The entity who provides this SSL is not on my list!".
Not only in Chrome. In Firefox as well.

User avatar
Nixola
Inner party member
Posts: 1868
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: LÖVE sites issues

Post by Nixola » Fri May 11, 2012 2:14 pm

It depends, someone has the error with Firefox, someone else with Chrome, and so on.
My PSVita's browser doesn't recognize it
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

coffee
Party member
Posts: 1206
Joined: Wed Nov 02, 2011 9:07 pm

Re: LÖVE sites issues

Post by coffee » Fri May 11, 2012 2:33 pm

All of you remember that if want more details of the SSL problem you can found more info and discussion here viewtopic.php?f=3&t=7349

pauld
Prole
Posts: 2
Joined: Mon Jun 18, 2012 2:19 pm

Re: LÖVE sites issues

Post by pauld » Tue Jun 19, 2012 12:32 pm

I know very little about certificates.

But my Googling came with this, that seems related:
Step 2 of: https://support.comodo.com/index.php?_m ... icleid=881

I came to it from: http://jimmyzimmerman.com/blog/2011/03/ ... refox.html

Post Reply

Who is online

Users browsing this forum: Fuzzlix and 6 guests