What went wrong?! RESOLVED

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
User avatar
WolfNinja2
Party member
Posts: 150
Joined: Wed Oct 24, 2012 10:10 pm

What went wrong?! RESOLVED

Post by WolfNinja2 »

I followed the gridlock player tutorial on this website, added my own map, even a character! I wa very excited (as I'm new to programming and never knew how to make a user movable player) I was so excited in fact, I wanted it to be better! So, I made a new state (i know how to do this) menu. the menu works fine, but now everything in the maze state is broke. I've figured out a lot of the bugs but the map function no longer works, it says 'attempt to get length of global "map"(a nil value)' PLEASE HELP!!!!!
:x
Last edited by WolfNinja2 on Fri Nov 09, 2012 11:01 am, edited 1 time in total.
User avatar
paritybit
Citizen
Posts: 53
Joined: Thu Sep 06, 2012 3:52 am

Re: What went wrong?!

Post by paritybit »

Might want to post a love file.
User avatar
substitute541
Party member
Posts: 484
Joined: Fri Aug 24, 2012 9:04 am
Location: Southern Leyte, Visayas, Philippines
Contact:

Re: What went wrong?!

Post by substitute541 »

.Love file please? Or just post the code in your post. Lot's of possibilities. One is that you probably called the map variable, BEFORE it was set.
Currently designing themes for WordPress.

Sometimes lurks around the forum.
User avatar
Helvecta
Party member
Posts: 167
Joined: Wed Sep 26, 2012 6:35 pm

No, guys, this has potential, just wait!

Post by Helvecta »

Image I don't know how we're supposed to help you without a .love file, but we're happy to acknowledge your disposition!
"Bump." -CMFIend420
User avatar
WolfNinja2
Party member
Posts: 150
Joined: Wed Oct 24, 2012 10:10 pm

Re: What went wrong?!

Post by WolfNinja2 »

I already scrapped this project, these bugs i managed to fix but then, player movement stopped working, also buttons cant be pushed on the title screen util you click spacebar :p help with that would also be nice, i can post that .love...
when i try to run the .love i get a rubber piggeh, so you might need to make a .bat or drag the files onto love unsure about that, all the files are there though.

EDIT:: the .love is fixed! haha
Attachments
MazeGuy.love
(13.28 KiB) Downloaded 82 times
Last edited by WolfNinja2 on Wed Oct 31, 2012 8:54 pm, edited 1 time in total.
User avatar
WolfNinja2
Party member
Posts: 150
Joined: Wed Oct 24, 2012 10:10 pm

Re: What went wrong?!

Post by WolfNinja2 »

also next time i will just post the .love if i need help..... haha sorry im a newbie
User avatar
Nixola
Inner party member
Posts: 1949
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: What went wrong?!

Post by Nixola »

You made a .rar archive, you have to make a .zip archive
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics
User avatar
WolfNinja2
Party member
Posts: 150
Joined: Wed Oct 24, 2012 10:10 pm

Re: What went wrong?!

Post by WolfNinja2 »

Nixola wrote:You made a .rar archive, you have to make a .zip archive
ohhhhhhhhhhhhhhhhhhhhhh (5 minutes later) hhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhh haha thanks, want me to reupload it as a working diddly do?
User avatar
Robin
The Omniscient
Posts: 6506
Joined: Fri Feb 20, 2009 4:29 pm
Location: The Netherlands
Contact:

Re: What went wrong?!

Post by Robin »

Do you still have a question or problem? If not, you might as well finish your game before you show it off. ;)
Help us help you: attach a .love.
Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 34 guests