love-0.5.0 failed to compile

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
User avatar
rude
Administrator
Posts: 1051
Joined: Mon Feb 04, 2008 3:58 pm
Location: Oslo, Norway

Re: love-0.5.0 failed to compile

Post by rude » Sun Oct 19, 2008 12:04 pm

appleide wrote:Uhh, how come there are no header files for everything inside the source folder box2d? Did I miss something incredibly obvious? ><
Maybe you missed the "Include" folder?

User avatar
appleide
Party member
Posts: 323
Joined: Fri Jun 27, 2008 2:50 pm

Re: love-0.5.0 failed to compile

Post by appleide » Sun Oct 19, 2008 8:42 pm

There is either include folders or header files in each of the other folders. In box2d folder, however, I cannot find any, not even it its child folders. No header files, no include folders.

Or am I suppose to somehow link it to the include folder from, say liblove? (Which is silly... And that include folder doesnt have the required header files anyway...)

I downloaded the .tar.gz and the .zip sources, and I can't find header files for box2d for either of them.

I 'm missing it. Maybe its hidden or something on my mac, but someone download it and check its there?

And yes, I did find header files for box2d in a previous version 0.4.x. The code seems to have changed so I can't use them. [has to do with testSegment]

User avatar
rude
Administrator
Posts: 1051
Joined: Mon Feb 04, 2008 3:58 pm
Location: Oslo, Norway

Re: love-0.5.0 failed to compile

Post by rude » Sun Oct 19, 2008 9:42 pm

I still don't get it.

The Box2D header is here:
src\box2d\Include\Box2D.h

You'll also need to add this as a search path:
src\liblove\include

Sorry for changing things all the time. :D

User avatar
appleide
Party member
Posts: 323
Joined: Fri Jun 27, 2008 2:50 pm

Re: love-0.5.0 failed to compile

Post by appleide » Mon Oct 20, 2008 2:54 am

You're right.
On a uni windows computer, the include folder is present in .zip and .tar.bz2 .

But, on my mac, the include folder is present only in .tar.bz2 and not the .zip.

That was the confusion. I guess its probably different archiving program different computers use? I use the default one that comes with OS X. :s

User avatar
rasjani
Prole
Posts: 22
Joined: Sun Sep 21, 2008 12:38 pm
Location: Finland
Contact:

Re: love-0.5.0 failed to compile

Post by rasjani » Mon Oct 20, 2008 10:34 am

They should be present in all source packages, check the conversation here: http://love2d.org/forum/viewtopic.php?f=3&t=186&start=7

User avatar
farvardin
Party member
Posts: 162
Joined: Sat Jun 28, 2008 6:46 pm

Re: love-0.5.0 failed to compile

Post by farvardin » Sat May 09, 2009 11:15 am

I'm trying to compile Löve from source on my computer which is using the current archlinux distribution.

with the "vanilla" source code it doesn't compile:

Code: Select all

opengl/love_opengl.cpp: In function ‘void love_opengl::screenshot(const char*)’:
opengl/love_opengl.cpp:1601: erreur: ‘ILvoid’ was not declared in this scope
opengl/love_opengl.cpp:1601: erreur: expected primary-expression before ‘)’ token
With my modified version which compiled some weeks ago (see http://aur.archlinux.org/packages/love/love/PKGBUILD please note the sed parts are commented and no longer relevant) , I got:

Code: Select all

opengl/ImageFont.cpp: In member function ‘virtual bool love_opengl::ImageFont::loadVolatile()’:
opengl/ImageFont.cpp:103: erreur: ‘printf’ was not declared in this scope
opengl/ImageFont.cpp:120: erreur: ‘printf’ was not declared in this scope
I think some code changed in the upstream opengl code (mesa?).

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: love-0.5.0 failed to compile

Post by bartbes » Sat May 09, 2009 12:42 pm

Or you need to add string.h in somewhere, but just to remind you of what you have done:

on 20 Oct 2008, 11:34

User avatar
Robin
The Omniscient
Posts: 6506
Joined: Fri Feb 20, 2009 4:29 pm
Location: The Netherlands
Contact:

Re: love-0.5.0 failed to compile

Post by Robin » Sat May 09, 2009 1:02 pm

What do you mean, bartbes? That farvardin dug up an old thread?
Help us help you: attach a .love.

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: love-0.5.0 failed to compile

Post by bartbes » Sat May 09, 2009 2:19 pm

Yes, I did.

User avatar
farvardin
Party member
Posts: 162
Joined: Sat Jun 28, 2008 6:46 pm

Re: love-0.5.0 failed to compile

Post by farvardin » Sun May 10, 2009 11:01 pm

I don't need to start a new thread called "love-0.5.0 failed to compile". This one is good enough to report new bugs related to evolutions of the upstread components.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 33 guests