Display choppy on Ubuntu

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
efexor
Prole
Posts: 4
Joined: Sat Aug 30, 2008 11:48 pm

Display choppy on Ubuntu

Post by efexor » Thu Jan 01, 2009 9:21 am

Well after doing some examples i noticed when i simply moved the sprite it was sort of choppy, not smooth. It's not the FPS because i was getting 80+. Any reasons why this is happening?

User avatar
Merkoth
Party member
Posts: 186
Joined: Mon Feb 04, 2008 11:43 pm
Location: Buenos Aires, Argentina

Re: Display choppy on Ubuntu

Post by Merkoth » Thu Jan 01, 2009 6:04 pm

Have you tried disabling desktop effects?

User avatar
igneous
Prole
Posts: 10
Joined: Wed Dec 31, 2008 5:35 am

Re: Display choppy on Ubuntu

Post by igneous » Thu Jan 01, 2009 6:33 pm

also, make sure vsync is enabled. if you're using the nvidia or ati drivers, it's as simple as checking a box in nvidia-settings or amdcccle

efexor
Prole
Posts: 4
Joined: Sat Aug 30, 2008 11:48 pm

Re: Display choppy on Ubuntu

Post by efexor » Thu Jan 01, 2009 7:03 pm

Well turning off the desktop effects did it but. My desktop effects :cry:

User avatar
mike
Administrator
Posts: 364
Joined: Mon Feb 04, 2008 5:24 pm

Re: Display choppy on Ubuntu

Post by mike » Thu Jan 01, 2009 7:30 pm

I've had that woe too. I want to have desktop effects but EVERYTHING chops when it's activated, even flash videos. I blame ATI.
Now posting IN STEREO (where available)

efexor
Prole
Posts: 4
Joined: Sat Aug 30, 2008 11:48 pm

Re: Display choppy on Ubuntu

Post by efexor » Thu Jan 01, 2009 7:53 pm

Well, i've got nvidia, so i guess its both :D

User avatar
Merkoth
Party member
Posts: 186
Joined: Mon Feb 04, 2008 11:43 pm
Location: Buenos Aires, Argentina

Re: Display choppy on Ubuntu

Post by Merkoth » Fri Jan 02, 2009 12:38 am

Those problems should be solved once this thing goes implemented into X, IIRC.

FWIW, I've been running various Ubuntu installs with desktop effects turned on and so far, so good. Shitty onboard nVidia chip here, using the "restricted driver" from the repos. Maybe igneous is right :P

User avatar
rude
Administrator
Posts: 1051
Joined: Mon Feb 04, 2008 3:58 pm
Location: Oslo, Norway

Re: Display choppy on Ubuntu

Post by rude » Fri Jan 02, 2009 1:34 am

Yeah, I remember Compiz being anal about that. It screwed severely with the LÖVE timer and accelerated video playback.

Post Reply

Who is online

Users browsing this forum: Geecko, Google [Bot] and 12 guests