No sound in any löve projects

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
innsmouthrain
Prole
Posts: 1
Joined: Wed May 07, 2014 8:08 am

No sound in any löve projects

Post by innsmouthrain » Wed May 07, 2014 8:12 am

Hi!

I'm looking around at game engines and editors for linux and found out about Löve2d! I am a fan of mari0 and I tried Mr Rescue as well as Hawkthorne journey now. Beautiful games and very promising framework for my team! I am very glad I stumbled upon this.

However. There is no sound at all in any of them. I've tried searching google and the forums but no luck. Anyone know something I can try to fix it?

I'm running arch linux and start the games by running a command like "love /usr/share/hawkthorne-journey/hawkthorne.love".

Warm regards

davisdude
Party member
Posts: 1154
Joined: Sun Apr 28, 2013 3:29 am
Location: North Carolina

Re: No sound in any löve projects

Post by davisdude » Sat May 10, 2014 1:53 pm

I'm not sure, honestly. I'm assuming your sound works regularly. I'm not much of a Linux person myself, I'm just sort of bumping this for you so a developer or other person might see this.
GitHub | MLib - Math and shape intersections library | Walt - Animation library | Brady - Camera library with parallax scrolling | Vim-love-docs - Help files and syntax coloring for Vim

User avatar
micha
Inner party member
Posts: 1083
Joined: Wed Sep 26, 2012 5:13 pm

Re: No sound in any löve projects

Post by micha » Sat May 10, 2014 5:15 pm

Hey,

I created a minimal example game to play sound. Please run the attached .love and press SPACE to play the sound. Do you hear anything? If not, do you get any output on the console?
Attachments
soundtest.love
(4.95 KiB) Downloaded 43 times

User avatar
XxSolidJelloxX
Prole
Posts: 25
Joined: Sun Jul 14, 2013 2:46 am
Location: The Stars

Re: No sound in any löve projects

Post by XxSolidJelloxX » Sun May 11, 2014 3:28 pm

micha wrote:Hey,

I created a minimal example game to play sound. Please run the attached .love and press SPACE to play the sound. Do you hear anything? If not, do you get any output on the console?
I tried this on windows. No sound when running just the .love file, but when I unpacked it and ran it with a compiler (.bat), I heard the sound loud and clear. The console wasn't enabled by default, so I enabled it and nothing printed to it when I pressed SPACE to play the sound. (Maybe when you said 'console' you meant something directed toward him being on linux?)... but anyways, yeah, that's what happened for me.
Last edited by XxSolidJelloxX on Mon May 12, 2014 1:46 am, edited 1 time in total.

User avatar
micha
Inner party member
Posts: 1083
Joined: Wed Sep 26, 2012 5:13 pm

Re: No sound in any löve projects

Post by micha » Sun May 11, 2014 5:40 pm

Edit: innsmouthrain will get a console output when he runs the game under linux.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 11 guests