Text not displayed for one particular user

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Tassilo
Prole
Posts: 14
Joined: Wed Jun 29, 2016 9:23 am
Contact:

Text not displayed for one particular user

Post by Tassilo » Sat Aug 25, 2018 7:28 pm

Hey guys.
My app "Pixel-Me" is available for quite a while now and has been used several times successfully by various people. However, one user just came up with this:
Image
The program and its window are opening (and working) correctly, but no text is visible.
Anyone ever experienced something like this before and has an idea, what might be causing this?
Love 11.1, Windows 10 used, packed executable, fonts embedded in the .exe, Text displayed using regular printf()
Thanks a lot,
Tassilo

grump
Party member
Posts: 583
Joined: Sat Jul 22, 2017 7:43 pm

Re: Text not displayed for one particular user

Post by grump » Sat Aug 25, 2018 8:08 pm

Tassilo wrote:
Sat Aug 25, 2018 7:28 pm
Anyone ever experienced something like this before and has an idea, what might be causing this?
You need to post a love file or at least a code snippet that demonstrates the bug.

Tassilo
Prole
Posts: 14
Joined: Wed Jun 29, 2016 9:23 am
Contact:

Re: Text not displayed for one particular user

Post by Tassilo » Sat Aug 25, 2018 8:23 pm

Not a single line of printf is being displayed to this user. It works fine for all others, so it seems to be something about love.
Lines of interest:

Code: Select all

love.graphics.setDefaultFilter("nearest","nearest",1)
font = love.graphics.newFont("fonts/font.ttf",8)
font:setFilter("nearest","nearest",1)
love.graphics.setFont(font)
function draw_button(text,x,y,width,height)
  newtext = love.graphics.newText( font, text )
  love.graphics.setColor(1, 1, 1, 1)
  textwidth, textheight = newtext:getDimensions( )
  love.graphics.setLineWidth(1)
  love.graphics.rectangle('line', x+0.5, y+0.5, width, height)
  love.graphics.print(text,x+((width-textwidth)/2),y+2)
end

grump
Party member
Posts: 583
Joined: Sat Jul 22, 2017 7:43 pm

Re: Text not displayed for one particular user

Post by grump » Sat Aug 25, 2018 9:26 pm

Yeah, right. You still need to post a love file or at least a code snippet that demonstrates the bug though, because the code you posted does absolutely nothing.

Tassilo
Prole
Posts: 14
Joined: Wed Jun 29, 2016 9:23 am
Contact:

Re: Text not displayed for one particular user

Post by Tassilo » Sat Aug 25, 2018 9:39 pm

Problem is, I cannot replicate the bug. Got the screenshot from a user experiencing it. The app is running perfectly fine on dozens of other machines.
User is reporting NO TEXT ever. App starts without, no text ever shows up. First time I heard of this and I had it running on several machines myself and know of dozens of users without problems.
My guess is, that it is somehow related to the user's system setup and one of you may have seen something similar before.

User avatar
Nixola
Inner party member
Posts: 1940
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: Text not displayed for one particular user

Post by Nixola » Sat Aug 25, 2018 9:43 pm

Are the user's graphics drivers up to date?
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

Tassilo
Prole
Posts: 14
Joined: Wed Jun 29, 2016 9:23 am
Contact:

Re: Text not displayed for one particular user

Post by Tassilo » Sat Aug 25, 2018 9:49 pm

Good point! Will have him check that, thanks.

User avatar
zorg
Party member
Posts: 2672
Joined: Thu Dec 13, 2012 2:55 pm
Location: Absurdistan, Hungary
Contact:

Re: Text not displayed for one particular user

Post by zorg » Sat Aug 25, 2018 11:29 pm

Some threads and an issue that may or may not be relevant:
https://bitbucket.org/rude/love/issues/ ... -older-ati
viewtopic.php?f=4&t=85080
viewtopic.php?t=85309

I'd ask about their graphics card as well, not just whether the drivers are up to date or not. Seems like older ati radeons can't handle what Löve requires with version 11.
Me and my stuff :3True Neutral Aspirant. Why, yes, i do indeed enjoy sarcastically correcting others when they make the most blatant of spelling mistakes. No bullying or trolling the innocent tho.

User avatar
pgimeno
Party member
Posts: 1785
Joined: Sun Oct 18, 2015 2:58 pm

Re: Text not displayed for one particular user

Post by pgimeno » Sun Aug 26, 2018 2:34 am

One user with the same problem and graphics card, reported that they had the latest drivers, so updating the driver is unfortunately not a solution. viewtopic.php?p=222533#p222533

Nelvin
Citizen
Posts: 90
Joined: Mon Sep 12, 2016 7:52 am
Location: Germany

Re: Text not displayed for one particular user

Post by Nelvin » Sun Aug 26, 2018 7:08 am

As it seems to be only related to text and not any other rendering my guess is, it's an issue with the glyph caching.

Using a bitmap font instead a ttf is probably the simplest solution for a quick fix.

http://www.angelcode.com/products/bmfont
https://github.com/libgdx/libgdx/wiki/Hiero

Post Reply

Who is online

Users browsing this forum: ivan, PGUp and 5 guests