"bad light userdata" on AArch64

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
User avatar
Sulunia
Party member
Posts: 202
Joined: Tue Mar 22, 2016 1:10 pm
Location: SRS, Brazil

"bad light userdata" on AArch64

Post by Sulunia » Tue Apr 09, 2019 2:07 pm

Hello folks, long time no see!

So, I've been using a Dragonboard410c SBC from Arrow, and It's pretty neat so far. :o:
But, after installing their latest debian and trying to run love, I got the following error:

Code: Select all

[email protected]:~$ love
Error: bad light userdata pointer
stack traceback:
        [C]: in function 'decode'
        [string "nogame.lua"]:23: in function 'nogame'
        [string "boot.lua"]:308: in function <[string "boot.lua"]:249>
        [C]: in function 'xpcall'
        [string "boot.lua"]:641: in function <[string "boot.lua"]:639>
        [C]: in function 'xpcall'
I've ran glxgears and there is HW acceleration... This is glxinfo output on versions available:

Code: Select all

[email protected]:~$ glxinfo | grep "version"
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
    Max core profile version: 3.1
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL core profile version string: 3.1 Mesa 18.3.2
OpenGL core profile shading language version string: 1.40
OpenGL version string: 3.1 Mesa 18.3.2
OpenGL shading language version string: 1.40
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.3.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
Any ideas? I tried running "LOVE_GRAPHICS_USE_OPENGLES=1 love" but it didn't work either.
Don't check my github! It contains thousands of lines of spaghetti code in many different languages cool software! :neko:
https://github.com/Sulunia

User avatar
CrimsonGuy
Prole
Posts: 48
Joined: Thu Apr 04, 2019 3:32 pm

Re: "bad light userdata" on AArch64

Post by CrimsonGuy » Tue Apr 09, 2019 2:20 pm

Doing some research seems like an issue with Luajit that affects apps that depend on it. You can find some workarounds here.

https://github.com/neovim/neovim/issues/7879

https://github.com/torch/torch7/issues/1035

User avatar
Sulunia
Party member
Posts: 202
Joined: Tue Mar 22, 2016 1:10 pm
Location: SRS, Brazil

Re: "bad light userdata" on AArch64

Post by Sulunia » Tue Apr 09, 2019 2:57 pm

It's a Luajit thing apparently... I think a patch to the source code is required?... :|

@edit
I forgot to check what love version I was trying to run, but I believe it's 0.10.2, since I installed it straight from apt.
I'd have to compile love 11.2 to test this out correctly, but I have no time to do this atm :(
Don't check my github! It contains thousands of lines of spaghetti code in many different languages cool software! :neko:
https://github.com/Sulunia

Post Reply

Who is online

Users browsing this forum: brandcraftiim, NotARaptor and 41 guests