LUBE-demo

Showcase your libraries, tools and other projects that help your fellow love users.
User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

LUBE-demo

Post by bartbes » Wed Mar 04, 2009 9:54 pm

I know it seems like I'm spamming, but this one is the solution to all, it's a combination of everything I have, powered by Updater, so auto-updating via github.

How to use:
  1. Download the distributable below
  2. Run it, and update it the first time you run
  3. Wait for it to finish
  4. Select the application you want to run
Application list:
  • LUBE-IRC (joins the #loveclub channel)
  • LUBE-X
  • NetPong-AIServer
  • NetPong-Client
  • NetPong-Server
NetPong is currently not working, so don't expect anything of it. (Keep in mind it comes from github)

Everything is released under MIT license.

P.S. if you need help setting up Updater with github, just pm me (or talk via IRC), I know how hard it is...

Difference between version 1, 2 and 3: new versions of Updater.
No difference for the content, all are still supported (support for v1 and v2 may break sometime in the future, not planned however).

github URL: http://github.com/bartbes/lube-demo/tree/master
Attachments
lube-demo-distributable-v3.love
Version 2.0 of Updater
(2.64 KiB) Downloaded 199 times
lube-demo-distributable-v2.love
Self-Updating
New version of Updater included (1.5)
(2.42 KiB) Downloaded 143 times
lube-demo-distributable.love
Self-Updating
(2.35 KiB) Downloaded 177 times
Last edited by bartbes on Fri Mar 27, 2009 7:28 pm, edited 3 times in total.

User avatar
mike
Administrator
Posts: 364
Joined: Mon Feb 04, 2008 5:24 pm

Re: LUBE-demo

Post by mike » Fri Mar 06, 2009 10:06 am

Tried to open up LUBE-IRC but received the following error:

Code: Select all

[string "LUBE-IRC/IRC.lua"]:1: module 'LUBE.Client' not found:
	no field package.preload['LUBE.Client']
	no file '.\LUBE\Client.lua'
	no file 'C:\Program Files\LOVE\lua\LUBE\Client.lua'
	no file 'C:\Program Files\LOVE\lua\LUBE\Client\init.lua'
	no file 'C:\Program Files\LOVE\LUBE\Client.lua'
	no file 'C:\Program Files\LOVE\LUBE\Client\init.lua'
	no file '.\LUBE\Client.dll'
	no file 'C:\Program Files\LOVE\LUBE\Client.dll'
	no file 'C:\Program Files\LOVE\loadall.dll'
	no file '.\LUBE.dll'
	no file 'C:\Program Files\LOVE\LUBE.dll'
	no file 'C:\Program Files\LOVE\loadall.dll'
	no file "LUBE.Client" in LOVE game directories.

stack traceback:
	[C]: in function 'require'
	[string "LUBE-IRC/IRC.lua"]:1: in main chunk
	[C]: in function 'include'
	[string "..."]:8: in function <[string "..."]:7>
	(tail call): ?
	[string "..."]:13: in function 'require'
	[string "LUBE-IRC/main.lua"]:5: in main chunk
	[C]: in function 'include'
	[string "..."]:8: in function <[string "..."]:7>
	(tail call): ?
	[string "..."]:13: in function 'require'
	[string "main.orig.lua"]:140: in function 'run'
	[string "main.orig.lua"]:186: in function <[string "main.orig.lua"]:174>
Now posting IN STEREO (where available)

User avatar
Kaze
Party member
Posts: 189
Joined: Sat Jul 19, 2008 4:39 pm
Location: Dublin, Ireland

Re: LUBE-demo

Post by Kaze » Fri Mar 06, 2009 10:47 am

mike wrote:Tried to open up LUBE-IRC but received the following error:

Code: Select all

[string "LUBE-IRC/IRC.lua"]:1: module 'LUBE.Client' not found:
	no field package.preload['LUBE.Client']
	no file '.\LUBE\Client.lua'
	no file 'C:\Program Files\LOVE\lua\LUBE\Client.lua'
	no file 'C:\Program Files\LOVE\lua\LUBE\Client\init.lua'
	no file 'C:\Program Files\LOVE\LUBE\Client.lua'
	no file 'C:\Program Files\LOVE\LUBE\Client\init.lua'
	no file '.\LUBE\Client.dll'
	no file 'C:\Program Files\LOVE\LUBE\Client.dll'
	no file 'C:\Program Files\LOVE\loadall.dll'
	no file '.\LUBE.dll'
	no file 'C:\Program Files\LOVE\LUBE.dll'
	no file 'C:\Program Files\LOVE\loadall.dll'
	no file "LUBE.Client" in LOVE game directories.

stack traceback:
	[C]: in function 'require'
	[string "LUBE-IRC/IRC.lua"]:1: in main chunk
	[C]: in function 'include'
	[string "..."]:8: in function <[string "..."]:7>
	(tail call): ?
	[string "..."]:13: in function 'require'
	[string "LUBE-IRC/main.lua"]:5: in main chunk
	[C]: in function 'include'
	[string "..."]:8: in function <[string "..."]:7>
	(tail call): ?
	[string "..."]:13: in function 'require'
	[string "main.orig.lua"]:140: in function 'run'
	[string "main.orig.lua"]:186: in function <[string "main.orig.lua"]:174>
I got this as well but didn't care enough to tell you.

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LUBE-demo

Post by bartbes » Fri Mar 06, 2009 2:39 pm

I'll fix that when I get home. Is because I used a LUBE version stored in the global lua include dir. Expect update soon.

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LUBE-demo

Post by bartbes » Fri Mar 06, 2009 6:03 pm

Fixed!

Version 2 now available.

User avatar
mike
Administrator
Posts: 364
Joined: Mon Feb 04, 2008 5:24 pm

Re: LUBE-demo

Post by mike » Fri Mar 06, 2009 9:54 pm

Small issues:
  • It CONSUMES resources like a dog.
  • When I tell it that I want to update it just sits there, with no indication that it's doing anything. I always think that it has crashed or something.
Moar:
  • Tried to open up LUBE-IRC, but when I type anything into the chat area it just quits the program with no errors.
Now posting IN STEREO (where available)

User avatar
Neptar
Prole
Posts: 20
Joined: Mon Feb 16, 2009 3:24 am
Location: England

Re: LUBE-demo

Post by Neptar » Sat Mar 07, 2009 1:00 am

Version 3 seems to have killed it. Version 2 was working fine. But now whenever I type anything it crashes out.

Also as mike said, when i first ever updated I thought it had crashed.

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LUBE-demo

Post by bartbes » Sat Mar 07, 2009 6:29 pm

Yes the updating, I am planning an update for Updater (ironic, isn't it?).
And I need some more information about the crash, as mine never crashes.
And it can't be the client shutting down, as there is no auto-shutdown, maybe a linux console output?

EDIT: PunDit checked for me, bug might be windows-only?

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LUBE-demo

Post by bartbes » Sun Mar 08, 2009 12:38 pm

Ok, bug confirmed windows-only.
Change between versions 2 and 3: http://github.com/bartbes/lube-demo/com ... 21dbd45479

This leads me to the conclusion it has to be os.date("%R"), can someone confirm this?

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LUBE-demo

Post by bartbes » Sun Mar 08, 2009 12:57 pm

Was %R, fixed, update available

Post Reply

Who is online

Users browsing this forum: No registered users and 13 guests