Löve Frames - A GUI Library

Showcase your libraries, tools and other projects that help your fellow love users.
scheda
Prole
Posts: 1
Joined: Tue Dec 30, 2014 9:45 pm

Re: Löve Frames - A GUI Library

Post by scheda » Tue Dec 30, 2014 9:47 pm

vekenti wrote:Make sure you are doing require("path.to.loveframes") and not require("path/to/loveframes").
Wow didnt know that would make a difference o.o thanks

-Edit- Got a different error now,says that

Code: Select all

attempt to index global 'loveframes' (a nil value)
in function 'load'
-Edit -

forgot to do loveframes = require(blabla) fixed now[/quote]

Can you post your code for this? I'm having the same trouble but can't figure it out. (Still VERY new to Love2d)

Xardas
Prole
Posts: 4
Joined: Wed Dec 31, 2014 2:03 pm

Re: Löve Frames - A GUI Library

Post by Xardas » Wed Dec 31, 2014 2:18 pm

I would love to use this library, but when I include it in my main.lua, it seems to conflict with other libraries like Simple-Tiled and hump. I get strange errors when using either of those two libraries in conjunction with LoveFrames.

This is the top of my main.lua:

Code: Select all

local loveframes = require "LoveFrames-master"
local sti = require "Simple-Tiled-Implementation-master"
local timer = require "hump-master.timer"
Do you happen to know how I can resolve this issue?
Thanks

User avatar
Doctory
Party member
Posts: 441
Joined: Fri Dec 27, 2013 4:53 pm

Re: Löve Frames - A GUI Library

Post by Doctory » Wed Dec 31, 2014 5:08 pm

@Xardas
try renaming the folders
i know it might not work, but still
"This is what videogames should be like; they should have meaning and triple machine guns"
- Jan Willem Nijman, 2013
github

Xardas
Prole
Posts: 4
Joined: Wed Dec 31, 2014 2:03 pm

Re: Löve Frames - A GUI Library

Post by Xardas » Wed Dec 31, 2014 5:58 pm

Hm no, that didn't help unfortunately.

tommyroyall
Prole
Posts: 14
Joined: Fri Nov 02, 2012 12:47 am

Re: Löve Frames - A GUI Library

Post by tommyroyall » Thu Jan 01, 2015 2:24 am

Hello! I am running Löve Frames inside of a Hump gamestate and it seems not to be playing nicely, giving me this error code:

Edit: I reran it after rebooting Zerobrane, and now it's giving me this:

Code: Select all

Program starting as '"C:\Program Files\love\love.exe" "C:\Users\Tommy\Desktop\ReindeerSimulator12-30-14" -debug'.
Program 'love.exe' started in 'C:\Users\Tommy\Desktop\ReindeerSimulator12-30-14' (pid: 4940).
Total lines in the project: 1454
Error: libs/loveframes/libraries/templates.lua:99: attempt to index local 'base' (a nil value)
stack traceback:
	libs/loveframes/libraries/templates.lua:99: in function 'Register'
	libs/loveframes/init.lua:443: in main chunk
	[C]: in function 'require'
	main.lua:88: in main chunk
	[C]: in function 'require'
	[string "boot.lua"]:360: in function <[string "boot.lua"]:241>
	[C]: in function 'xpcall'
Program completed in 36.95 seconds (pid: 4940).
However I'll keep the old one here:

Code: Select all

Program starting as '"C:\Program Files\love\love.exe" "C:\Users\Tommy\Desktop\ReindeerSimulator12-30-14" -debug'.
Program 'love.exe' started in 'C:\Users\Tommy\Desktop\ReindeerSimulator12-30-14' (pid: 4932).
Total lines in the project: 1453
Error: libs/loveframes/objects/base.lua:11: attempt to call field 'NewObject' (a nil value)
stack traceback:
	libs/loveframes/objects/base.lua:11: in main chunk
	[C]: in function 'require'
	libs/loveframes/init.lua:435: in main chunk
	[C]: in function 'require'
	main.lua:87: in main chunk
	[C]: in function 'require'
	[string "boot.lua"]:360: in function <[string "boot.lua"]:241>
	[C]: in function 'xpcall'
Program completed in 2.18 seconds (pid: 4932).
If code is wanted, I'll upload it for you, but which source should I use? Sorry for the question, I'm new to the forum.

User avatar
Nikolai Resokav
Party member
Posts: 140
Joined: Wed Apr 28, 2010 12:51 am
Location: United States

Re: Löve Frames - A GUI Library

Post by Nikolai Resokav » Thu Jan 01, 2015 4:03 am

scheda wrote:Can you post your code for this? I'm having the same trouble but can't figure it out. (Still VERY new to Love2d)
What kind of issue are you having?
Xardas wrote:I would love to use this library, but when I include it in my main.lua, it seems to conflict with other libraries like Simple-Tiled and hump. I get strange errors when using either of those two libraries in conjunction with LoveFrames.

This is the top of my main.lua:

Code: Select all

local loveframes = require "LoveFrames-master"
local sti = require "Simple-Tiled-Implementation-master"
local timer = require "hump-master.timer"
Do you happen to know how I can resolve this issue?
Thanks
Can you post the errors you are getting?
tommyroyall wrote:Hello! I am running Löve Frames inside of a Hump gamestate and it seems not to be playing nicely, giving me this error code:
Can post a .love of your program so that I can take a look?

Xardas
Prole
Posts: 4
Joined: Wed Dec 31, 2014 2:03 pm

Re: Löve Frames - A GUI Library

Post by Xardas » Thu Jan 01, 2015 9:43 am

Image

This has to do with me calling

Code: Select all

currentMap = sti.new("maps/desert")
in love.load(). Btw, this works just fine if I don't use LoveFrames.

If I comment it out or remove that line, I get the next error:

Image

This is due to using a timer from HUMP's timer module:

Code: Select all

timer.tween(1, label, {y=40}, 'out-cubic')

User avatar
Nikolai Resokav
Party member
Posts: 140
Joined: Wed Apr 28, 2010 12:51 am
Location: United States

Re: Löve Frames - A GUI Library

Post by Nikolai Resokav » Thu Jan 01, 2015 10:32 am

Xardas wrote:Image

This has to do with me calling

Code: Select all

currentMap = sti.new("maps/desert")
in love.load(). Btw, this works just fine if I don't use LoveFrames.

If I comment it out or remove that line, I get the next error:

Image

This is due to using a timer from HUMP's timer module:

Code: Select all

timer.tween(1, label, {y=40}, 'out-cubic')
I think the utf8 library that Love Frames uses might be causing the issue. Try removing the utf8 require code in init.lua and see if that fixes any of the issues.

Xardas
Prole
Posts: 4
Joined: Wed Dec 31, 2014 2:03 pm

Re: Löve Frames - A GUI Library

Post by Xardas » Thu Jan 01, 2015 11:54 am

Indeed, that was the issue!

I just set

Code: Select all

loveframes.config["ENABLE_UTF8_SUPPORT"] = false
Thanks, now there are no problems :)

tommyroyall
Prole
Posts: 14
Joined: Fri Nov 02, 2012 12:47 am

Re: Löve Frames - A GUI Library

Post by tommyroyall » Thu Jan 01, 2015 10:17 pm

Thank you so much for looking into this Nikolai! Loveframes has been used in numerous past projects and proves vital for this one, and the file that it is called in from is main.lua, though the one that is giving me issues would be CabinGamestate.lua. At the same time, the first one that is opened is MenuGamestate.lua. Here is the download link to the .love file, http://www.mediafire.com/download/eyil1 ... 30-14.love

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests