Page 34 of 38

Re: Löve Frames - A GUI Library

Posted: Sun Jan 17, 2016 10:27 pm
by zorg
murks wrote:Does this library work with Löve 0.10.0?
Literally in the first post: :3
Nikolai Resokav wrote:Note: Löve Frames is only compatible with versions 0.8.0 and 0.9.0 of LÖVE.
Edit: On the previous page:
Nikolai Resokav wrote:...I'm currently not developing Love Frames anymore. However, I am currently working on a new UI library to replace Love Frames which will have support for object resizing and what not.

Re: Löve Frames - A GUI Library

Posted: Sun Jan 17, 2016 10:48 pm
by murks
Ok, thanks.
I am rather certain that post was last updated well before the release of löve 0.10.0 so I thought the post might be outdated.

Re: Löve Frames - A GUI Library

Posted: Sun Jan 17, 2016 11:44 pm
by bobbyjones
murks wrote:Ok, thanks.
I am rather certain that post was last updated well before the release of löve 0.10.0 so I thought the post might be outdated.
There is a fork by someone that updates loveframes. Idk where it's at though. Maybe ask on irc to see who's it is.

Re: Löve Frames - A GUI Library

Posted: Mon Jan 18, 2016 8:36 am
by Fenrir
To make it work with 0.10.0, you just need to update the stencil code to the new system, apart from that it works without problems!

Re: Löve Frames - A GUI Library

Posted: Wed Jan 20, 2016 1:46 pm
by Dev
bobbyjones wrote:
murks wrote:Ok, thanks.
I am rather certain that post was last updated well before the release of löve 0.10.0 so I thought the post might be outdated.
There is a fork by someone that updates loveframes. Idk where it's at though. Maybe ask on irc to see who's it is.
This is the fork right here. The stencil system was updated. Not sure if anything else is broken though. But Fenrir said that's the only problem so there you go.

https://github.com/cyborgize/LoveFrames

Re: Löve Frames - A GUI Library

Posted: Wed Jan 20, 2016 2:27 pm
by Jack5500
Kenny, are you going to share any information on your new library in the near future? Really looking forward to it

Re: Löve Frames - A GUI Library

Posted: Thu Jan 28, 2016 7:59 pm
by meffcio
Dev wrote:
bobbyjones wrote:
murks wrote:Ok, thanks.
I am rather certain that post was last updated well before the release of löve 0.10.0 so I thought the post might be outdated.
There is a fork by someone that updates loveframes. Idk where it's at though. Maybe ask on irc to see who's it is.
This is the fork right here. The stencil system was updated. Not sure if anything else is broken though. But Fenrir said that's the only problem so there you go.

https://github.com/cyborgize/LoveFrames
I took your love-frames demo 0.10.0 fork and provided it with 0.10.0 loveframes fork, and it doesn't work. It runs ok, but after clicking anything:
loveframes.PNG
loveframes.PNG (35.39 KiB) Viewed 3375 times

Re: Löve Frames - A GUI Library

Posted: Sun Jan 31, 2016 7:48 pm
by Kenny Shields
Jack5500 wrote:Kenny, are you going to share any information on your new library in the near future? Really looking forward to it
I plan on releasing a public alpha version soon, though I can't make any promises of when that will be. If you'd like more information feel free to send me an email or private message.

Re: Löve Frames - A GUI Library

Posted: Tue Mar 15, 2016 10:30 pm
by zell2002
Fenrir wrote:To make it work with 0.10.0, you just need to update the stencil code to the new system, apart from that it works without problems!
what do you mean sorry ?

I get an issue here :
love.graphics.setStencilTest(true)

I can see the function needs a string and then number, ie( "greater", 0) - however I dont understand what it is doing at this point and thus what the correct fix is, any pointers?

Re: Löve Frames - A GUI Library

Posted: Sun Apr 03, 2016 12:53 am
by yarlesp
neither the tooltips or the menus are working in this. i'm using love 0.9.0.

heres the code that creates the popup menu i want. it's called from love.mousepressed and moving this code to that function doesn't do anything

(that last line is for me, it prints a string on-screen. the string prints "menu x y" whenever i right-click, so i know all the code is being executed and the menu exists)

Code: Select all

function game.popup_menu(x, y)
  if not loveframes.util.GetHoverObject() then
    local bldgmenu = loveframes.Create("menu")
    bldgmenu:AddOption("Details", false, function() end)
    bldgmenu:AddOption("Demolish", false, function() end)
    bldgmenu:SetPos(x, y):SetVisible(true)
    util.add_debug_string(bldgmenu:GetType().." "..bldgmenu:GetX().." "..bldgmenu:GetY())
  end
end
and here's the definition of my gui. that last tooltip i define for the 'elec' button never shows up when i hover over the elec button.

for the record the first part of the gui, all the way down to the tooltip, shows up and seems to function fine. its just these two elements im having problems with. thanks for any help anyone can provide.

Code: Select all

-- load the map and gui
function game.load()
  loveframes.SetState("gamegui")
  
  local sidebar = loveframes.Create("frame")
  sidebar:SetName("CAnyon")
  sidebar:SetSize(110, 600)
  sidebar:SetState("gamegui")
  sidebar:SetDraggable(false):ShowCloseButton(false):SetAlwaysOnTop(true)
  
  local elec = loveframes.Create("button", sidebar):SetSize(20, 20):SetPos(5, 30):SetText("!")
  local water = loveframes.Create("button", sidebar):SetSize(20, 20):SetPos(30, 30):SetText("W")
  local weapons = loveframes.Create("button", sidebar):SetSize(20, 20):SetPos(55, 30):SetText(">")
  local food = loveframes.Create("button", sidebar):SetSize(20, 20):SetPos(80, 30):SetText("F")
  
  local elec_tooltip = loveframes.Create("tooltip")
  elec_tooltip:SetObject(elec):SetText("Electric grid mapmode")
end