LOVE memory using

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
rmn_rmn
Prole
Posts: 21
Joined: Thu Jul 08, 2010 3:04 am

LOVE memory using

Post by rmn_rmn » Fri Aug 27, 2010 5:07 am

Hi everybody!
I face a strange behavior of my game: sometimes it uses 160 mb, sometimes only 5 mb memory. What is the reason of such a difference? How can I force it to use 5 mb always? The game is small and 5 mb is it's reasonable usage.

User avatar
Robin
The Omniscient
Posts: 6506
Joined: Fri Feb 20, 2009 4:29 pm
Location: The Netherlands
Contact:

Re: LOVE memory using

Post by Robin » Fri Aug 27, 2010 7:49 am

That is a very interesting question and we might have an answer if we could see the source of that game. :)
Help us help you: attach a .love.

rmn_rmn
Prole
Posts: 21
Joined: Thu Jul 08, 2010 3:04 am

Re: LOVE memory using

Post by rmn_rmn » Fri Aug 27, 2010 8:03 am

Thanks, Robin. I should have uploaded it before. It is 70 percent ready at the moment, but should be enough to determine the source of the problem, I guess.
(In particular, online mode and sometimes artificial int. don't work properly.)
Attachments
game.love
The source file of the game
(2.66 MiB) Downloaded 84 times

User avatar
Taehl
Dreaming in associative arrays
Posts: 1024
Joined: Mon Jan 11, 2010 5:07 am
Location: CA, USA
Contact:

Re: LOVE memory using

Post by Taehl » Mon Aug 30, 2010 5:27 am

My best guess (having not looked at the code) would be runaway data. A "sorcerer's apprentice mode" bug. You mentioned AI, which I would consider the prime suspect. For example: Path-finding. You have it grow a table of paths until a suitable path is found. Well, if it can't find a path, the path table could potentially grow and grow and grow until...

Image
Earliest Love2D supporter who can't Love anymore. Let me disable pixel shaders if I don't use them, dammit!
Lenovo Thinkpad X60 Tablet, built like a tank. But not fancy enough for Love2D 0.10.0+.

Zeromuse
Prole
Posts: 1
Joined: Fri Aug 13, 2010 5:05 am

Re: LOVE memory using

Post by Zeromuse » Mon Aug 30, 2010 6:11 am

Just throwin stuff out there but I read something in the audio snippet (btw I'm new to LOVE)
http://love2d.org/wiki/Tutorial:Audio

If it is that then something having to do with the difference between static and steam use of your audio files. Like I said though, just throwin it out there.

User avatar
Lap
Party member
Posts: 256
Joined: Fri Apr 30, 2010 3:46 pm

Re: LOVE memory using

Post by Lap » Mon Aug 30, 2010 10:20 am

Didn't we already have the "Wow!" joke last month?

User avatar
Taehl
Dreaming in associative arrays
Posts: 1024
Joined: Mon Jan 11, 2010 5:07 am
Location: CA, USA
Contact:

Re: LOVE memory using

Post by Taehl » Mon Aug 30, 2010 10:55 am

Two months ago. :P And hush, it was appropriate, and I'll probably never get to use that image again.
Earliest Love2D supporter who can't Love anymore. Let me disable pixel shaders if I don't use them, dammit!
Lenovo Thinkpad X60 Tablet, built like a tank. But not fancy enough for Love2D 0.10.0+.

rmn_rmn
Prole
Posts: 21
Joined: Thu Jul 08, 2010 3:04 am

Re: LOVE memory using

Post by rmn_rmn » Mon Aug 30, 2010 4:44 pm

Hmm, I noticed the difference before the game mode, just running it and staying in the main menu. So the slow ai doesn't seem to be the reason.

Post Reply

Who is online

Users browsing this forum: slime and 5 guests