LÖVE 0.7.0 beta released

General discussion about LÖVE, Lua, game development, puns, and unicorns.
Locked
User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

LÖVE 0.7.0 beta released

Post by bartbes » Sat Sep 18, 2010 6:58 pm

Here it is, the beta of LÖVE 0.7.0 Game Slave.

What is new:
changes.txt wrote: LOVE 0.7.0 [Game Slave]
-----------------------

* Added love.thread.
* Added love.font.
* Added love.graphics.Framebuffer.
* Added Source:play, Source:pause, etc.
* Added Source:isStatic().
* Added get/setPosition, get/setVelocity, and get/setDirection to Source.
* Added get/setGroupIndex to CircleShape and PolygonShape.
* Added Font:getWrap.
* Added identity field to love.conf.
* Added love.quit callback.
* Added love.focus callback.
* Added extra meter parameter to love.physics.newWorld.
* Added love.graphics.setIcon.
* Added way to make the window desktop resolution.
* Added subtractive and multiplicative blend modes.
* Added body:getAllowSleeping.
* Added shape:getBody.
* Added love.filesystem.FileData for public usage.

* Fixed the debug module not being an upvalue of the error handlers. (you can now override debug)
* Fixed some cases when love.audio.pause and friends, were acting on everything, not just the passed Source.
* Fixed setFixedRotation enabling other flags.
* Fixed a bug in the loader (for require).
* Fixed ParticleSystem::setSprite not retaining the new image.
* Fixed setMode removing images settings (wrapping, filters).
* Fixed shape:getBody, it's now exposed for LÖVE usage.
* Fixed DistanceJoint:getType() returning "circle" - it now returns "distance".
* Fixed SpriteBatches being unaffected by setColor
* Fixed the audio bug.
* Fixed invalid FSAA values crashing LÖVE.
* Fixed a bunch of compiler warnings.
* Fixed OS X not properly using UTIs for .love files.
* Fixed the modplug decoder not properly handeling files that fail to load.
* Fixed a memory leak in setFont.

* Changed fonts, they're now po2 safe.
* Changed the traceback in the error screen.
* Changed font origin to top-left.

* Removed font functions from love.graphics.
What is left to do:
  • Some bugfixes to love.font
  • Testing
  • Finishing the no-game screen
Downloads: (we're still building some packages, be patient) Alternative ways of installing:
  • PPA: ppa:bartbes/love-unstable (will contain other unstable builds in the future, beware)
Last edited by thelinx on Sat Oct 23, 2010 11:20 pm, edited 2 times in total.
Reason: Added link to windows build.

pekka
Party member
Posts: 206
Joined: Thu Jan 07, 2010 6:48 am
Location: Oulu, Finland
Contact:

Re: LÖVE 0.7.0 beta released

Post by pekka » Sat Sep 18, 2010 7:04 pm

Um, why do the debs' file names begin with love_0.6.2 and not _0.7.0?

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LÖVE 0.7.0 beta released

Post by bartbes » Sat Sep 18, 2010 7:09 pm

Not because I screwed up, that's because it would only create problems with apt if I were to name it 0.7.0, also, it is not 0.7.0 yet. They are however the right build.

pekka
Party member
Posts: 206
Joined: Thu Jan 07, 2010 6:48 am
Location: Oulu, Finland
Contact:

Re: LÖVE 0.7.0 beta released

Post by pekka » Sat Sep 18, 2010 7:43 pm

I built the Linux source successfully on Ubuntu 10.04 LTS with an AMD 64-bit processor. It runs. I saw the new "no game" screen.

It also runs the demos from Windows version 0.6.2, except that there are bunch of complaints about some audio service thingy. They don't prevent the sinescroller or passsingclouds from playing music, though. It prints this on the console:

Code: Select all

bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
AL lib: ALc.c:1818: alcCloseDevice(): deleting 32 Buffer(s)

I can do more testing tomorrow. I've seen the OpenAL library complain the same in other circumstances, so I suppose that's not a problem. I'll look at where that other complaint is coming from, though.

(Yeah, the no.love demo also looks wonky, because you changed the font origin. But we knew that'd happen.)

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LÖVE 0.7.0 beta released

Post by bartbes » Sat Sep 18, 2010 7:47 pm

Yeah, sorry for the lack of packages, launchpad delayed the amd64 builds for 2 hours :S, the audio messages are related to bluez-alsa, and are nothing to worry about, basically it complains about there not being bluetooth audio devices.. yeah, like you'd need those.

User avatar
Tesselode
Party member
Posts: 555
Joined: Fri Jul 23, 2010 7:55 pm

Re: LÖVE 0.7.0 beta released

Post by Tesselode » Sat Sep 18, 2010 8:15 pm

GDebi says this is an older version than 0.6.2.

User avatar
Robin
The Omniscient
Posts: 6506
Joined: Fri Feb 20, 2009 4:29 pm
Location: The Netherlands
Contact:

Re: LÖVE 0.7.0 beta released

Post by Robin » Sat Sep 18, 2010 8:34 pm

Woooh!

Also, wouldn't 0.6.9 be more appropriate than 0.6.2 as a name for the 0.7.0 beta? Since it's a whole frakkin' different release.
Help us help you: attach a .love.

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LÖVE 0.7.0 beta released

Post by bartbes » Sat Sep 18, 2010 9:14 pm

It's 0.6.2r<revnum>!

@Tesselode: Yeah, sorry, that was because someone else (rude!) failed to give the old 0.6.2 package a good version number.

User avatar
nevon
Commander of the Circuloids
Posts: 938
Joined: Thu Feb 14, 2008 8:25 pm
Location: Stockholm, Sweden
Contact:

Re: LÖVE 0.7.0 beta released

Post by nevon » Sat Sep 18, 2010 10:04 pm

pekka wrote:It also runs the demos from Windows version 0.6.2, except that there are bunch of complaints about some audio service thingy.
I used to have that before as well. It doesn't affect anything, but removing the package bluez-alsa also removes those error messages.

User avatar
Jasoco
Inner party member
Posts: 3650
Joined: Mon Jun 22, 2009 9:35 am
Location: Pennsylvania, USA
Contact:

Re: LÖVE 0.7.0 beta released

Post by Jasoco » Sat Sep 18, 2010 11:43 pm

I said it before, I'll reiterate.

Yaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaay!

No problems I've found. Just have to fix all the text offsets but really nice! Can't wait to explore the new stuff more.

Locked

Who is online

Users browsing this forum: No registered users and 4 guests