LOVE2D debugging trouble with debug.debug()

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
triangle345
Prole
Posts: 3
Joined: Tue Jan 16, 2018 11:52 am

LOVE2D debugging trouble with debug.debug()

Post by triangle345 » Mon Apr 16, 2018 10:52 am

I tried to use the Lua debugging framework mentioned here:
https://love2d.org/wiki/Debug

I simply open a windows 10 cmd console and run my love app using --console flag. It does give me a "lua>" prompt but the UI is unusable. It keeps switching between "lua>" and regular cmd prompt for some reason. Anyone have luck with using lua debugging tools on their LOVE2D games?

User avatar
pgimeno
Party member
Posts: 1154
Joined: Sun Oct 18, 2015 2:58 pm

Re: LOVE2D debugging trouble with debug.debug()

Post by pgimeno » Mon Apr 16, 2018 11:08 am

I've used lovebird in past, https://github.com/rxi/lovebird which gives you a web interface.
Thrust II Reloaded - GifLoad for Löve - GSpöt GUI - My NotABug.org repositories
The Microsoft Github repositories I had have been closed after the acquisition announcement and will be removed in the near future.

User avatar
zorg
Party member
Posts: 2308
Joined: Thu Dec 13, 2012 2:55 pm
Location: Absurdistan, Hungary
Contact:

Re: LOVE2D debugging trouble with debug.debug()

Post by zorg » Mon Apr 16, 2018 11:18 am

I wrote my own console interface using love.thread and io functions (so they don't block) which isn't exactly a debug interface, but one could potentially code enough functionality to have it act like one. :3
Me and my stuff :3True Neutral Aspirant. Why, yes, i do indeed enjoy sarcastically correcting others when they make the most blatant of spelling mistakes. No bullying or trolling the innocent tho.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests