Could LÖVE run on a Raspberry Pi 2B WITH x11?

General discussion about LÖVE, Lua, game development, puns, and unicorns.
User avatar
molul
Party member
Posts: 232
Joined: Sun Feb 05, 2012 6:51 pm
Location: Valencia, Spain

Re: Could LÖVE run on a Raspberry Pi 2B WITH x11?

Post by molul » Thu Jun 14, 2018 2:58 pm

Thanks, MachineCode. I think I'll have to go for GLES, if I want the LÖVE build to work on the RK3066.

EDIT:
Well the Pi arrived today, got LÖVE built, copied the binaries and dependencies to the Rockchip board... and got a Segmentation fault when trying to run LÖVE from there.

I'm not giving up yet, though. LÖVE on the Raspberry Pi was running really bad, which means it's not the GLES version.

Would anyone share whatever useful info on how to build LÖVE-GLES?

User avatar
Nixola
Inner party member
Posts: 1920
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: Could LÖVE run on a Raspberry Pi 2B WITH x11?

Post by Nixola » Thu Jun 14, 2018 3:08 pm

Try setting the LOVE_GRAPHICS_USE_OPENGLES environment variable to 1 before launching LÖVE; that should be all there is to it.
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

User avatar
molul
Party member
Posts: 232
Joined: Sun Feb 05, 2012 6:51 pm
Location: Valencia, Spain

Re: Could LÖVE run on a Raspberry Pi 2B WITH x11?

Post by molul » Thu Jun 14, 2018 3:12 pm

I just tried a minute ago. Segmentation fault again -_-

On the Raspberry, however, I can see the Mysterious Mysteries demo better (not smooth at all, but without GLES I couldn't see the clouds and the duck, just white shapes over blue background).

Is there anything else I could try?

User avatar
Nixola
Inner party member
Posts: 1920
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: Could LÖVE run on a Raspberry Pi 2B WITH x11?

Post by Nixola » Thu Jun 14, 2018 3:31 pm

I guess you could try building LÖVE without stripping the debug symbols (add a "-g" flag to g++ iirc? You'll possibly have to edit the makefile), then debug LÖVE on the device it segfaults on by running "gdb love" and getting a backtrace when it segfaults; I'm afraid I can't be much more of help as I do not know or own the board you have and I'm a bit rusty with this stuff, but I guess other people on here should be able to help.
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

User avatar
molul
Party member
Posts: 232
Joined: Sun Feb 05, 2012 6:51 pm
Location: Valencia, Spain

Re: Could LÖVE run on a Raspberry Pi 2B WITH x11?

Post by molul » Mon Jun 18, 2018 5:49 am

Thanks, it's worth a try :) I don't know where to add the -g parameter, so I'l have to wait for someone who knows to shed some light.

[EDIT]
Hmmm. I tried starting from scratch, this time copying dependencies one by one (yesterday, at some point, I just copied a lot of libraries to the love executable directory), and after copying the first 5 or 6 dependencies I was asked for, I didn't get a Segmentation fault but "Error: Could not initialize SDL video subsystem (No available video device)".

I'll try to get SDL2 built now and hope for the best (although I guess I'll be asked to copy more dependencies later, resulting in the same Segmentation fault).
Last edited by molul on Mon Jun 18, 2018 6:51 am, edited 1 time in total.

User avatar
Nixola
Inner party member
Posts: 1920
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: Could LÖVE run on a Raspberry Pi 2B WITH x11?

Post by Nixola » Mon Jun 18, 2018 6:47 am

I think you edited the wrong post
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

User avatar
molul
Party member
Posts: 232
Joined: Sun Feb 05, 2012 6:51 pm
Location: Valencia, Spain

Re: Could LÖVE run on a Raspberry Pi 2B WITH x11?

Post by molul » Mon Jun 18, 2018 6:51 am

I did -_-U Thanks! Gosh, I need some sleep.

User avatar
molul
Party member
Posts: 232
Joined: Sun Feb 05, 2012 6:51 pm
Location: Valencia, Spain

Re: Could LÖVE run on a Raspberry Pi 2B WITH x11?

Post by molul » Fri Jun 22, 2018 6:40 pm

Well, I was lucky enough to have a friend that was able to get LÖVE running on the Rockchip RK3066 :D

I'm afraid I can''t say what he did because he spent three full days modifying LÖVE's source and many of the dependencies, and I understood nearly nothing :(

So I can say this works, but it takes a true expert to do it.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests