Help, I upgraded to 11.1 and now everything's fucked

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
TheHUG
Prole
Posts: 9
Joined: Sun Apr 01, 2018 4:21 pm

Help, I upgraded to 11.1 and now everything's fucked

Post by TheHUG » Tue Jul 10, 2018 12:49 pm

Hi, sorry if this is a silly question, I'm quite new to love2d.

I was running 0.10.2 (which I installed quite soon before 11 was reased), and I decided to upgrade and adapt my game so it would be compatible. Once I did this, trying to run love resulted in the error:
love: error while loading shared libraries: liblove-11.1.so: cannot open shared object file: No such file or directory
I see in the software center that love is not installed there (I uninstalled love 0.10.2 before installing 11.1), so I decide to install it there via GUI as well (which I guess is responsible for the following?)
So I find liblove-11.1.so hidden in /snap, which certainly wasn't how 0.10.2 was stored, figure out I can run love with love2d instead of love. This is a little inconvenient for love-minor-mode on emacs, but I guess I can make it work (just aliasing doesn't fix it). but ok, I could just fix that within the .el itself. Biggest problem is that now love2d can't find the libraries I had placed in it's path for usage (which worked fine in 0.10.2)
e.g.
[...]
no file '/usr/share/lua/5.1/monocle/init.lua'
[...]
Which is a file that definitely exists, and that lua5.1 can find by itself.

When lua 0.10.2 just worked that was nice. What's up with all the hassle for 11.1?

at this point I'd be happy just to downgrade back to a working 0.10.2, but can't find an option for that either (love=0.10.2 ... Version '0.10.2' for 'love' was not found).

Any advice,is appreciated.
TheHUG

User avatar
bartbes
Sex machine
Posts: 4942
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: Help, I upgraded to 11.1 and now everything's fucked

Post by bartbes » Tue Jul 10, 2018 5:13 pm

Okay, let's do this one by one..
TheHUG wrote:
Tue Jul 10, 2018 12:49 pm
I decided to upgrade and adapt my game so it would be compatible. Once I did this, trying to run love resulted in the error:
love: error while loading shared libraries: liblove-11.1.so: cannot open shared object file: No such file or directory
I'm guessing you're running ubuntu (supported by what's ahead). It looks like you only updated the love package, but haven't updated the liblove package. The easiest and smoothest way to rectify this is by running a system update as normal.
TheHUG wrote:
Tue Jul 10, 2018 12:49 pm
I see in the software center that love is not installed there (I uninstalled love 0.10.2 before installing 11.1), so I decide to install it there via GUI as well (which I guess is responsible for the following?)
Surprising, but I'm fairly sure it explains the following because...
TheHUG wrote:
Tue Jul 10, 2018 12:49 pm
So I find liblove-11.1.so hidden in /snap, which certainly wasn't how 0.10.2 was stored,
It seems to have installed a snap instead! I'm not sure which snap it is, or where it came from, but here we are.
TheHUG wrote:
Tue Jul 10, 2018 12:49 pm
Biggest problem is that now love2d can't find the libraries I had placed in it's path for usage (which worked fine in 0.10.2)
e.g.
[...]
no file '/usr/share/lua/5.1/monocle/init.lua'
[...]
Which is a file that definitely exists, and that lua5.1 can find by itself.
Well, that's both the advantage and disadvantage of snaps: they are sandboxed. So it can't actually access your system-installed lua libraries.
TheHUG wrote:
Tue Jul 10, 2018 12:49 pm
Any advice,is appreciated.
My advice: remove the snap, update your system to install the latest version of liblove, and enjoy.

User avatar
raidho36
Party member
Posts: 1685
Joined: Mon Jun 17, 2013 12:00 pm

Re: Help, I upgraded to 11.1 and now everything's fucked

Post by raidho36 » Tue Jul 10, 2018 9:53 pm

You should probably use a PPA, the version in the official repo is outdated.

TheHUG
Prole
Posts: 9
Joined: Sun Apr 01, 2018 4:21 pm

Re: Help, I upgraded to 11.1 and now everything's fucked

Post by TheHUG » Wed Jul 11, 2018 9:27 am

Thanks, I managed a workaround for now by adding the snap's /share/lib file to my LD_LIBRARY_PATH. I'll try a system update and see if that fixes it all.

Thanks for the reply raidho, I think I am using the PPA, I added it with:
sudo add-apt-repository ppa:bartbes/love-stable
sudo apt-get update
and the love version I have is labelled as 11.1ppa1

Post Reply

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 12 guests