I can't play to game using an old version of Löve

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
Pordrack
Prole
Posts: 4
Joined: Tue Sep 04, 2018 5:23 pm

I can't play to game using an old version of Löve

Post by Pordrack » Tue Sep 04, 2018 5:30 pm

Hi ! I tried to play at some game using the 0.9.2 , 0.10.2 or other older version of Löve but it juste crash , and crash again , I haven't find any link to download older version of Löve , I don't know if it's normal or not. Thanks to anyone who's reading this, goodbye .

PS : Sorry about my English , I'm still learning

User avatar
Drakkahn
Prole
Posts: 24
Joined: Sat Jan 17, 2015 11:09 pm

Re: I can't play to game using an old version of Löve

Post by Drakkahn » Wed Sep 05, 2018 4:00 am

It's completely normal to not be able to play older games with the newer versions of love. It's because the api changes through the versions. Here's a link to a list of the older versions: https://bitbucket.org/rude/love/downloads/

Pordrack
Prole
Posts: 4
Joined: Tue Sep 04, 2018 5:23 pm

Re: I can't play to game using an old version of Löve

Post by Pordrack » Sat Sep 15, 2018 12:27 pm

Thanks for your help but Ubuntu does'nt let me install an older version because of my newer version of Löve. :(

User avatar
pgimeno
Party member
Posts: 1337
Joined: Sun Oct 18, 2015 2:58 pm

Re: I can't play to game using an old version of Löve

Post by pgimeno » Sat Sep 15, 2018 2:34 pm

What I do is compiling it as a static binary. That lets me have several executables (one for each version) that don't conflict with each other. It's quite some work to compile them all, but you only do that once. Or you can just compile the version you want to. There are compilation instructions and a list of dependencies on the main page: https://bitbucket.org/rude/love

To compile as static, write: ./configure --enable-static --disable-shared

The executable usually goes to src/.libs/ and you can copy it to /usr/local/bin/ with some other name.
Thrust II Reloaded - GifLoad for Löve - GSpöt GUI - My NotABug.org repositories - portland (mobile orientation)
The MS-Github repositories I had have been closed after the acquisition announcement and will be removed in the near future.

Pordrack
Prole
Posts: 4
Joined: Tue Sep 04, 2018 5:23 pm

Re: I can't play to game using an old version of Löve

Post by Pordrack » Sun Sep 16, 2018 8:01 pm

Hey , thanks for your answer , I compiled love 0.10.1 with your command but I can't find the executable , theres no .lib file , but i've a lot of .Plo with "# dummy" written in all of them.

User avatar
pgimeno
Party member
Posts: 1337
Joined: Sun Oct 18, 2015 2:58 pm

Re: I can't play to game using an old version of Löve

Post by pgimeno » Sun Sep 16, 2018 11:13 pm

configure just configures it, you need to run make to actually compile it. Not sure if that was the issue.

Also, I was wrong. The love executable goes in src/, not src/.libs/ but in any case, the .libs directory is hidden (because it starts with a dot), you need to request it explicitly or tell your filesystem browser to show hidden files.
Thrust II Reloaded - GifLoad for Löve - GSpöt GUI - My NotABug.org repositories - portland (mobile orientation)
The MS-Github repositories I had have been closed after the acquisition announcement and will be removed in the near future.

Pordrack
Prole
Posts: 4
Joined: Tue Sep 04, 2018 5:23 pm

Re: I can't play to game using an old version of Löve

Post by Pordrack » Tue Sep 18, 2018 7:05 pm

Thanks a lot , it worked fine :) Now I can play to all games made with love .

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests