Is love-android updated to be compatible with Android API level 26?

Discuss any ports of LÖVE to different platforms.
Post Reply
Pkill-9
Prole
Posts: 4
Joined: Sat Sep 15, 2018 1:49 pm

Is love-android updated to be compatible with Android API level 26?

Post by Pkill-9 » Thu Oct 11, 2018 4:51 pm

The page for building a game APK using APKTool (https://love2d.org/wiki/Game_Distribution/APKTool) says at the top:
FIXME: This method is obsolete and shouldn't be used! New guide is needed if you plan distributing your game to Play Store. Google announces that all apps in Play Store must be compatible with API level 26, which can't be satisfied because LOVE APK limitation at the moment.
Has it been updated for API level 26?

Pebsie
Party member
Posts: 143
Joined: Mon Nov 11, 2013 12:35 am
Location: Lincoln, United Kingdom
Contact:

Re: Is love-android updated to be compatible with Android API level 26?

Post by Pebsie » Wed Oct 31, 2018 11:15 am

As far as I'm aware love-android hasn't even been updated to 11.1 yet. Sad times, but shit happens.
Website: http://peb.si
Twitter: @Pebsiee http://twitter.com/pebsiee
Steam: pebsie

User avatar
MissDanish
Citizen
Posts: 64
Joined: Wed Mar 07, 2018 11:21 pm
Location: Denmark

Re: Is love-android updated to be compatible with Android API level 26?

Post by MissDanish » Wed Oct 31, 2018 7:09 pm

Pebsie wrote:
Wed Oct 31, 2018 11:15 am
As far as I'm aware love-android hasn't even been updated to 11.1 yet. Sad times, but shit happens.
you can download it here: https://bitbucket.org/rude/love/downloads/
Provides free hugs :neko:

User avatar
gg
Prole
Posts: 9
Joined: Sun Nov 04, 2018 3:54 am

Re: Is love-android updated to be compatible with Android API level 26?

Post by gg » Sun Nov 04, 2018 4:06 am

Love 11.1 works very well! Thank you

hasan
Prole
Posts: 3
Joined: Sun Jan 29, 2017 12:09 pm

Re: Is love-android updated to be compatible with Android API level 26?

Post by hasan » Sun Dec 23, 2018 3:16 pm

Installing another version different from the one on play store works for name.love archive, but will not be able to run the main.lua as love disappears from share with or run with list.
I did crazy thing, using Apkeditor replaced the sdk version info and it is runs smoothly from tow editors on my device.
I do not know when it will crash and looking forward to see what the others are handling the issue.

User avatar
kicknbritt
Prole
Posts: 48
Joined: Sat May 30, 2015 2:15 am
Location: Chicago, IL/Anchorage,AK

Re: Is love-android updated to be compatible with Android API level 26?

Post by kicknbritt » Thu Mar 28, 2019 3:27 pm

Has anyone figured this out yet?
"I AM THE ARBITER!!!" *Pulls out Energy sword and kills everything*

jonthysell
Prole
Posts: 11
Joined: Fri Nov 03, 2017 5:19 pm
Location: Pacific Northwest
Contact:

Re: Is love-android updated to be compatible with Android API level 26?

Post by jonthysell » Sat Apr 06, 2019 6:54 pm

I was able to update to API 26 off the 0.10.x branch last year and it worked fine, Google Play accepted my submission. Check out steps 6a, 6b, and just the last part of 8c here:

viewtopic.php?f=4&t=85615

Before you ask, no I haven't tried this on 0.11.x, but it looks like that branch is already on API 28 anyway. I just haven't had any reason to jump to 0.11.x considering how much work it took me to get a working dev environment for 0.10.x on Windows.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests