Search found 1229 matches

by pgimeno
Fri Sep 21, 2018 11:19 am
Forum: General
Topic: Offline LÖVE documentation for download
Replies: 88
Views: 76801

Re: Offline LÖVE documentation for download

You probably meant to add --page-requisites

The problem with that method is that, in order to keep it updated, it needs to be fully re-downloaded every time.
by pgimeno
Wed Sep 19, 2018 9:57 pm
Forum: General
Topic: GLSL unsigned integers not supported in last version ?
Replies: 6
Views: 233

Re: GLSL unsigned integers not supported in last version ?

"#version" is not directly supported by Löve. I imagine that the main reason is that it needs to be placed at the very beginning, but Löve needs to add code before that, and the code it needs to add may depend on the version. "#pragma language glsl3" is for Löve 11.1 only. It makes it add "#version ...
by pgimeno
Wed Sep 19, 2018 2:45 pm
Forum: General
Topic: GLSL unsigned integers not supported in last version ?
Replies: 6
Views: 233

Re: GLSL unsigned integers not supported in last version ?

Really? It works fine for me after that change. I've attached it.
by pgimeno
Wed Sep 19, 2018 2:22 pm
Forum: Games and Creations
Topic: Wÿld Ünÿcÿrns - A music-based shooterlike game made for music game jam 2018
Replies: 5
Views: 223

Re: Wÿld Ünÿcÿrns - A music-based shooterlike game made for music game jam 2018

Cool game! I had to make a little adjustment to make it work. --- main_game.lua.orig 2018-09-17 23:40:04.000000000 +0200 +++ main_game.lua 2018-09-19 16:18:21.180301615 +0200 @@ -50,7 +50,7 @@ float amount = sqrt(x*x+y*y); // /sqrt(2) amount = amount * amount * amount * amount * amount * amount; flo...
by pgimeno
Tue Sep 18, 2018 10:24 pm
Forum: General
Topic: GLSL unsigned integers not supported in last version ?
Replies: 6
Views: 233

Re: GLSL unsigned integers not supported in last version ?

Try adding this line at the top of the shader:

Code: Select all

#pragma language glsl3
by pgimeno
Sun Sep 16, 2018 11:13 pm
Forum: Support and Development
Topic: I can't play to game using an old version of Löve
Replies: 6
Views: 277

Re: I can't play to game using an old version of Löve

configure just configures it, you need to run make to actually compile it. Not sure if that was the issue. Also, I was wrong. The love executable goes in src/, not src/.libs/ but in any case, the .libs directory is hidden (because it starts with a dot), you need to request it explicitly or tell your...
by pgimeno
Sun Sep 16, 2018 8:21 am
Forum: Support and Development
Topic: i keep getting out of range pixel when using a certain method for collision detection
Replies: 2
Views: 258

Re: i keep getting out of range pixel when using a certain method for collision detection

Hello!

The forums don't seem to allow attaching more than one image per post (I've had that myself), but more importantly, it's impossible to know what you're doing wrong without having any code to look into. How about you attach a .love file with the project?
by pgimeno
Sat Sep 15, 2018 2:34 pm
Forum: Support and Development
Topic: I can't play to game using an old version of Löve
Replies: 6
Views: 277

Re: I can't play to game using an old version of Löve

What I do is compiling it as a static binary. That lets me have several executables (one for each version) that don't conflict with each other. It's quite some work to compile them all, but you only do that once. Or you can just compile the version you want to. There are compilation instructions and...
by pgimeno
Sat Sep 15, 2018 9:06 am
Forum: Support and Development
Topic: CRT effect and shaders:
Replies: 6
Views: 233

Re: CRT effect and shaders:

A key to understand shaders is that they don't say "where each pixel should move", but "what each pixel should show". It's kind of the other way around. For example, if you want to show an image tilted 30° to the right, the shader has to sample the original image with an angle of 30° to the left.
by pgimeno
Thu Sep 13, 2018 2:29 pm
Forum: Support and Development
Topic: can't get spriter to work (it does, but nothing shows up)
Replies: 7
Views: 219

Re: can't get spriter to work (it does, but nothing shows up)

I think you can do spriterData:setCanvasOffset(-400, -500) or something like that. I don't use spriter, sorry. Doesn't Spriter offer a hook point? If so, that should be automatically used, but it doesn't appear like the library can handle that.