Eclipse Error/Some questions about this

A project to port LÖVE to Android handhelds
Locked
User avatar
PedroChurro
Prole
Posts: 25
Joined: Tue Oct 09, 2012 8:22 pm
Location: In my room

Eclipse Error/Some questions about this

Post by PedroChurro » Sun Nov 11, 2012 11:28 am

Hi,


So, when a saw this, I immediately wanted to try. So, I follow this viewtopic.php?f=11&t=8415 tutorial, and when I try to run eclipse it says "Failed to load JNI shared library". Do you guys know a fix to this? It would be really helpfull.(BTW, I copied the jre7 folder on Program Files > Java and pasted it in the eclipse folder, and changed the name from jre7 to jre)

And also, do this changes/adds any code? Like, if I put the code love.keyboard.isDown("right") and run the game on a touch screen Android, what will the Android understand? Will it do the code if I touch on the screen right-ish?

Thanks.
(Sorry for my bad english)
I try to make games.

User avatar
T-Bone
Inner party member
Posts: 1492
Joined: Thu Jun 09, 2011 9:03 am

Re: Eclipse Error/Some questions about this

Post by T-Bone » Sun Nov 11, 2012 11:33 am

Not sure about the error, but in order to use the touch screen, you can simply use love.mousepressed etc.

User avatar
PedroChurro
Prole
Posts: 25
Joined: Tue Oct 09, 2012 8:22 pm
Location: In my room

Re: Eclipse Error/Some questions about this

Post by PedroChurro » Sun Nov 11, 2012 11:44 am

T-Bone wrote:Not sure about the error, but in order to use the touch screen, you can simply use love.mousepressed etc.

Wow, didn't remember of that. Thanks!
I try to make games.

User avatar
Petunien
Party member
Posts: 191
Joined: Fri Feb 03, 2012 8:02 pm
Location: South Tyrol (Italy)

Re: Eclipse Error/Some questions about this

Post by Petunien » Sun Nov 11, 2012 4:48 pm

I remember that error, I had it too. I was using a wrong version of JDK.

Like other guys say, installing the right 32-/64-Bit version of JDK/Eclipse should solve the error.
They have to match each other.

http://stackoverflow.com/questions/1058 ... ed-library
"Docendo discimus" - Lucius Annaeus Seneca

User avatar
PedroChurro
Prole
Posts: 25
Joined: Tue Oct 09, 2012 8:22 pm
Location: In my room

Re: Eclipse Error/Some questions about this

Post by PedroChurro » Sun Nov 11, 2012 5:05 pm

Petunien wrote:I remember that error, I had it too. I was using a wrong version of JDK.

Like other guys say, installing the right 32-/64-Bit version of JDK/Eclipse should solve the error.
They have to match each other.

http://stackoverflow.com/questions/1058 ... ed-library
Looks like I had the 32-Bit Java and 64-Bit Eclipse. Thanks!
I try to make games.

Locked

Who is online

Users browsing this forum: No registered users and 5 guests