Page 1 of 1

[solved][Android] NDK Error when running ndk-build

Posted: Sun Jun 18, 2017 7:36 pm
by NickRock
I'm pretty sure I have installed all the new system variables correctly. NDK version is r9d.

When I run the command ndk-build is gives me this error:

Android NDK: ERROR:C:/Users/Nicolas/NDK/android-ndk-r9d/sources/cxx-stl/gnu-libs
tdc++/ LOCAL_SRC_FILES points to a missing file
Android NDK: Check that C:/Users/Nicolas/NDK/android-ndk-r9d/sources/cxx-stl/gnu
-libstdc++/4.9/libs/armeabi/libgnustl_static.a exists or that its path is correct
C:/Users/Nicolas/NDK/android-ndk-r9d/build/core/ *** Andr
oid NDK: Aborting . Stop.

From what I understood it is looking for this file /sources/cxx-stl/gnu-libstdc++/4.9/libs/armeabi/libgnustl_static.a

But the folder 4.9 doesn't exist. Mine only has the versions 4.8 and 4.6. I found 4.9 in the r10 version but the bitbucket page says that there have been some problems with the latest versions.

How can I fix this issue? It seems like the r9 version of NDK is just too outdated but the latest versions don't work either (according to the bitbucket page).

Re: [Android] NDK Error when running ndk-build

Posted: Fri Jun 23, 2017 12:57 am
by wison27
Try use the NDK 14b, is generating normally here. See this: .

Re: [solved][Android] NDK Error when running ndk-build

Posted: Sat Nov 04, 2017 7:19 am
by desman
Your path is too long. Windows command line string only support up to 32,768 characters.

Please check if this a same problem: ... d-ndk-r11c ... tory-error

Re: [solved][Android] NDK Error when running ndk-build

Posted: Sat Oct 06, 2018 4:01 am
by maryrosie
I also think the problem you are having is because your path is too long!