LÖVE 0.6.1

General discussion about LÖVE, Lua, game development, puns, and unicorns.
User avatar
rude
Administrator
Posts: 1051
Joined: Mon Feb 04, 2008 3:58 pm
Location: Oslo, Norway

Re: LÖVE 0.6.1

Post by rude » Sun Feb 07, 2010 4:03 pm

There were several problems, but everything should be fixed now. Binaries are updated. The new binaries also has the fix Avalon mentioned.

User avatar
Jasoco
Inner party member
Posts: 3650
Joined: Mon Jun 22, 2009 9:35 am
Location: Pennsylvania, USA
Contact:

Re: LÖVE 0.6.1

Post by Jasoco » Sun Feb 07, 2010 7:12 pm

Yay, the demos have fixed sound now so all is well!

Except for this one little problem...
Image

Notice how the text stretches at the bottom as if the image size is smaller than what you're asking for. Would be a simple fix if you ask me. The original 0.5.0 version doesn't have this problem so I guess it happened in the rewrite. And doesn't even detract from the ability to learn how to do it so, fix it in your own time.

User avatar
Aharon
Prole
Posts: 1
Joined: Mon Feb 08, 2010 12:47 am

Re: LÖVE 0.6.1

Post by Aharon » Mon Feb 08, 2010 12:52 am

Just updated it here, and already made the love.audio modifications in code. All appears to work just like b4. (with the improvements, of course)

Thank you for the excellent work, Löve Team :ultrahappy:

User avatar
Person
Prole
Posts: 39
Joined: Thu Jun 18, 2009 2:35 am

Re: LÖVE 0.6.1

Post by Person » Tue Feb 09, 2010 2:56 pm

*celebrates* This one works on my Mac! 0.6.0 couldn't no matter how hard I tried so I guess something must have changed this time around. I'm so exited! *goes wild*
"Here's another curse for you, may all your bacon burn."

User avatar
middlerun
Citizen
Posts: 64
Joined: Tue Nov 25, 2008 4:31 am
Location: Sydney, Australia
Contact:

Re: LÖVE 0.6.1

Post by middlerun » Sat Feb 13, 2010 8:43 am

Playing an MP3 isn't working for me in LÖVE 0.6.1 on Ubuntu Karmic. love.audio.newSource() seems to work, but when I try to play it the game freezes. I converted it to Ogg and it's fine, so I guess it's no big deal.

Geti
Party member
Posts: 112
Joined: Tue Oct 20, 2009 6:38 am

Re: LÖVE 0.6.1

Post by Geti » Sat Feb 13, 2010 10:53 am

This news makes me happy. <3 all this sound business.

User avatar
Garotas*Gostosas
Prole
Posts: 41
Joined: Fri Apr 03, 2009 12:15 am

Re: LÖVE 0.6.1

Post by Garotas*Gostosas » Sat Feb 13, 2010 11:55 am

excellent! you guys made sumthing good even better...! :)
btw "no" is quite a cool game. :ultrahappy: good times!
I LOVE GAME, YEAH!

giniu
Party member
Posts: 221
Joined: Mon Nov 30, 2009 4:44 pm

Re: LÖVE 0.6.1

Post by giniu » Sat Feb 13, 2010 3:22 pm

Congratulations on new release, quite fast after 0.6.0 :) I must say that I especially like
rude wrote:
  • The error screen redraws when an event occurs.
it really speeds up my getting around 0.6.x, really glad to see it back :)

User avatar
bartbes
Sex machine
Posts: 4946
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LÖVE 0.6.1

Post by bartbes » Sat Feb 13, 2010 8:59 pm

giniu wrote:I must say that I especially like
rude wrote:
  • The error screen redraws when an event occurs.
r
[...] really glad to see it back :)
No problem :P

User avatar
Jasoco
Inner party member
Posts: 3650
Joined: Mon Jun 22, 2009 9:35 am
Location: Pennsylvania, USA
Contact:

Re: LÖVE 0.6.1

Post by Jasoco » Sun Feb 14, 2010 7:14 pm

middlerun wrote:Playing an MP3 isn't working for me in LÖVE 0.6.1 on Ubuntu Karmic. love.audio.newSource() seems to work, but when I try to play it the game freezes. I converted it to Ogg and it's fine, so I guess it's no big deal.
I've never had MP3's work on Löve. Converting to Ogg always works though.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 4 guests