LÖVE 0.9.1 released

General discussion about LÖVE, Lua, game development, puns, and unicorns.
User avatar
Fenrir
Party member
Posts: 222
Joined: Wed Nov 27, 2013 9:44 am
Contact:

Re: LÖVE 0.9.1 released

Post by Fenrir » Wed Apr 02, 2014 8:58 am

Thanks for this release, I'm intensively using Canvas in my game and this change:
Updated Canvas drawing code, texture coordinates are no longer flipped vertically.
It mades me remove a lot of workarounds I was using to map everything as expected. :)

Another good news is that I'm having a big performances jump with this version, don't know if it's coming from Canvas optimizations or Meshes (I'm also using them a lot), anyway, thanks again!

So what's the plan for the future now? Going on 0.10.0, or 1.0.0 ? Officialy integrating iOS and Android ports ?

Cheers,

User avatar
Rucikir
Party member
Posts: 119
Joined: Tue Nov 05, 2013 6:33 pm
Location: Paris
Contact:

Re: LÖVE 0.9.1 released

Post by Rucikir » Wed Apr 02, 2014 6:46 pm

Hi,
I do not really know how you usually do, but the packages on Ubuntu's PPA are broken, and out-of date on the officials repo.
I'm expecting someone to say "It's normal, it has always been", but it would be nice to fix this, nuh ?
Lua script to distribute your LÖVE games. love-release.lua : Forum | Github
@Rucikir

User avatar
bartbes
Sex machine
Posts: 4933
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LÖVE 0.9.1 released

Post by bartbes » Wed Apr 02, 2014 6:53 pm

How are they broken?

User avatar
Rucikir
Party member
Posts: 119
Joined: Tue Nov 05, 2013 6:33 pm
Location: Paris
Contact:

Re: LÖVE 0.9.1 released

Post by Rucikir » Wed Apr 02, 2014 7:11 pm

I think I found it... liblove requires libmng1, and libmng1 is not present on Ubuntu Trusty repos (I'm running the beta).
On Trusty you only have http://packages.ubuntu.com/trusty/libmng2, and not libmng1, but on Saucy you only have libmng1.
Lua script to distribute your LÖVE games. love-release.lua : Forum | Github
@Rucikir

User avatar
bartbes
Sex machine
Posts: 4933
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LÖVE 0.9.1 released

Post by bartbes » Wed Apr 02, 2014 7:18 pm

Ah, I couldn't test on trusty sadly, I'll see about getting this fixed.. but that might take a while. From what I've found on the internet all that's really changed is the name of the binary, so it's kind of annoying this breaks.. That said, if you force install liblove (and get the other dependencies) and you add a symlink from /usr/lib/libmng.so.2 to /usr/lib/libmng.so.1 it probably should work. It's hacky at best, though.

EDIT: Slime pointed out libmng is a dependency of devil, not of love itself, so I'll have a look at removing it as a dependency altogether. This also means that the symlink probably isn't necessary..

User avatar
R-BG
Prole
Posts: 11
Joined: Sat Jan 11, 2014 11:37 pm
Contact:

Re: LÖVE 0.9.1 released

Post by R-BG » Wed Apr 09, 2014 5:10 pm

Looks like the file description is still "0.9.0". At least for the win64-version.
Attachments
love_descr.png
love_descr.png (6.8 KiB) Viewed 9536 times

minism
Prole
Posts: 20
Joined: Tue Nov 01, 2011 5:32 am

Re: LÖVE 0.9.1 released

Post by minism » Sat Apr 19, 2014 12:01 am

Nice work guys, LOVE is becoming amazingly good!

Kadaj
Prole
Posts: 7
Joined: Tue Dec 07, 2010 12:25 pm

Re: LÖVE 0.9.1 released

Post by Kadaj » Thu Apr 24, 2014 2:34 pm

Nice release but I have one problem with the latest version. When I launch my game the frame rate is oddly low sometimes. When printing dt it shows that every other frame is about twice as long as the previous one. Without capping the fps it is normally over 200 or something but in this version it stays at about 65 and when capped at 60fps ( with timer.sleep ) the game runs about 44fps. As I said this does not happen every time when I launch the game only sometimes ( more than I like ). This problem has not happened before version 0.9.1. Any ideas where could the problem be? It could be that my code sucks but this has not happened before ( and I have been developing this game about two years from 0.8.0 -> 0.9.1 ) so It has to be somewhere in the core of the Love.

Edit: tested with two different PCs ( both has Windows 8.1 )
Last edited by Kadaj on Fri Apr 25, 2014 7:31 am, edited 1 time in total.

jjmafiae
Party member
Posts: 1333
Joined: Tue Jul 24, 2012 8:22 am

Re: LÖVE 0.9.1 released

Post by jjmafiae » Thu Apr 24, 2014 5:27 pm

Same here, the framerate is strange right now.
My Itch.io Games (Not up to date)
My Website

User avatar
slime
Solid Snayke
Posts: 2763
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: LÖVE 0.9.1 released

Post by slime » Thu Apr 24, 2014 6:31 pm

love.timer.sleep can't be used to completely accurately cap FPS, the sleep duration is not reliable enough for that (and the reliability varies depending on the OS and system.)

Nothing in LÖVE itself changed that would cause framerate issues like that. It might be your code or a video driver problem.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 3 guests