LÖVE 0.9.2 Released

General discussion about LÖVE, Lua, game development, puns, and unicorns.
User avatar
Nixola
Inner party member
Posts: 1918
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: LÖVE 0.9.2 Released

Post by Nixola » Tue Aug 04, 2015 1:42 pm

If you wish, you can run 0.9.2 on the RPI already! This branch adds GLES support and I am running it on my own pi (even though it has an issue I don't yet understand), and you can also build LÖVE 0.10.0 in its current development state.
(EDIT: you'll need libgles2-mesa-dev for 0.9.2 and gcc-4.8 for 0.10.0)
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

cyanisaac
Prole
Posts: 2
Joined: Tue Aug 04, 2015 2:44 am

Re: LÖVE 0.9.2 Released

Post by cyanisaac » Tue Aug 04, 2015 4:25 pm

Nixola wrote:If you wish, you can run 0.9.2 on the RPI already! This branch adds GLES support and I am running it on my own pi (even though it has an issue I don't yet understand), and you can also build LÖVE 0.10.0 in its current development state.
(EDIT: you'll need libgles2-mesa-dev for 0.9.2 and gcc-4.8 for 0.10.0)
Hmm, that's neato. I will look into that!

User avatar
slime
Solid Snayke
Posts: 2763
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: LÖVE 0.9.2 Released

Post by slime » Tue Aug 04, 2015 4:27 pm

Nixola wrote:you'll need [..] gcc-4.8 for 0.10.0
Does it fail to compile if GCC 4.7 is used? I've been trying to have 4.7 as a minimum requirement for compiling LÖVE 0.10.0 using GCC.

User avatar
bartbes
Sex machine
Posts: 4925
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: LÖVE 0.9.2 Released

Post by bartbes » Tue Aug 04, 2015 4:37 pm

I'm fairly sure raspbian only has gcc-4.6 and gcc-4.8 in the repos, not 4.7.

User avatar
Nixola
Inner party member
Posts: 1918
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: LÖVE 0.9.2 Released

Post by Nixola » Wed Aug 05, 2015 10:06 am

bartbes wrote:I'm fairly sure raspbian only has gcc-4.6 and gcc-4.8 in the repos, not 4.7.
I'm not sure if the repos have 4.7, but I'm sure they have 4.6 and 4.8 and I also guess 4.8 would be better than 4.7 anyway, so that's why I suggested it.
Little sidenote: I couldn't get raspbian to automatically "set" the gcc and g++ commands to use gcc-4.8 and g++-4.8, I had to create a symlink in /usr/bin myself after installing gcc-4.8 and g++-4.8 and removing the 4.6 versions.
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

Daniel_Cortez
Prole
Posts: 11
Joined: Sun Apr 06, 2014 4:43 pm
Location: Novokuznetsk, Russia

Re: LÖVE 0.9.2 Released

Post by Daniel_Cortez » Thu Aug 06, 2015 3:51 am

https://bitbucket.org/rude/love/src/3d6 ... hanges.txt
* Removed the "canvas", "shader", "npot", "subtractive", and "mipmap" Graphics Feature constant (the features always have guaranteed support now.)
Does that mean that the support for old graphics cards will be dropped?
↑↑↓↓↑↑↑↑

User avatar
Davidobot
Party member
Posts: 1142
Joined: Sat Mar 31, 2012 5:18 am
Location: Game-Dev. Land
Contact:

Re: LÖVE 0.9.2 Released

Post by Davidobot » Thu Aug 06, 2015 6:34 am

Daniel_Cortez wrote:https://bitbucket.org/rude/love/src/3d6 ... hanges.txt
* Removed the "canvas", "shader", "npot", "subtractive", and "mipmap" Graphics Feature constant (the features always have guaranteed support now.)
Does that mean that the support for old graphics cards will be dropped?
No, as far as I can tell, they will now be supported by all systems?
the features always have guaranteed support now
My library:
LovelyMoon

Check out my current project:
Raycaster

Oh hey, I have a website now!

User avatar
slime
Solid Snayke
Posts: 2763
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: LÖVE 0.9.2 Released

Post by slime » Thu Aug 06, 2015 12:28 pm

LÖVE 0.10.0 will only run on systems that support either OpenGL 2.1 or OpenGL ES 2. Fortunately that includes almost every system out there – there are even ways to use OpenGL ES 2 on Windows systems that don't have proper driver support for OpenGL 2.1.

gingerbeardman
Prole
Posts: 3
Joined: Mon Sep 14, 2015 7:22 am

Re: LÖVE 0.9.2 Released

Post by gingerbeardman » Mon Sep 14, 2015 7:24 am

Note that you must be registered in the iOS Developer Program in order to build for physical iOS devices.
Those is no longer true as of Xcode 7.

The Developer Program gets you extra benefits, but building to your own device is now free for all.

User avatar
Rucikir
Party member
Posts: 119
Joined: Tue Nov 05, 2013 6:33 pm
Location: Paris
Contact:

Re: LÖVE 0.9.2 Released

Post by Rucikir » Sat Oct 24, 2015 8:39 am

Could you update the Ubuntu PPA, as Ubuntu's new version 15.10, Wily Werewolf has just been published ?
Lua script to distribute your LÖVE games. love-release.lua : Forum | Github
@Rucikir

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests