Update to LuaJIT 2.0.4?

General discussion about LÖVE, Lua, game development, puns, and unicorns.
Post Reply
Whatthefuck
Party member
Posts: 105
Joined: Sat Jun 21, 2014 3:45 pm

Update to LuaJIT 2.0.4?

Post by Whatthefuck » Wed Jun 10, 2015 8:22 am

Like the title says, LuaJIT 2.0.4 was released somewhat recently and it has a bunch of various fixes/improvements. (http://luajit.org/changes.html)

Is there a chance you guys could update LuaJIT to 2.0.4 in 0.10.0?

Thanks in advance for the answer.

User avatar
kikito
Inner party member
Posts: 3152
Joined: Sat Oct 03, 2009 5:22 pm
Location: Madrid, Spain
Contact:

Re: Update to LuaJIT 2.0.4?

Post by kikito » Wed Jun 10, 2015 8:34 am

That's a good point. From what I read, 2.0.4 is all bugfixes, so it should be an easy update (not that I know anything about C/C++)
When I write def I mean function.

User avatar
Fenrir
Party member
Posts: 222
Joined: Wed Nov 27, 2013 9:44 am
Contact:

Re: Update to LuaJIT 2.0.4?

Post by Fenrir » Wed Jun 10, 2015 8:43 am

As for the lastest version lua is provided as an external library (at least on Windows), just switching the lua51.dll/so should work, no? Is there any pre-build binaries somewhere?

Whatthefuck
Party member
Posts: 105
Joined: Sat Jun 21, 2014 3:45 pm

Re: Update to LuaJIT 2.0.4?

Post by Whatthefuck » Wed Jun 10, 2015 4:40 pm

Fenrir wrote:As for the lastest version lua is provided as an external library (at least on Windows), just switching the lua51.dll/so should work, no? Is there any pre-build binaries somewhere?
Nah, gotta build that shit.

User avatar
bartbes
Sex machine
Posts: 4944
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: Update to LuaJIT 2.0.4?

Post by bartbes » Wed Jun 10, 2015 5:04 pm

Can I gloat about the wonders of dynamic linking? I've been running love against luajit 2.0.4 since the 21st of May.

User avatar
slime
Solid Snayke
Posts: 2832
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: Update to LuaJIT 2.0.4?

Post by slime » Wed Jun 10, 2015 5:18 pm

Indeed, you can replace the version of LuaJIT normally used by LÖVE with your own right now if you want – on all operating systems.

I try to use the most recent versions of all dependencies for new releases of LÖVE, so 0.10.0 will come with LuaJIT 2.0.4 where possible (and LuaJIT 2.1-alpha on iOS, since it's the only version of LuaJIT to fully support iOS.)

Whatthefuck
Party member
Posts: 105
Joined: Sat Jun 21, 2014 3:45 pm

Re: Update to LuaJIT 2.0.4?

Post by Whatthefuck » Thu Jun 11, 2015 6:30 am

slime wrote:Indeed, you can replace the version of LuaJIT normally used by LÖVE with your own right now if you want – on all operating systems.
What the hell, last time I tried switching .dlls up it resulted in crashes.

User avatar
I~=Spam
Party member
Posts: 206
Joined: Fri Dec 14, 2012 11:59 pm

Re: Update to LuaJIT 2.0.4?

Post by I~=Spam » Thu Jun 11, 2015 7:17 am

Whatthefuck wrote:
slime wrote:Indeed, you can replace the version of LuaJIT normally used by LÖVE with your own right now if you want – on all operating systems.
What the hell, last time I tried switching .dlls up it resulted in crashes.
It shouldn't if you do it right.... luajit was intended to be a drop-in replacement so that a project for lua 5.1 literally just has to replace the lua dll to use luajit instead. I love dynamic linking. :D

Are you sure you didn't remove any wrong dlls? Also what LOVE version did you try this with? If you tried 0.8.0 I think this version uses standard lua 5.2 so it is not compatible with luajit.
My Tox ID: 0F1FB9170B94694A90FBCF6C4DDBDB9F58A9E4CDD0B4267E50BF9CDD62A0F947E376C5482610

jjmafiae
Party member
Posts: 1333
Joined: Tue Jul 24, 2012 8:22 am

Re: Update to LuaJIT 2.0.4?

Post by jjmafiae » Thu Jun 11, 2015 3:10 pm

I~=Spam wrote:
Whatthefuck wrote:
slime wrote:Indeed, you can replace the version of LuaJIT normally used by LÖVE with your own right now if you want – on all operating systems.
What the hell, last time I tried switching .dlls up it resulted in crashes.
It shouldn't if you do it right.... luajit was intended to be a drop-in replacement so that a project for lua 5.1 literally just has to replace the lua dll to use luajit instead. I love dynamic linking. :D

Are you sure you didn't remove any wrong dlls? Also what LOVE version did you try this with? If you tried 0.8.0 I think this version uses standard lua 5.2 so it is not compatible with luajit.
it was possible to use luajit with 0.8.0 I remember people doing that (here: viewtopic.php?t=7735&f=4)

User avatar
bartbes
Sex machine
Posts: 4944
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: Update to LuaJIT 2.0.4?

Post by bartbes » Thu Jun 11, 2015 3:31 pm

I~=Spam wrote:If you tried 0.8.0 I think this version uses standard lua 5.2 so it is not compatible with luajit.
We have never shipped a version of love using lua 5.2. This does mean however, that you can swap out luajit and lua 5.1, but not 5.2 (or 5.3) though all of those versions are supported by love at a source level.

Post Reply

Who is online

Users browsing this forum: Google [Bot], slime and 7 guests