LÖVE 0.10.1 released

General discussion about LÖVE, Lua, game development, puns, and unicorns.
CraftedPixel
Prole
Posts: 7
Joined: Tue Dec 29, 2015 5:26 pm

Incompatible with Windows XP!

Post by CraftedPixel » Wed Mar 02, 2016 10:30 pm

I have a school computer that uses windows xp and love2d 10+ are incompatible!
But love 8 runs just fine.
When I run it with the win XP machine I get a OpenGL error.
Saying:

Unable to create OpenGL window

This program requires a graphics card and video drivers which support OpenGL 2.1 or OpenGL ES 2.
Detected OpenGL version:
1.4.0 - Build 4 14 10 4410 - Intel 945G (Intel)


There should be some backwords compatibility with the older OpenGL

Thanks for reading!

CraftedPixel

User avatar
slime
Solid Snayke
Posts: 2778
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: LÖVE 0.10.1 released

Post by slime » Wed Mar 02, 2016 10:36 pm

That GPU is not capable of using shaders, which LÖVE 0.10 requires to run. LÖVE 0.9.2 will work fine (although the performance of that GPU is miserable), though.

We had backwards-compatibility with those ancient 15 year old era GPUs for many years, but eventually it became more complex and bug-prone and took way more effort than it's worth to support them – especially since mobile support was added. Having mandatory support for shaders in LÖVE's APIs also means people using LÖVE don't have to worry about writing multiple graphics codepaths for when shaders aren't supported.
Last edited by slime on Sun Mar 06, 2016 1:01 am, edited 2 times in total.

User avatar
alberto_lara
Party member
Posts: 326
Joined: Wed Oct 30, 2013 8:59 pm

Re: LÖVE 0.10.1 released

Post by alberto_lara » Sat Mar 05, 2016 10:08 pm

The GPU is not capable of using shaders
Did you mean CPU? I thought the shaders were destined to run specifically in the GPU, maybe I'm just confused :?
LÖVE Projects: GOOi, Süsse, Dyzön and Katsudö
Thanks for taking the time and read this

User avatar
Nixola
Inner party member
Posts: 1935
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: LÖVE 0.10.1 released

Post by Nixola » Sat Mar 05, 2016 10:34 pm

He means that specific GPU. OpenGL 1.4 doesn't have shaders.
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

User avatar
alberto_lara
Party member
Posts: 326
Joined: Wed Oct 30, 2013 8:59 pm

Re: LÖVE 0.10.1 released

Post by alberto_lara » Mon Apr 25, 2016 10:38 pm

Nixola wrote:He means that specific GPU. OpenGL 1.4 doesn't have shaders.
Like.
LÖVE Projects: GOOi, Süsse, Dyzön and Katsudö
Thanks for taking the time and read this

atex
Prole
Posts: 1
Joined: Fri Feb 12, 2016 3:34 pm

Re: LÖVE 0.10.1 released

Post by atex » Fri Apr 29, 2016 2:29 pm

Hello everyone.
On my windows pc I have this version and everything is perfect. On my Linux (Ubuntu 14) I got a problem. Love said :
"This program requires a graphics card and video drivers which support OpenGL 2.1 or OpenGL ES 2.
SDL window creation error: Couldn't find matching GLX visual"

So as I read somewere the 0.9.2 version runs without problem on cases like this one.

Any chance of get (and where) the 0.9.2 version and install in on my Ubuntu ?
Thanks in advance for any help.

Antonio Teixeira

User avatar
Kingdaro
Party member
Posts: 395
Joined: Sun Jul 18, 2010 3:08 am

Re: LÖVE 0.10.1 released

Post by Kingdaro » Fri Apr 29, 2016 3:36 pm

You should probably update your drivers on Ubuntu from a different repository from the main. I recall Ubuntu's sources being notoriously outdated.

smasher
Prole
Posts: 1
Joined: Wed Jun 29, 2016 9:36 am

Re: LÖVE 0.10.1 released

Post by smasher » Wed Jun 29, 2016 9:39 am

Hello,

Could someone please package this version for Ubuntu 12.04 (Precise) and put it the official PPA?

Thanks in advance

User avatar
Kari-Jukka
Prole
Posts: 1
Joined: Thu Jun 26, 2014 3:33 pm
Location: Finland

Re: LÖVE 0.10.1 released

Post by Kari-Jukka » Sat Jul 02, 2016 8:42 pm

I was wondering, why has bitmap support been removed for ImageData:encode?
There was no explanation for this and I really don't see why it has been removed in LÖVE 0.10.0.

User avatar
slime
Solid Snayke
Posts: 2778
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: LÖVE 0.10.1 released

Post by slime » Sat Jul 02, 2016 9:56 pm

Kari-Jukka wrote:I was wondering, why has bitmap support been removed for ImageData:encode?
LOVE 0.9 and earlier used a rather large LGPL-licensed library called DevIL for all image decoding and encoding. In 0.10 we switched to a couple much smaller more specialized libraries.

As a result, most obscure image formats that almost no one used are no longer supported for loading, and BMP wasn't re-implemented for saving. You can just save as TGA instead of BMP though, the two formats are both used for similar purposes but TGA is a bit more common.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 2 guests