Configuring Visual Studio with Babelua for LÖVE

General discussion about LÖVE, Lua, game development, puns, and unicorns.
User avatar
Eroica
Prole
Posts: 9
Joined: Sat Feb 28, 2015 12:38 pm

Configuring Visual Studio with Babelua for LÖVE

Post by Eroica » Fri Jul 15, 2016 3:38 pm

Hi,

I switched from a Mac machine to a new Windows box, and would like to set up Visual Studio to work with LÖVE. I know that there's ZeroBrane Studio available for Windows (which I also used on the Mac), but I thought I'd give Visual Studio a try this time.

I configured Visual Studio and Babelua according to this topic: viewtopic.php?f=3&t=79884&p=181765&hili ... io#p181765

But my problem now is that I can't get the debugger to work (the main reason why I want to use Visual Studio). I can successfully run LÖVE using Babelua's "Run Without Debugging", but if I try to "Start Debugging" (F5), I get the following error message:

https://db.tt/jTuiwqmh

Here's my Babelua setup for this example project:

https://db.tt/SrbVEnBj

LÖVE itself has been installed to the standard directory on "C:\Program Files".

Did anyone have success with a similar setup, and can tell me maybe what settings I need to change?

User avatar
SiENcE
Party member
Posts: 782
Joined: Thu Jul 24, 2008 2:25 pm
Location: Berlin/Germany
Contact:

Re: Configuring Visual Studio with Babelua for LÖVE

Post by SiENcE » Wed Jul 20, 2016 7:51 am

Did anyone have success with a similar setup, and can tell me maybe what settings I need to change?
Late reply, but maybe other people also wanted to know a solution?

Install BabeLua and after this, first start Visual Studio as Admin (important!; after this you can start VS as normal User).

Create a Lua Project, go to project settings and setup like this:

Image

Lua exe path: c:\Projects\0100\love.exe
Working path: c:\Projects\0100\game
Command line: ./

In Lua exe path you put Löve.
In Working path you put your project...main.lua should be there!

Have some fun with debugging lua :).

cheers

Mariscal
Prole
Posts: 16
Joined: Sat Jun 25, 2016 4:51 pm
Location: London
Contact:

Re: Configuring Visual Studio with Babelua for LÖVE

Post by Mariscal » Wed Jul 20, 2016 10:02 pm

I did start VS as an Admin but still getting the same problem Eroica mentioned. If I run without debugger everything is fine, but otherwise I get the error message about "Error starting process love.exe"

I'm using VS 2015, the free edition.
Currently working on Breaking Fast, a competitive 2D "mario kart alike" racing game! Already passed steam greenlight, hopefully soon to be released! :D

User avatar
SiENcE
Party member
Posts: 782
Joined: Thu Jul 24, 2008 2:25 pm
Location: Berlin/Germany
Contact:

Re: Configuring Visual Studio with Babelua for LÖVE

Post by SiENcE » Wed Jul 20, 2016 10:41 pm

Maybe you use Löve 64bit ?

Visual Studio is always 32bit :).

So just use Löve 32 bit.

Mariscal
Prole
Posts: 16
Joined: Sat Jun 25, 2016 4:51 pm
Location: London
Contact:

Re: Configuring Visual Studio with Babelua for LÖVE

Post by Mariscal » Wed Jul 20, 2016 11:12 pm

I have the feeling it's going to be that, I'll try tomorrow and I'll let you now! Thanks! :D
Currently working on Breaking Fast, a competitive 2D "mario kart alike" racing game! Already passed steam greenlight, hopefully soon to be released! :D

Mariscal
Prole
Posts: 16
Joined: Sat Jun 25, 2016 4:51 pm
Location: London
Contact:

Re: Configuring Visual Studio with Babelua for LÖVE

Post by Mariscal » Fri Jul 22, 2016 7:02 pm

SiENcE wrote:Maybe you use Löve 64bit ?

Visual Studio is always 32bit :).

So just use Löve 32 bit.
Yes, it did work! :awesome: I can finally debug properly, thanks so much!
Currently working on Breaking Fast, a competitive 2D "mario kart alike" racing game! Already passed steam greenlight, hopefully soon to be released! :D

User avatar
SiENcE
Party member
Posts: 782
Joined: Thu Jul 24, 2008 2:25 pm
Location: Berlin/Germany
Contact:

Re: Configuring Visual Studio with Babelua for LÖVE

Post by SiENcE » Sun Jul 24, 2016 9:09 pm

No problem :). Good Luck, i think VS+Babelua is the best debug environment for löve.

User avatar
Eroica
Prole
Posts: 9
Joined: Sat Feb 28, 2015 12:38 pm

Re: Configuring Visual Studio with Babelua for LÖVE

Post by Eroica » Mon Aug 01, 2016 11:56 am

:awesome: Thanks for your replies both of you! The problem was really caused by having the 64bit version of LÖVE installed. Now with the 32bit version, everything works!

phobos2077
Prole
Posts: 11
Joined: Sun Feb 12, 2017 4:50 pm

Re: Configuring Visual Studio with Babelua for LÖVE

Post by phobos2077 » Sun Feb 12, 2017 4:51 pm

Everything seems to work. But how do you set up code completion for the LOVE API?

terids
Prole
Posts: 1
Joined: Wed Mar 01, 2017 5:26 pm

Re: Configuring Visual Studio with Babelua for LÖVE

Post by terids » Wed Mar 01, 2017 5:27 pm

phobos2077 wrote:
Sun Feb 12, 2017 4:51 pm
Everything seems to work. But how do you set up code completion for the LOVE API?
I too would like to know this. As far as I can tell, this isn't possible yet? I hope I'm wrong :)

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests