LÖVE 11.0 released!

General discussion about LÖVE, Lua, game development, puns, and unicorns.
unindented
Prole
Posts: 1
Joined: Mon Apr 02, 2018 12:58 am

Re: LÖVE 11.0 released!

Post by unindented » Mon Apr 02, 2018 12:59 am

When building for macOS, should we be using the same frameworks as for 0.10.0? I don't see a 11.0 version here: https://love2d.org/sdk/

User avatar
Jasoco
Inner party member
Posts: 3620
Joined: Mon Jun 22, 2009 9:35 am
Location: Pennsylvania, USA
Contact:

Re: LÖVE 11.0 released!

Post by Jasoco » Mon Apr 02, 2018 1:41 am

Looks like I have a lot of work to do. Some shaders of mine are giving complaints probably because of the switch from 255-based colors to 1.0-based colors.

User avatar
slime
Solid Snayke
Posts: 2763
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: LÖVE 11.0 released!

Post by slime » Mon Apr 02, 2018 1:42 am

unindented wrote:
Mon Apr 02, 2018 12:59 am
When building for macOS, should we be using the same frameworks as for 0.10.0? I don't see a 11.0 version here: https://love2d.org/sdk/
Until the new ones go up on that page, you can download stock 11.0 and copy the frameworks out of love.app/Contents/Frameworks/.

ThiefOfPringles
Prole
Posts: 16
Joined: Fri Feb 26, 2016 1:42 pm

Re: LÖVE 11.0 released!

Post by ThiefOfPringles » Mon Apr 02, 2018 2:48 am

Running the installer on Windows 10 produces some interesting text...

https://i.imgur.com/W46ZHjz.png

Maybe it's some kind of ASCII - Unicode mixup?

User avatar
pixelicidio
Prole
Posts: 5
Joined: Sat Mar 17, 2018 2:47 pm
Contact:

Re: LÖVE 11.0 released!

Post by pixelicidio » Mon Apr 02, 2018 3:20 am

Is good to know Love2D have a new release to keep the project up to date.

But this was a big-breaking-code change:
Changed colour values to be in the range 0-1, rather than 0-255
Saludos!

User avatar
eouppdru
Prole
Posts: 5
Joined: Tue Feb 20, 2018 3:39 pm

Re: LÖVE 11.0 released!

Post by eouppdru » Mon Apr 02, 2018 4:50 am

after updating my game to 11.0, it seems to sometimes not create canvases. it doesn't produce an error, just sometimes the canvases are all black and drawing to them does nothing. I'll have to do more testing. oh, and the new deprecation thing is nice, but it took me a while to notice. the text is tiny at high DPI.

edit: here's some code that generates a 8x8 grid of 64 small (64x64) canvases, and draws a white rectangle to them. you should just see a 512x512 white square. when you press any keyboard key it'll regenerate all 64 canvases. if I mash the keyboard to make a ton of canvases, some will be eventually black, and if it's like what I've experienced in my game it won't generate an error but you can't draw anything to them, they're opaque black. code runs on both 0.10.2 and 11.0, never generates a black square in 0.10.2, predictably generates black squares in 11.0. in my testing it's pretty consistently happening between 64 and 131 keypresses, and so on, getting worse over time.

I'm using the appimage on arch linux with vega 56 and open source drivers, and it's the same story with intel integrated graphics on a laptop.

Code: Select all

lg = love.graphics
canvas = {}
count = 0
function reload()
	count = count + 1
	canvas = {}
	for i = 0,63 do
		canvas[i] = lg.newCanvas(64,64)
		canvas[i]:renderTo(function() lg.rectangle("fill", 0,0, 64,64) end)
	end
end

function love.load() reload() end
function love.keypressed() reload() end

function love.draw()
	for i = 0,63 do lg.draw(canvas[i], i%(8)*64, math.floor(i/8)*64) end
	lg.print(count, 520, 0, 0, 4)
end
1522645991.png
1522645991.png (9.29 KiB) Viewed 1020 times
Last edited by eouppdru on Mon Apr 02, 2018 5:44 am, edited 1 time in total.
PGP: 9D05F9CC4FB3DEA617ADCDDA355A9D99CBE1CC1B

User avatar
ivan
Party member
Posts: 1313
Joined: Fri Mar 07, 2008 1:39 pm
Contact:

Re: LÖVE 11.0 released!

Post by ivan » Mon Apr 02, 2018 5:44 am

Cool. One of my proposals body:isTouching(other) has made it into the new version. :)
Would be great if we get body:getTransform() and contact:getOther() in the future too.
Well done!

User avatar
zorg
Party member
Posts: 2367
Joined: Thu Dec 13, 2012 2:55 pm
Location: Absurdistan, Hungary
Contact:

Re: LÖVE 11.0 released!

Post by zorg » Mon Apr 02, 2018 6:31 am

ThiefOfPringles wrote:
Mon Apr 02, 2018 2:48 am
Running the installer on Windows 10 produces some interesting text...
https://i.imgur.com/W46ZHjz.png
Maybe it's some kind of ASCII - Unicode mixup?
Indeed, NSIS fails to interpret the letter Ö, not sure what the source and destination encoding is though that fails; this isn't a new issue though. Edit: tries to decode UTF-8 "Ö" with ISO-8859-1.
pixelicidio wrote:
Mon Apr 02, 2018 3:20 am
But this was a big-breaking-code change:
Changed colour values to be in the range 0-1, rather than 0-255
Well, now the 11.0 version change makes more sense! :D
Me and my stuff :3True Neutral Aspirant. Why, yes, i do indeed enjoy sarcastically correcting others when they make the most blatant of spelling mistakes. No bullying or trolling the innocent tho.

davidmekersa
Prole
Posts: 9
Joined: Wed Dec 30, 2015 6:30 pm

Re: LÖVE 11.0 released!

Post by davidmekersa » Mon Apr 02, 2018 7:14 am

pixelicidio wrote:
Mon Apr 02, 2018 3:20 am
Is good to know Love2D have a new release to keep the project up to date.

But this was a big-breaking-code change:
Changed colour values to be in the range 0-1, rather than 0-255
Saludos!
You're right... I produced hundred of tutorials videos for Love and now I need to check which one is using colors.
Corona SDK did the same once upon a time, a big mess too.

User avatar
raidho36
Party member
Posts: 1685
Joined: Mon Jun 17, 2013 12:00 pm

Re: LÖVE 11.0 released!

Post by raidho36 » Mon Apr 02, 2018 7:53 am

eouppdru wrote:
Mon Apr 02, 2018 4:50 am
after updating my game to 11.0, it seems to sometimes not create canvases. it doesn't produce an error, just sometimes the canvases are all black and drawing to them does nothing.
Can confirm. Apparently it has something to do with the canvases getting garbage collected and re-created from the same memory. Also happens if you release the canvas manually. I guess the new version doesn't release GL objects properly? The last one didn't had this problem.
Last edited by raidho36 on Mon Apr 02, 2018 8:25 am, edited 2 times in total.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests