0.6.0 Update

General discussion about LÖVE, Lua, game development, puns, and unicorns.
User avatar
bartbes
Sex machine
Posts: 4944
Joined: Fri Aug 29, 2008 10:35 am
Location: The Netherlands
Contact:

Re: 0.6.0 Update

Post by bartbes » Thu Oct 22, 2009 2:17 pm

I saw it, it is known, but I have no idea what the problem or the solution is, I leave that to the one with the windows debugger.. (eh, rude?)

User avatar
Robin
The Omniscient
Posts: 6506
Joined: Fri Feb 20, 2009 4:29 pm
Location: The Netherlands
Contact:

Re: 0.6.0 Update

Post by Robin » Thu Oct 22, 2009 2:19 pm

kalle2990 wrote:Did you see my bug, or is it already known?
I'm running on Windows Vista Service Pack 2, and each time I close the LÖVE window the program stops responding and I have to click "End Program". I also noticed the same thing happening when I'm trying to print stuff using print(), are these stuff connected to each other?
Have you submitted this to the bug tracker?
Help us help you: attach a .love.

User avatar
kalle2990
Party member
Posts: 245
Joined: Sat Sep 12, 2009 1:17 pm
Location: Sweden

Re: 0.6.0 Update

Post by kalle2990 » Thu Oct 22, 2009 3:20 pm

Umm... I forgot about that, will do it right away ^^

User avatar
rude
Administrator
Posts: 1051
Joined: Mon Feb 04, 2008 3:58 pm
Location: Oslo, Norway

Re: 0.6.0 Update

Post by rude » Thu Oct 22, 2009 4:09 pm

bartbes wrote:I leave that to the one with the windows debugger.. (eh, rude?)
As long as you deal with most of the Linux stuff. :P

LÖVE redirects its stdout to a file in the same directory where love.exe resides. Should probably redirect to %APPDATA%\LOVE\ instead.

User avatar
kalle2990
Party member
Posts: 245
Joined: Sat Sep 12, 2009 1:17 pm
Location: Sweden

Re: 0.6.0 Update

Post by kalle2990 » Thu Oct 22, 2009 4:19 pm

Which means you will fix it in the next build?

User avatar
Sslaxx
Citizen
Posts: 57
Joined: Sat Feb 14, 2009 8:54 pm
Location: Malvern, Worcs, UK
Contact:

Re: 0.6.0 Update

Post by Sslaxx » Sat Oct 24, 2009 11:16 pm

Interesting, music appears to be (semi) working in the 24/10 build, but not sound. Also, gone back to the old love.<whatever> scheme instead of "fill" or "kpenter", then?

So far:
* Sound effects not working (get a buzz or a click instead).
* Music loads and plays, but doesn't stop when you tell it to play something else. It overlaps instead - 0.5.0 would just stop playing one tune and switch to the other.
* Can you make up your mind which schema to use for things like input and drawing? "fill" or love.draw_fill? You could always have it so that love.draw_fill = "fill", thus meaning you could use either schema in a command like love.graphics.rectangle.

User avatar
rude
Administrator
Posts: 1051
Joined: Mon Feb 04, 2008 3:58 pm
Location: Oslo, Norway

Re: 0.6.0 Update

Post by rude » Sat Oct 24, 2009 11:41 pm

Sslaxx wrote:Sound effects not working (get a buzz or a click instead).
They should be. Attach the files and/or code you're using.
Sslaxx wrote:Music loads and plays, but doesn't stop when you tell it to play something else. It overlaps instead - 0.5.0 would just stop playing one tune and switch to the other.
0.5.0 does that because it sucks (i.e. is only able to play one "Music" at a time).
Sslaxx wrote:Can you make up your mind which schema to use for things like input and drawing? "fill" or love.draw_fill?
It should only be strings.

I'm starting to suspect you're not really testing the 94ad57cb6b2f build. Perhaps something failed in the "bulletproof" build system. Which OS are you using?

User avatar
Sslaxx
Citizen
Posts: 57
Joined: Sat Feb 14, 2009 8:54 pm
Location: Malvern, Worcs, UK
Contact:

Re: 0.6.0 Update

Post by Sslaxx » Sat Oct 24, 2009 11:49 pm

On the bug tracker, tickets 87 and 88. Using the most recent x86 build of LÖVE on Ubuntu 9.10RC (downloaded and installed it over an hour ago).

From a strings dump of the version installed.

Code: Select all

	love.draw = function()
		lists.b:draw()
		-- Ground
		love.graphics.setColor(146, 201, 87)
		love.graphics.rectangle(love.draw_fill, 0, 530, 800, 70)
		love.graphics.setColor(205, 227, 161)
		love.graphics.rectangle(love.draw_fill, 0, 520, 800, 10)
		love.graphics.setColor(255, 255, 255)
		lists.f:draw()
	end
And yes, tried removing/purging and then re-installing it, still same issues.

daveberk
Prole
Posts: 3
Joined: Wed Oct 07, 2009 5:36 pm

Re: 0.6.0 Update

Post by daveberk » Sun Oct 25, 2009 10:50 am

Hi, new guy here.

Where can I get the 0.6.0 source? I searched around a bit but couldn't find the SVN(?) project address.

User avatar
rude
Administrator
Posts: 1051
Joined: Mon Feb 04, 2008 3:58 pm
Location: Oslo, Norway

Re: 0.6.0 Update

Post by rude » Sun Oct 25, 2009 11:48 am


Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests