0.6.0 Update

General discussion about LÖVE, Lua, game development, puns, and unicorns.
philnelson
Prole
Posts: 48
Joined: Sun Feb 01, 2009 3:32 am

Re: 0.6.0 Update

Post by philnelson »

Thanks a lot, anjo.
User avatar
Fizzadar
Prole
Posts: 30
Joined: Mon Oct 26, 2009 6:18 pm

Re: 0.6.0 Update

Post by Fizzadar »

OK, I installed the stuff via Macports, which cut almost all the fatal errors. However, it still won't compile. Apparently 'ft2build.h' doesn't exist:

Code: Select all

// FreeType2
#include <ft2build.h>
Any chance someone could just upload me a copy? I've just spent an hour getting nowhere, I just want to code my game :(
User avatar
bmelts
Party member
Posts: 380
Joined: Fri Jan 30, 2009 3:16 am
Location: Wiscönsin
Contact:

Re: 0.6.0 Update

Post by bmelts »

The newest commit is out, making OS X building from source a lot easier! (and fixing your ft2build.h problem too!)

Step 1 is downloading the newest frameworks - there are two new ones to put in /Library/Frameworks (replacements for the two dylibs you had to put in platform/macosx): http://dl.getdropbox.com/u/1830330/Frameworks.zip

Step 2 is grabbing the latest source. That's easy enough.

Step 3 is hitting Build and hoping that I didn't screw something up again. (I think I didn't!)
User avatar
Fizzadar
Prole
Posts: 30
Joined: Mon Oct 26, 2009 6:18 pm

Re: 0.6.0 Update

Post by Fizzadar »

I believe the frameworks are missing the mpg123.framework folder, because it failed due to no including that, apart from that, it was fine.

EDIT: I grabbed the framework from the old frameworks ZIP, building now...

Failed again says the file 'libltdl.3.dylib' doesn't exist, yet it does...

There's also about 10,000 warnings about classes and unused variables.

EDIT 2: got a picture of the error so I don't have to type it all out: http://winsaucestudios.com/forum/index. ... tem;id=233
User avatar
bmelts
Party member
Posts: 380
Joined: Fri Jan 30, 2009 3:16 am
Location: Wiscönsin
Contact:

Re: 0.6.0 Update

Post by bmelts »

Christ, I'm dumb. No one let me do things at night ever again.

The 10,000 warnings are because I have practically every warning flag turned on in the compiler, so you shouldn't really worry about those.

The libltdl.3.dylib is because I'm really stupid. Type this in the Terminal for a quick fix:

Code: Select all

install_name_tool -change @executable_path/../Frameworks/mpg123.framework/Resources/libltdl.3.dylib /Library/Frameworks/mpg123.framework/Resources/libltdl.3.dylib /Library/Frameworks/mpg123.framework/mpg123
That should help. It will also make the .app only work on your machine (or any other machine with mpg123.framework in /Library/Frameworks, which isn't many since it's a custom framework). I'll patch the Xcode project when I have a chance.
User avatar
Fizzadar
Prole
Posts: 30
Joined: Mon Oct 26, 2009 6:18 pm

Re: 0.6.0 Update

Post by Fizzadar »

Haha! It worked!

T_T it crashes on start "love quit unexpectedly".

Crap.
User avatar
bmelts
Party member
Posts: 380
Joined: Fri Jan 30, 2009 3:16 am
Location: Wiscönsin
Contact:

Re: 0.6.0 Update

Post by bmelts »

:cry:

You should be able to click the "Report..." button and see the reason why it quit unexpectedly. I had some problems with that, but I thought I fixed them before committing.. :?
User avatar
Fizzadar
Prole
Posts: 30
Joined: Mon Oct 26, 2009 6:18 pm

Re: 0.6.0 Update

Post by Fizzadar »

Code: Select all

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: /Users/bill/libs/lib/libmodplug.0.dylib
  Referenced from: /Users/Nick/love/platform/macosx/build/Release/love.app/Contents/MacOS/love
  Reason: image not found
:S
User avatar
bmelts
Party member
Posts: 380
Joined: Fri Jan 30, 2009 3:16 am
Location: Wiscönsin
Contact:

Re: 0.6.0 Update

Post by bmelts »

ffffffffffff :x

I fixed that, I KNOW I fixed that. Seriously. But apparently not, agggh.

Run this in Terminal (it's all one line):

Code: Select all

install_name_tool -change /Users/bill/libs/lib/libmodplug.0.dylib @executable_path/../Frameworks/libmodplug.framework/libmodplug /Users/Nick/love/platform/macosx/build/Release/love.app/Contents/MacOS/love
If my prediction is correct, if you try to run it now, it will then crash again, for a similar reason. Copy the part after "Library not loaded:", and then type this in Terminal:

Code: Select all

install_name_tool -change <paste the path from the error message here> @executable_path/../Frameworks/mpg123.framework/mpg123 /Users/Nick/love/platform/macosx/build/Release/love.app/Contents/MacOS/love
Ideally, that should fix things. Since apparently my fix didn't actually take. :brows:
User avatar
Fizzadar
Prole
Posts: 30
Joined: Mon Oct 26, 2009 6:18 pm

Re: 0.6.0 Update

Post by Fizzadar »

YEEEEEEEEEEEESSSSSS!

Thanks so much for all the help :)
Post Reply

Who is online

Users browsing this forum: No registered users and 19 guests