Error Analyzing App Version -- Xcode upload fails

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
meteopath
Prole
Posts: 15
Joined: Sun May 15, 2022 12:41 am

Error Analyzing App Version -- Xcode upload fails

Post by meteopath »

My project builds and archives successfully in Xcode. The app outputted by Xcode works on my computer. But every attempt to upload it to my account in App Store Connect fails with the error message: Error Analyzing App Version.

I have made a few dozen unsuccessful attempts in the last week. Of those attempts, at least a dozen were fresh rebuilds with all-new libraries, .love files and bundle ids. I have tried as many different combinations as I could think of for version/build numbers and name. I'm not sure where I am going wrong. But I have a couple of ideas:

1. Version number. The "Version" field under the target's General pane in Xcode loads as "11.4". Should I change this to 11.5? Should I change this to 1.0? (I have tried both). Or does the fact that it loads as 11.4 show that I've done something wrong in preparing the materials before launching Xcode?

2. plist. It is either shorter in Xcode than it is as a text file in the downloadable Love app, or I'm just not looking in the right places for the rest of the fields. Specifically, in Xcode, I'm not seeing the UTExportedTypeDeclarations and wondering if maybe they remain attached to the project and are what is preventing my app to upload and be registered with a bundle id of my own.

These are just two guesses, so any other suggestions would also be very much appreciated.
Post Reply

Who is online

Users browsing this forum: Google [Bot] and 58 guests