Absolute beginner to programming

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
FruitGroot
Prole
Posts: 1
Joined: Tue Aug 29, 2017 1:34 am

Absolute beginner to programming

Post by FruitGroot »

Ive been trying to get a simple hello world to run in love2d for hours. I dont know what im doing wrong nothing i create in Zerobrane will run in Love0.10.2 , not even Zerobrane's LOVE-samples. I tried downloading a user created game from the forums to see if it was just my love file not working properly but it ran fine. Does anyone have any idea whats going on, im really confused over here.
sphyrth
Party member
Posts: 258
Joined: Mon Jul 07, 2014 11:04 am
Contact:

Re: Absolute beginner to programming

Post by sphyrth »

If there's an error message, can you post a screenshot of it?
User avatar
Mutos
Prole
Posts: 29
Joined: Sat Aug 05, 2017 7:05 am
Contact:

Re: Absolute beginner to programming

Post by Mutos »

Hi FruitGroot,


Could you post console text or screenshots of your error messages, or even your .love, so we can try to figure out what went wrong.

It must be a small spanner in the works, but if you don't know what to search for, it can take you hours to stumble upon it.

You talk about a .love file : did you check to have only the files and not the folder compressed ? Name of main.lua and conf.lua, if you are running LInux, case matters. Also, try to run it without making a .love file, they are only needed for distribution. Just open a console, cd to the folder your main.lua resides into, type "love .", and it should run.

With next to no information, that's the only no-brainer advices I can give you... Hope it helps...
Benoît 'Mutos' Robin
Hoshikaze 2250, Sci-Fi universe in collaborative writing
Post Reply

Who is online

Users browsing this forum: No registered users and 20 guests