LOVE window vertical stretch problem (Windows 10)?

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
Posts: 4
Joined: Thu Aug 14, 2014 11:42 pm

LOVE window vertical stretch problem (Windows 10)?

Post by geckojsc » Wed Nov 01, 2017 1:11 pm


Confirmed my suspicions that this is a recent bug in Intel drivers.
It affects certain other programs including Blender: ... pic/735289

I guess I'll try downgrading my drivers for now, to see if that fixes it.

[edit 2]

The earliest version of the Intel Graphics Driver available for download is, which is the one which introduced the bug. If anyone knows a way I could downgrade to or earlier, please give me a shout

[edit 3]

Fortunately the Dell site has some downloads from 2016. I installed the most recent of those and it fixed the problem. Kind of sucks that this problem will be affecting a large number of Intel HD Graphics users for the foreseeable future (though I have no way of testing on the very latest drivers because Dell lags behind with updates and doesn't allow un-approved drivers, such as those on the Intel website, to be installed manually)


Hey everyone,
I've recently found that all my LOVE projects are being stretched vertically by a small amount, such that the top of the display extends behind the title bar. This never previously happened, but now it happens for every LOVE game, and even for older LOVE versions. I can only assume it has been caused by a driver update or something, but I have no idea how to go about fixing it.

Example code:
Draw a 100x100 rectangle in the centre of the screen, and 4 circles (one in each corner)

Code: Select all

function love.draw()
    local w, h ="fill", w/2-50, h/2-50, 100, 100)"fill", 0, 0, 50, 32)"fill", w, 0, 50, 32)"fill", 0, h, 50, 32)"fill", w, h, 50, 32)
Result (with annotation)
Untitled-1.png (70.85 KiB) Viewed 1094 times
My laptop screen is 1.5x the standard DPI, but the problem still occurs when I disable DPI scaling, and even when using an external monitor.

However, the problem doesn't occur in fullscreen mode, or when running the game in borderless window mode.

Some info about my system
OS Name: Microsoft Windows 10 Home
Version: 10.0.15063 Build 15063
System Manufacturer: Dell Inc.
System Model: XPS 13 9350
System Type: x64-based PC
Processor: Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz, 2400 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date: Dell Inc. 1.5.1, 18/08/2017
Display: Intel(R) HD Graphics 520
Driver Version:
Resolution: 1920 x 1080 x 59 hertz
Any help or suggestions would be greatly appreciated!

Post Reply

Who is online

Users browsing this forum: darkfrei and 15 guests