Building Game in xCode 9.x

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
kippllo
Prole
Posts: 6
Joined: Sun Apr 15, 2018 2:23 am

Building Game in xCode 9.x

Post by kippllo » Sun Apr 15, 2018 2:30 am

Hello, I'm new to this forum so hello!
I've run into a problem when trying to build a love game for iOS using the fuse technique...
Screen Shot 2018-04-15 at 5.50.37 PM.png
Screen Shot 2018-04-15 at 5.50.37 PM.png (57.46 KiB) Viewed 253 times
All the frameworks have errors and are shown in red, and the build always fails.
I've done some digging and most people say to reload the framework, or manually enter the framework path. But I don't know how to do this or if it would even work.

Any help is greatly appreciated!
Thank you!
-kip

Update:
Screen Shot 2018-04-15 at 6.08.02 PM.png
Screen Shot 2018-04-15 at 6.08.02 PM.png (129.25 KiB) Viewed 252 times
Attachments
Screen Shot 2018-04-15 at 6.07.47 PM.png
Screen Shot 2018-04-15 at 6.07.47 PM.png (477.72 KiB) Viewed 252 times
Last edited by kippllo on Sun Apr 15, 2018 11:13 pm, edited 2 times in total.

User avatar
slime
Solid Snayke
Posts: 2763
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: Building Game in xCode 9.x

Post by slime » Sun Apr 15, 2018 7:48 pm

Your screenshot didn't get posted correctly, but if the errors are related to linking Metal functions, the iOS source code for LÖVE 11.1 – released today – resolved that (by weak-linking with Metal.framework).

kippllo
Prole
Posts: 6
Joined: Sun Apr 15, 2018 2:23 am

Re: Building Game in xCode 9.x

Post by kippllo » Sun Apr 15, 2018 11:15 pm

Ok I downloaded the update, but I'm still getting the same problem. I would like to note that I tried building to the simulator instead of my iPhone and it worked fine for that. The problem seems to be in building for a real device...

kippllo
Prole
Posts: 6
Joined: Sun Apr 15, 2018 2:23 am

Re: Building Game in xCode 9.x

Post by kippllo » Sun Apr 15, 2018 11:15 pm

I aslo uploaded a pic of the error message

User avatar
slime
Solid Snayke
Posts: 2763
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: Building Game in xCode 9.x

Post by slime » Sun Apr 15, 2018 11:39 pm

Are you sure you downloaded the LÖVE 11.1 iOS source? It works for me, and has Metal.framework listed under the frameworks dropdown and set to weak-link:
Screen Shot 2018-04-15 at 8.38.56 PM.png
Screen Shot 2018-04-15 at 8.38.56 PM.png (383.71 KiB) Viewed 250 times

Also note that you'll need to change the code-signing and bundle identifier settings in the General tab of the love-ios target, in order to use your Apple Developer account to deploy LÖVE to your phone.

kippllo
Prole
Posts: 6
Joined: Sun Apr 15, 2018 2:23 am

Re: Building Game in xCode 9.x

Post by kippllo » Mon Apr 16, 2018 12:40 am

Ok so I thought I had downloaded the new source, but I guess I didn't.
I have now downloaded the right source and it worked!!! Thank you so much!!!
One more question, when I compile in xCode I get TONS of warnings, but it still works. Is that normal?

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests