Error Analyzing App Version -- Xcode upload fails

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
meteopath
Prole
Posts: 18
Joined: Sun May 15, 2022 12:41 am

Error Analyzing App Version -- Xcode upload fails

Post by meteopath »

My project builds and archives successfully in Xcode. The app outputted by Xcode works on my computer. But every attempt to upload it to my account in App Store Connect fails with the error message: Error Analyzing App Version.

I have made a few dozen unsuccessful attempts in the last week. Of those attempts, at least a dozen were fresh rebuilds with all-new libraries, .love files and bundle ids. I have tried as many different combinations as I could think of for version/build numbers and name. I'm not sure where I am going wrong. But I have a couple of ideas:

1. Version number. The "Version" field under the target's General pane in Xcode loads as "11.4". Should I change this to 11.5? Should I change this to 1.0? (I have tried both). Or does the fact that it loads as 11.4 show that I've done something wrong in preparing the materials before launching Xcode?

2. plist. It is either shorter in Xcode than it is as a text file in the downloadable Love app, or I'm just not looking in the right places for the rest of the fields. Specifically, in Xcode, I'm not seeing the UTExportedTypeDeclarations and wondering if maybe they remain attached to the project and are what is preventing my app to upload and be registered with a bundle id of my own.

These are just two guesses, so any other suggestions would also be very much appreciated.
meteopath
Prole
Posts: 18
Joined: Sun May 15, 2022 12:41 am

Re: Error Analyzing App Version -- Xcode upload fails

Post by meteopath »

Hi, updating my own post. A week later, I'm still stuck. I'm trying with Apple Support, but I don't feel great about my chances. Thought I'd check back here again and include some screen shots this time. All of my attempts still fail during upload with the Error Analyzing App Version message (My builds and archives prior to upload are successful). I wanted to ask about a window that comes up during upload, just before the failures. It is the "preparing app record" window and has a field, "name", that gets autocompleted with "love". This is the screen:

Image

"love" in the name field is wrong, because when I click next, I get this error:

Image

So I return to the "preparing app record" window and change the name field from "love" to "nqtTest1" or whatever name I'm using. At that point, the error window becomes: Error Analyzing App Version.

I've tried to figure out where "love" as name comes from. In a later test, before building and archiving, I changed the scheme of the project from "love-macosx" to the name of my app nqtTest5. This resulted in changes after archiving in the Organizer window:

Image

In the shadowy part in the upper left, you can see that it has "nqtTest5" in two places where in the first screen shot it was "love-macosx". But that doesn't change that the name field is still autocompleted with "love".

I'd be thrilled with any help. Guesses also very welcome. --Just previewed this before posting, and if the images appear all at the bottom, the intended order is chronological 3.10.33 > 3.10.40 > 7.28.32. Thanks very much.
Attachments
Screen Shot 2022-08-13 at 3.10.33 PM.png
Screen Shot 2022-08-13 at 3.10.33 PM.png (480.86 KiB) Viewed 1058 times
Screen Shot 2022-08-13 at 7.28.32 PM.png
Screen Shot 2022-08-13 at 7.28.32 PM.png (518.15 KiB) Viewed 1058 times
Screen Shot 2022-08-13 at 3.10.40 PM.png
Screen Shot 2022-08-13 at 3.10.40 PM.png (460.44 KiB) Viewed 1058 times
Post Reply

Who is online

Users browsing this forum: No registered users and 23 guests