Page 2 of 2

Re: [11.3] AdMob support for iOS + EU Consent

Posted: Fri Feb 07, 2020 3:18 pm
by bio1712
Updated to LÖVE 11.3.
I've updated the AdMob SDK and made some changes.
If you update from a previous version, open the file info.plist and set GADApplicationIdentifier with your AdMob app ID.

Re: [11.3] AdMob support for iOS + EU Consent

Posted: Sat Feb 08, 2020 11:20 pm
by gianmichele
Brilliant! Thank you very much :)

Re: [11.3] AdMob support for iOS + EU Consent

Posted: Mon Jul 27, 2020 10:22 am
by joogur
Hello

Thank you very much for your post it really helped! I can successfully build my app with XCode, however, if I want to open my app on the phone, I get the following error:

Error

boot.lua:507: module 'love.ads' not found:
no field package.preload['love.ads']
no 'love/ads' in LOVE game directories.
no file 'love/ads' in LOVE paths.
no file './love/ads.lua'
no file '/usr/local/share/luajit-2.1.0-beta3/love/ads.lua'
no file '/usr/local/share/lua/5.1/love/ads.lua'
no file '/usr/local/share/lua/5.1/love/ads/init.lua'
no file './love/ads.so'
no file '/usr/local/lib/lua/5.1/love/ads.so'
no file '/usr/local/lib/lua/5.1/loadall.so'
no file './love.so'
no file '/usr/local/lib/lua/5.1/love.so'
no file '/usr/local/lib/lua/5.1/loadall.so'


Traceback

[C]: in function 'require'
[C]: in function 'xpcall'
[C]: in function 'xpcall'

Did anyone already face same problem or knows the solution to this?

Thank you very much.

Re: [11.3] AdMob support for iOS + EU Consent

Posted: Sat Aug 08, 2020 6:24 am
by vestman
joogur wrote: Mon Jul 27, 2020 10:22 am Hello

Thank you very much for your post it really helped! I can successfully build my app with XCode, however, if I want to open my app on the phone, I get the following error:

Error

boot.lua:507: module 'love.ads' not found:
...
Did anyone already face same problem or knows the solution to this?

Thank you very much.
I'm getting the same error. Did you find a solution to this?