Steamworks FFI

Showcase your libraries, tools and other projects that help your fellow love users.
pauljessup
Party member
Posts: 189
Joined: Wed Jul 03, 2013 4:06 am

Re: Steamworks FFI

Post by pauljessup »

Saw your responsive above, and put it into the .app folder, and that seemed to work.

However, there is a new error now, see attached
Screen Shot 2021-01-25 at 1.35.42 PM.png
Screen Shot 2021-01-25 at 1.35.42 PM.png (56.87 KiB) Viewed 5822 times
pauljessup
Party member
Posts: 189
Joined: Wed Jul 03, 2013 4:06 am

Re: Steamworks FFI

Post by pauljessup »

the line that's throwing the error-

if not steam.init() or not steam.isRunning() then
User avatar
ivan
Party member
Posts: 1721
Joined: Fri Mar 07, 2008 1:39 pm
Contact:

Re: Steamworks FFI

Post by ivan »

Do you have anywhere debug = {} in your code? Looks like your code may have overwritten the default debug library.
pauljessup
Party member
Posts: 189
Joined: Wed Jul 03, 2013 4:06 am

Re: Steamworks FFI

Post by pauljessup »

Yes, yes I do. I have a complex debug setup that makes tracking things easy, hence why it's also global. I created a different namespace for it, and so far, everything seems okay.
pauljessup
Party member
Posts: 189
Joined: Wed Jul 03, 2013 4:06 am

Re: Steamworks FFI

Post by pauljessup »

Thanks for the help- and the good library. Works great, now that I got those issues out of the way
User avatar
ivan
Party member
Posts: 1721
Joined: Fri Mar 07, 2008 1:39 pm
Contact:

Re: Steamworks FFI

Post by ivan »

Ok, so I have a pretty big update featuring full HTML documentation:
https://2dengine.com/?p=sworks
User avatar
ivan
Party member
Posts: 1721
Joined: Fri Mar 07, 2008 1:39 pm
Contact:

Re: Steamworks FFI

Post by ivan »

Ok, I have released an update to support the brand new version: Steamworks v1.51!
groverburger wrote: Sun Jan 24, 2021 12:19 am I'm logged in to Steam, and I have my libsteam_api.dylib in my .app/Contents/Frameworks, so I think everything should be in order. I'm also using macOS Big Sur 11.1 and Steam SDK v1.5.
I can confirm that this issue should be fixed on Linux.
Can you pull the latest version and test it on Mac please.
User avatar
groverburger
Prole
Posts: 35
Joined: Tue Oct 30, 2018 9:27 pm

Re: Steamworks FFI

Post by groverburger »

ivan wrote: Sat Jan 30, 2021 5:41 pm Ok, I have released an update to support the brand new version: Steamworks v1.51!
I can confirm that this issue should be fixed on Linux.
Can you pull the latest version and test it on Mac please.
Just tested it on mac - seems to work! I got my "logged in successfully" message showing up in terminal.

I don't know if this is just a mac thing or even if this is a problem, but shift-tab doesn't pull up the steam overlay like it does on windows. I assume it will work when launched through steam, but it isn't working on my mac while testing. Do you know anything about this?
User avatar
ivan
Party member
Posts: 1721
Joined: Fri Mar 07, 2008 1:39 pm
Contact:

Re: Steamworks FFI

Post by ivan »

I don't have a Mac to test this, so I'm not really sure.

There is an example script that can be used to test the library:
https://bitbucket.org/itraykov/sworks-f ... /examples/

and also, I don't miss the new documentation:
https://2dengine.com/?p=sworks
Teo434
Prole
Posts: 11
Joined: Mon Apr 27, 2020 12:21 am

Re: Steamworks FFI

Post by Teo434 »

Hello! I've been trying out this framework on windows and it works perfectly fine, however, when I tried to use it on linux (on 2 different computers and os's) I keep getting this error:

Code: Select all

Your Steam client doesn't have a connection to the back-end
Looking a bit deeper into the errors reveals that

Code: Select all

[S_API] SteamAPI_Init(): Sys_LoadModule failed to load: /home/teo434/snap/love/26/.steam/sdk64/steamclient.so
I've restarted steam, restarted my os, reinstalled steam, changed proton versions, yet still nothing seems to be working... :|
If you're curious, my game.love contains: sworks, libsteam_api.so and main.lua, I'm using the love2d demo from the bitbucket repo too. Not entirely sure this would change anything at all but, I'm running love 11.2
Lastly, both steam.init() and steam.isRunning() return false.
Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests