Love2D 11.2 Requirements? [SOLVED]

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
User avatar
Darlex
Party member
Posts: 117
Joined: Sun Sep 24, 2017 10:02 am
Location: absolutely not Chile
Contact:

Love2D 11.2 Requirements? [SOLVED]

Post by Darlex » Fri Mar 15, 2019 11:26 pm

I need the love2d's requirements for Windows, MacOS, Linux, iOS and Android.
Where i can get them?
D0NM wrote:
Sat Mar 16, 2019 7:50 am
:joker:
Thereis a nice answer already.
slime wrote:
Thu Apr 14, 2016 11:10 am
LÖVE works on Windows XP and Mac OS 10.7 (Lion). The main thing is that it requires an OpenGL 2.1 or OpenGL ES 2-capable graphics card as well as graphics drivers that provide said OpenGL version.

The oldest OpenGL 2.1-capable desktop GPUs are (roughly) the nvidia GeForce 6000 series from 2004, the ATI Radeon 9000 series from 2003, and the Intel GMA X or Intel HD series from 2007 or 2010 (depending on the graphics driver).
viewtopic.php?t=82086
Last edited by Darlex on Sat Mar 16, 2019 2:39 pm, edited 1 time in total.
culdud uwu

User avatar
Stifu
Citizen
Posts: 71
Joined: Mon Mar 14, 2016 9:53 am
Contact:

Re: Love2D 11.2 Requirements?

Post by Stifu » Sat Mar 16, 2019 6:24 am

What do you mean "requirements"? Hardware, software? To run what, a "hello world"?
Zabuyaki, our upcoming beat 'em up: https://www.zabuyaki.com

User avatar
arampl
Party member
Posts: 248
Joined: Mon Oct 20, 2014 3:26 pm

Re: Love2D 11.2 Requirements?

Post by arampl » Sat Mar 16, 2019 6:44 am

Stifu wrote:
Sat Mar 16, 2019 6:24 am
What do you mean "requirements"? Hardware, software? To run what, a "hello world"?
=D. I have never laughed so hard in my life.

But seriously, I wasn't able to run Love2D application on videocard with OpenGL 2.0 or lower.

User avatar
zorg
Party member
Posts: 2615
Joined: Thu Dec 13, 2012 2:55 pm
Location: Absurdistan, Hungary
Contact:

Re: Love2D 11.2 Requirements?

Post by zorg » Sat Mar 16, 2019 7:47 am

Question's probably about opengl version, that's the only thing i can think of, since anything else i can think of (memory, processor usage) highly depends on what and how efficient you code it...
and yes, it would be nice if the wiki had such info; i thought it was OGL 1.3 minimum but maybe that's the GLSL version... i don't know.
Me and my stuff :3True Neutral Aspirant. Why, yes, i do indeed enjoy sarcastically correcting others when they make the most blatant of spelling mistakes. No bullying or trolling the innocent tho.

User avatar
D0NM
Party member
Posts: 206
Joined: Mon Feb 08, 2016 10:35 am
Location: Zabuyaki
Contact:

Re: Love2D 11.2 Requirements?

Post by D0NM » Sat Mar 16, 2019 7:50 am

:joker:
Thereis a nice answer already.
slime wrote:
Thu Apr 14, 2016 11:10 am
LÖVE works on Windows XP and Mac OS 10.7 (Lion). The main thing is that it requires an OpenGL 2.1 or OpenGL ES 2-capable graphics card as well as graphics drivers that provide said OpenGL version.

The oldest OpenGL 2.1-capable desktop GPUs are (roughly) the nvidia GeForce 6000 series from 2004, the ATI Radeon 9000 series from 2003, and the Intel GMA X or Intel HD series from 2007 or 2010 (depending on the graphics driver).
viewtopic.php?t=82086
Our LÖVE Gamedev blog Zabuyaki (an open source retro beat 'em up game). Follow @Zabuyaki.
Twitter @FaMeSoft / GP32 Free Platformer: SUPER PLUSHA
:joker: LÖVE & Lua Video Lessons in Russian / Видео уроки по LÖVE и Lua :joker:

User avatar
zorg
Party member
Posts: 2615
Joined: Thu Dec 13, 2012 2:55 pm
Location: Absurdistan, Hungary
Contact:

Re: Love2D 11.2 Requirements?

Post by zorg » Sat Mar 16, 2019 8:51 am

D0NM wrote:
Sat Mar 16, 2019 7:50 am
...
Cool, now lets ask slime on discord or here whether we can add this info somewhere on the more visible pages of the wiki. maybe with the versioning table, since ogl requirements iirc changed with a few versions.
Me and my stuff :3True Neutral Aspirant. Why, yes, i do indeed enjoy sarcastically correcting others when they make the most blatant of spelling mistakes. No bullying or trolling the innocent tho.

User avatar
Darlex
Party member
Posts: 117
Joined: Sun Sep 24, 2017 10:02 am
Location: absolutely not Chile
Contact:

Re: Love2D 11.2 Requirements?

Post by Darlex » Sat Mar 16, 2019 2:38 pm

Stifu wrote:
Sat Mar 16, 2019 6:24 am
What do you mean "requirements"? Hardware, software? To run what, a "hello world"?
A fricking lot of IF statements and For loops.
culdud uwu

User avatar
Darlex
Party member
Posts: 117
Joined: Sun Sep 24, 2017 10:02 am
Location: absolutely not Chile
Contact:

Re: Love2D 11.2 Requirements?

Post by Darlex » Sat Mar 16, 2019 2:38 pm

D0NM wrote:
Sat Mar 16, 2019 7:50 am
:joker:
Thereis a nice answer already.
slime wrote:
Thu Apr 14, 2016 11:10 am
LÖVE works on Windows XP and Mac OS 10.7 (Lion). The main thing is that it requires an OpenGL 2.1 or OpenGL ES 2-capable graphics card as well as graphics drivers that provide said OpenGL version.

The oldest OpenGL 2.1-capable desktop GPUs are (roughly) the nvidia GeForce 6000 series from 2004, the ATI Radeon 9000 series from 2003, and the Intel GMA X or Intel HD series from 2007 or 2010 (depending on the graphics driver).
viewtopic.php?t=82086
Well, that is useful! Thanks
culdud uwu

MrFariator
Party member
Posts: 107
Joined: Wed Oct 05, 2016 11:53 am

Re: Love2D 11.2 Requirements? [SOLVED]

Post by MrFariator » Sat Mar 16, 2019 4:08 pm

Worth noting to the quoted post above is that Windows XP is no longer officially supported since 11.0 (see "Other changes").
-- Run once in a blue moon
if math.random() > 0.99 then
  local account = Twitter:getProfile ( https://twitter.com/GravityCircuit )
  account:post ( currentProgress:getGIF() )
end

User avatar
zorg
Party member
Posts: 2615
Joined: Thu Dec 13, 2012 2:55 pm
Location: Absurdistan, Hungary
Contact:

Re: Love2D 11.2 Requirements?

Post by zorg » Sun Mar 17, 2019 12:48 am

Darlex wrote:
Sat Mar 16, 2019 2:38 pm
Stifu wrote:
Sat Mar 16, 2019 6:24 am
What do you mean "requirements"? Hardware, software? To run what, a "hello world"?
A fricking lot of IF statements and For loops.
Yeah, the requirement for that is you need a computer with a processor and not a vegetable or a wooden chair... :monocle:

An intel 8080 can execute ifs and fors just as well as an intel skylake i7-6700K, the only significant difference (besides the architectural like branch predictions and # of cores) is that whereas the latter can do approximately 4 000 000 000 cycles (not instructions) per second (per core), the former can do only 2 000 000, or naively, there's a 2000x difference between them in speed, and 41 years in terms of when they were first released.

That said, other libs that Löve itself uses may pose a smidge stricter restrictions on hardware elements, but usually, a computer up to the last decade should suffice. As i said before though, things like what you mentioned depend heavily on you, the developer, to write code that's not sub-par in terms of efficiency. (where it's possible to do so.)
Me and my stuff :3True Neutral Aspirant. Why, yes, i do indeed enjoy sarcastically correcting others when they make the most blatant of spelling mistakes. No bullying or trolling the innocent tho.

Post Reply

Who is online

Users browsing this forum: ivan and 6 guests