LÖVE 0.7.2

General discussion about LÖVE, Lua, game development, puns, and unicorns.
User avatar
Nixola
Inner party member
Posts: 1940
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

LÖVE 0.7.2

Post by Nixola » Sun May 13, 2012 4:53 pm

How can I install LÖVE 0.7.2 on Ubuntu 12.04 without overriding LÖVE 0.8.0?
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

User avatar
Davidobot
Party member
Posts: 1149
Joined: Sat Mar 31, 2012 5:18 am
Location: Game-Dev. Land
Contact:

Re: LÖVE 0.7.2

Post by Davidobot » Thu May 17, 2012 5:51 pm

Install it in a different directory.
My library:
LovelyMoon

Check out my current project:
Raycaster

Oh hey, I have a website now!

User avatar
Nixola
Inner party member
Posts: 1940
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: LÖVE 0.7.2

Post by Nixola » Thu May 17, 2012 6:24 pm

Yeah, right.



How?
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

User avatar
Davidobot
Party member
Posts: 1149
Joined: Sat Mar 31, 2012 5:18 am
Location: Game-Dev. Land
Contact:

Re: LÖVE 0.7.2

Post by Davidobot » Thu May 17, 2012 6:29 pm

Nixola wrote:Yeah, right.



How?
In another file, you know download it and place it in another folder, or do you need the download link?
My library:
LovelyMoon

Check out my current project:
Raycaster

Oh hey, I have a website now!

User avatar
Nixola
Inner party member
Posts: 1940
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: LÖVE 0.7.2

Post by Nixola » Thu May 17, 2012 6:33 pm

Ehm... How can I do that on Linux Ubuntu 12.04, a different OS from Windows?
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

User avatar
josefnpat
Inner party member
Posts: 955
Joined: Wed Oct 05, 2011 1:36 am
Location: your basement
Contact:

Re: LÖVE 0.7.2

Post by josefnpat » Thu May 17, 2012 6:51 pm

Nixola wrote:Ehm... How can I do that on Linux Ubuntu 12.04, a different OS from Windows?
I need a working version of 0.7.2 on my computer, so let me do it, and I will post the results.
Missing Sentinel Software | Twitter

FORCIBLY IGNORED.
<leafo> when in doubt delete all of your code
<bartbes> git rm -r *
<bartbes> git commit -m "Fixed all bugs"
<bartbes> git push

User avatar
josefnpat
Inner party member
Posts: 955
Joined: Wed Oct 05, 2011 1:36 am
Location: your basement
Contact:

Re: LÖVE 0.7.2

Post by josefnpat » Thu May 17, 2012 6:56 pm

Basically you're going to have to build it yourself.
Make sure you have the deps installed: https://love2d.org/wiki/make

Here's what I did:

Code: Select all

hg clone ssh://hg@bitbucket.org/rude/love
cd love
hg update 0.7.2
./platform/unix/automagic 
./configure
make
then your binary will be:

Code: Select all

src/love
Image
Missing Sentinel Software | Twitter

FORCIBLY IGNORED.
<leafo> when in doubt delete all of your code
<bartbes> git rm -r *
<bartbes> git commit -m "Fixed all bugs"
<bartbes> git push

User avatar
Nixola
Inner party member
Posts: 1940
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: LÖVE 0.7.2

Post by Nixola » Thu May 17, 2012 7:15 pm

Did './configure', here are the last 2 lines before it stopped:

checking for library containing mng_initialize... no
configure: error: DevIL needs MNG


Here the full terminal output:

Code: Select all

nicola@nicola-DOTS:~/LOVE/love$ ./platform/unix/automagic
Generating src/Makefile.am ...
src/Makefile.am is updated! ^.^
./platform/unix/automagic: line 7: libtoolize: command not found
configure.in:8: error: possibly undefined macro: AC_PROG_LIBTOOL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.in:6: installing `platform/unix/install-sh'
configure.in:6: installing `platform/unix/missing'
src/Makefile.am:3: user variable `DEFAULT_INCLUDES' defined here...
/usr/share/automake-1.11/am/compile.am: ... overrides Automake variable `DEFAULT_INCLUDES' defined here
src/Makefile.am: installing `platform/unix/depcomp'
nicola@nicola-DOTS:~/LOVE/love$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
./configure: line 2450: AC_PROG_LIBTOOL: command not found
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking for library containing sqrt... -lm
checking for library containing SDL_Init... -lSDL
checking for library containing glLoadIdentity... -lGL
checking for library containing alSourcePlay... -lopenal
checking for library containing lua_pcall... -llua5.1
checking for library containing ilInit... -lIL
checking for library containing mng_initialize... no
configure: error: DevIL needs MNG
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

User avatar
josefnpat
Inner party member
Posts: 955
Joined: Wed Oct 05, 2011 1:36 am
Location: your basement
Contact:

Re: LÖVE 0.7.2

Post by josefnpat » Thu May 17, 2012 7:24 pm

Nixola wrote:Did './configure', here are the last 2 lines before it stopped:

checking for library containing mng_initialize... no
configure: error: DevIL needs MNG


Here the full terminal output:

Code: Select all

nicola@nicola-DOTS:~/LOVE/love$ ./platform/unix/automagic
Generating src/Makefile.am ...
src/Makefile.am is updated! ^.^
./platform/unix/automagic: line 7: libtoolize: command not found
configure.in:8: error: possibly undefined macro: AC_PROG_LIBTOOL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.in:6: installing `platform/unix/install-sh'
configure.in:6: installing `platform/unix/missing'
src/Makefile.am:3: user variable `DEFAULT_INCLUDES' defined here...
/usr/share/automake-1.11/am/compile.am: ... overrides Automake variable `DEFAULT_INCLUDES' defined here
src/Makefile.am: installing `platform/unix/depcomp'
nicola@nicola-DOTS:~/LOVE/love$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
./configure: line 2450: AC_PROG_LIBTOOL: command not found
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking for library containing sqrt... -lm
checking for library containing SDL_Init... -lSDL
checking for library containing glLoadIdentity... -lGL
checking for library containing alSourcePlay... -lopenal
checking for library containing lua_pcall... -llua5.1
checking for library containing ilInit... -lIL
checking for library containing mng_initialize... no
configure: error: DevIL needs MNG
Did you install the dependencies?:

Code: Select all

sudo apt-get install build-essential automake libmpg123-dev libmodplug-dev libphysfs-dev libfreetype6-dev libdevil-dev liblua5.1-0-dev libopenal-dev libsdl1.2-dev libvorbis-dev
Missing Sentinel Software | Twitter

FORCIBLY IGNORED.
<leafo> when in doubt delete all of your code
<bartbes> git rm -r *
<bartbes> git commit -m "Fixed all bugs"
<bartbes> git push

User avatar
Nixola
Inner party member
Posts: 1940
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: LÖVE 0.7.2

Post by Nixola » Thu May 17, 2012 7:25 pm

Yes, I did
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests