minimum requirements

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
User avatar
Tricky
Citizen
Posts: 75
Joined: Thu Dec 18, 2014 4:07 pm
Location: Breda, the Netherlands
Contact:

minimum requirements

Post by Tricky » Tue Apr 12, 2016 6:44 pm

Wel, stupid question maybe, but today I tried to demonstrate my current WIP project on somebody's computer which didn't work as OpenGL 2.1 was required (which I never knew, I guess Mac El Capitan (my primary system) has that for default).

Now let's sum of a few minimal requirements (for Love 0.10.x) I need.
Just to get a simple program like

Code: Select all

function love.draw() love.graphics.print("Hello World!") end

on the run. I'm pretty sure it won't work under Windows 1, 2 and 3.11, but which windows version do I need at least? 95? 98? XP? Vista? 10? And which Mac OS X version do I need at least? Snow Leopard? Lion? Yosemite? El Capitan? Minimal version for the Linux kernel? (Windows, Mac and Linux are the platforms I'm aiming for in this project).

I just want to avoid some whi... I mean.... complaints about my game not working because the minimal requirements are not met ;)

User avatar
Beelz
Party member
Posts: 234
Joined: Thu Sep 24, 2015 1:05 pm
Location: New York, USA
Contact:

Re: minimum requirements

Post by Beelz » Tue Apr 12, 2016 7:33 pm

For something as simple as a hello world, there really isn't a minimum spec. However the problem you faced was the computer in question wasn't OpenGL compatible... Some low-end computers(including my laptop) do not come with OpenGL and instead rely on DirectX. In a nutshell, no canvases and no fun :'(

I'm not sure about Mac or Linux, but anything XP or newer should be fine... It depends more on the hardware, not as much on the OS(don't qoute me). That being said, if you plan on developing for v0.10.x, you could provide a disclaimer stating that some lower-end pc's may not be compatible... Other than that, not much you could do other than developing for 0.9.x and completely avoiding canvases and the like.

Code: Select all

if self:hasBeer() then self:drink()
else self:getBeer() end
GitHub -- Website

bobbyjones
Party member
Posts: 712
Joined: Sat Apr 26, 2014 7:46 pm

Re: minimum requirements

Post by bobbyjones » Wed Apr 13, 2016 2:56 am

Beelz wrote:For something as simple as a hello world, there really isn't a minimum spec. However the problem you faced was the computer in question wasn't OpenGL compatible... Some low-end computers(including my laptop) do not come with OpenGL and instead rely on DirectX. In a nutshell, no canvases and no fun :'(

I'm not sure about Mac or Linux, but anything XP or newer should be fine... It depends more on the hardware, not as much on the OS(don't qoute me). That being said, if you plan on developing for v0.10.x, you could provide a disclaimer stating that some lower-end pc's may not be compatible... Other than that, not much you could do other than developing for 0.9.x and completely avoiding canvases and the like.
It's not that it did not come with opengl but more likely that it does not support Opengl 2.1. The minimum specs for Windows is XP and above I believe. With support for Opengl 2.1. On Linux I think as long as you have Opengl 2.1 or opengl es 2 (I'm not sure of the opengl es version number) you would be fine.
Check out my most recent medium post, please give feedback.
Link

User avatar
Tricky
Citizen
Posts: 75
Joined: Thu Dec 18, 2014 4:07 pm
Location: Breda, the Netherlands
Contact:

Re: minimum requirements

Post by Tricky » Thu Apr 14, 2016 10:28 am

Right for Windows I shall then put "Vista" is minimum Windows version just to be safe (and maybe note that XP computer "may" support it). :)
For MacOS, I think I will aim then for "Mavericks" or later (since that is what most new mac applications require).
It's not that it did not come with opengl but more likely that it does not support Opengl 2.1.
That is indeed correct. I once used that PC to play a BlitzMax game I wrote, which uses OpenGL 1.1 and that worked.

Thank you very much ;)

User avatar
slime
Solid Snayke
Posts: 2820
Joined: Mon Aug 23, 2010 6:45 am
Location: Nova Scotia, Canada
Contact:

Re: minimum requirements

Post by slime » Thu Apr 14, 2016 11:10 am

LÖVE works on Windows XP and Mac OS 10.7 (Lion). The main thing is that it requires an OpenGL 2.1 or OpenGL ES 2-capable graphics card as well as graphics drivers that provide said OpenGL version.

The oldest OpenGL 2.1-capable desktop GPUs are (roughly) the nvidia GeForce 6000 series from 2004, the ATI Radeon 9000 series from 2003, and the Intel GMA X or Intel HD series from 2007 or 2010 (depending on the graphics driver).

User avatar
Tricky
Citizen
Posts: 75
Joined: Thu Dec 18, 2014 4:07 pm
Location: Breda, the Netherlands
Contact:

Re: minimum requirements

Post by Tricky » Thu Apr 14, 2016 1:35 pm

Thank you ;)

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests