black screen running .love file

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
PGUp
Citizen
Posts: 68
Joined: Fri Apr 21, 2017 9:17 am

black screen running .love file

Post by PGUp » Thu May 17, 2018 8:06 am

running lua file
ss1.png
ss1.png (140.15 KiB) Viewed 452 times

running .love file
ss2.png
ss2.png (111.49 KiB) Viewed 452 times
running lua files works just fine like the first pic, but running .love file result in a black screen (second pic). The game is not freezing, just black screen, other .love files that i downloaded also works, but not mine..
-

User avatar
Nixola
Inner party member
Posts: 1935
Joined: Tue Dec 06, 2011 7:11 pm
Location: Italy

Re: black screen running .love file

Post by Nixola » Thu May 17, 2018 8:11 am

Since it's your .love file that doesn't work (you said others work), could you upload it so we may check if there's something wrong with it?
lf = love.filesystem
ls = love.sound
la = love.audio
lp = love.physics
lt = love.thread
li = love.image
lg = love.graphics

User avatar
pgimeno
Party member
Posts: 1260
Joined: Sun Oct 18, 2015 2:58 pm

Re: black screen running .love file

Post by pgimeno » Thu May 17, 2018 12:21 pm

I saw a thread like this one a few days ago, which had a .love file, but when I tried to reply, it was gone.

I tried the .love file in 0.10 and 11.0. It worked fine for me in 11.0, but in 0.10 I got the black screen. Maybe you have both versions installed, and it's calling the wrong one when you try to run the .love file?

Try with a .love file that has this as main.lua, to see if that's the case:

Code: Select all

function love.draw()
  love.graphics.print(table.concat{love.getVersion()})
end
Thrust II Reloaded - GifLoad for Löve - GSpöt GUI - My NotABug.org repositories
The Microsoft Github repositories I had have been closed after the acquisition announcement and will be removed in the near future.

PGUp
Citizen
Posts: 68
Joined: Fri Apr 21, 2017 9:17 am

Re: black screen running .love file

Post by PGUp » Thu May 17, 2018 1:26 pm

Nixola wrote:
Thu May 17, 2018 8:11 am
Since it's your .love file that doesn't work (you said others work), could you upload it so we may check if there's something wrong with it?
here:
main.love
(1.41 KiB) Downloaded 13 times
-

PGUp
Citizen
Posts: 68
Joined: Fri Apr 21, 2017 9:17 am

Re: black screen running .love file

Post by PGUp » Thu May 17, 2018 1:26 pm

pgimeno wrote:
Thu May 17, 2018 12:21 pm
I saw a thread like this one a few days ago, which had a .love file, but when I tried to reply, it was gone.

I tried the .love file in 0.10 and 11.0. It worked fine for me in 11.0, but in 0.10 I got the black screen. Maybe you have both versions installed, and it's calling the wrong one when you try to run the .love file?

Try with a .love file that has this as main.lua, to see if that's the case:

Code: Select all

function love.draw()
  love.graphics.print(table.concat{love.getVersion()})
end
i deleted the 11.0 version already.
-

User avatar
pgimeno
Party member
Posts: 1260
Joined: Sun Oct 18, 2015 2:58 pm

Re: black screen running .love file

Post by pgimeno » Thu May 17, 2018 1:49 pm

PGUp wrote:
Thu May 17, 2018 1:26 pm
i deleted the 11.0 version already.
Well, in 0.10 I get a black screen. If I edit the setColor / setBackgroundColor calls to make them be in the 0-255 range, it works in 0.10 too.
Thrust II Reloaded - GifLoad for Löve - GSpöt GUI - My NotABug.org repositories
The Microsoft Github repositories I had have been closed after the acquisition announcement and will be removed in the near future.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 11 guests