love renders only background color

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
User avatar
Serpent7776
Prole
Posts: 5
Joined: Sun Dec 16, 2018 7:50 pm

love renders only background color

Post by Serpent7776 » Sun Dec 16, 2018 8:44 pm

love2d is not rendering anything for me, I get only background color. It's like that for both default window when no game was given on command line and when I run my game. The game is running properly because I can hear music and sounds, it's just visuals that are not working. Maybe it's driver incompatibility, but other apps/games run fine on this system.
Any ideas how to check whether it's an love2d issue or driver/system issue?

Running `env LIBGL_DEBUG=verbose love` gives just:

Code: Select all

libGL: OpenDriver: trying /usr/local/lib/dri/r600_dri.so
libGL: Using DRI2 for screen 0
It happens for both love 11.2 and 11.1.
It was working properly on love2d 0.10.
My system is FreeBSD 11.2 (not sure it's supported system) built from ports.
Attachments
love-default-window.png
love default window I see
love-default-window.png (3.17 KiB) Viewed 1580 times

User avatar
pgimeno
Party member
Posts: 1688
Joined: Sun Oct 18, 2015 2:58 pm

Re: love renders only background color

Post by pgimeno » Sun Dec 16, 2018 11:22 pm

Does setting LOVE_GRAPHICS_USE_GL2=1 help?

User avatar
Serpent7776
Prole
Posts: 5
Joined: Sun Dec 16, 2018 7:50 pm

Re: love renders only background color

Post by Serpent7776 » Mon Dec 17, 2018 6:48 pm

Yes, it does.

User avatar
pgimeno
Party member
Posts: 1688
Joined: Sun Oct 18, 2015 2:58 pm

Re: love renders only background color

Post by pgimeno » Mon Dec 17, 2018 7:09 pm

Looks like a driver problem, then. No idea how to further diagnose that in FreeBSD, sorry.

User avatar
Serpent7776
Prole
Posts: 5
Joined: Sun Dec 16, 2018 7:50 pm

Re: love renders only background color

Post by Serpent7776 » Mon Dec 17, 2018 8:18 pm

Thanks for help. So does setting LOVE_GRAPHICS_USE_GL2=1 tells love to use OpenGLv2, and without it it's using OpenGLv3?

User avatar
pgimeno
Party member
Posts: 1688
Joined: Sun Oct 18, 2015 2:58 pm

Re: love renders only background color

Post by pgimeno » Mon Dec 17, 2018 8:53 pm

I don't know the details, but here's some info: viewtopic.php?p=224381#p224381 (you may need to take a look at the previous post for context).

User avatar
Serpent7776
Prole
Posts: 5
Joined: Sun Dec 16, 2018 7:50 pm

Re: love renders only background color

Post by Serpent7776 » Tue Dec 18, 2018 6:18 pm

ok, thanks

rincewind
Prole
Posts: 2
Joined: Wed Dec 26, 2018 3:30 pm

Re: love renders only background color

Post by rincewind » Wed Dec 26, 2018 3:43 pm

Thank you so mush to pointing it. Same issue, FreeBSD 11.2/12.0 with love 11.1-11.2
this environment variable actually helps

kinda impressed with performance btw. Almost only 5% of cpu used with 60fps in my "game of life" test. And it's just an 8yo outdated notebook with i5.

it was interesting for me how much memory it will use so i made this.
controls - arrows to change map coordinates, space for calling LUA garbage collector :), esc to exit
1.love
(436.85 KiB) Downloaded 21 times

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 8 guests