Love-imgui canvas render acting strange on focus

Questions about the LÖVE API, installing LÖVE and other support related questions go here.
Forum rules
Before you make a thread asking for help, read this.
Post Reply
Zulsorai
Prole
Posts: 16
Joined: Fri Jun 20, 2014 1:57 am

Love-imgui canvas render acting strange on focus

Post by Zulsorai » Sun Feb 10, 2019 9:27 am

So I've been playing around with the Love-imgui library lately and have been having some issues when I render a canvas to a window.

It seems to render fine until the window object becomes the focus, once it does all the text renders as blocks and lines become thicker.

However, if I click on the top menu bar it renders correctly again. Stranger yet if I open the Demo window provided by the library and enable the 'io.MouseDrawCursor' under 'Input and Focus', this seems to solve the issue.

I was wondering if anyone else has come across this issue when using this library, or if I've just managed to implement it wrong.
I've been looking at the source files and can't see anything obvious why toggling this would cause the image to render differently. Though to be fair I don't really know C++.

Just some quick notes:
Windows 10
Love 11.2 64
Using the prebuilt 64bit imgui.dll library on camchenry's fork: https://github.com/camchenry/love-imgui/releases

New-Project.love
(10.97 KiB) Downloaded 53 times
WASD: move green ball

grump
Party member
Posts: 572
Joined: Sat Jul 22, 2017 7:43 pm

Re: Love-imgui canvas render acting strange on focus

Post by grump » Sun Feb 10, 2019 9:44 am

Sounds like something sets a blendmode but fails to restore the previous one.

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests