Search found 18 matches

by CryoNox
Thu Jul 02, 2009 4:55 am
Forum: Support and Development
Topic: WEIRD PNG image problem
Replies: 13
Views: 3167

Re: WEIRD PNG image problem

hey thanks robin and bartbes for your advice and stuff. Appreciate it :)
by CryoNox
Wed Jul 01, 2009 3:39 am
Forum: Support and Development
Topic: WEIRD PNG image problem
Replies: 13
Views: 3167

Re: WEIRD PNG image problem

oh thanks bartbes, I didn't notice the case :D

Still, its kinda weird that the problem only occurs after it is compressed into a .love file.
by CryoNox
Tue Jun 30, 2009 6:16 pm
Forum: Support and Development
Topic: WEIRD PNG image problem
Replies: 13
Views: 3167

Re: WEIRD PNG image problem

alright I've attached it ^^
By right, you're supposed to see the love logo fading in before fading out. It doesn't appear though, cos the image won't load.
by CryoNox
Tue Jun 30, 2009 2:23 pm
Forum: Support and Development
Topic: WEIRD PNG image problem
Replies: 13
Views: 3167

WEIRD PNG image problem

Hey all, I've encountered a weird problem when I create my own .png images. When I drag my project folder into the LÖVE icon, the image loads perfectly fine. However, when I compress everything into a zip folder and change the extension to .love, the image fails to load when I run the program. This ...
by CryoNox
Tue Jun 30, 2009 5:39 am
Forum: Games and Creations
Topic: A Platformer With Love!
Replies: 76
Views: 17730

Re: A Platformer With Love!

oh okay I didn't realize you could move to the right :X Maybe you could put a signal or arrow?

Its looks quite cool by the way :D
by CryoNox
Mon Jun 29, 2009 5:35 pm
Forum: Support and Development
Topic: No blend mode.
Replies: 19
Views: 5713

Re: No blend mode.

ARGH I JUST REALIZED MY STUPID MISTAKE:

I did this:
love.graphics.setBlendMode(love.color_modulate)

instead of this:
love.graphics.setColorMode(love.color_modulate)

lol.
by CryoNox
Mon Jun 29, 2009 4:37 pm
Forum: Support and Development
Topic: No blend mode.
Replies: 19
Views: 5713

Re: No blend mode.

I tried adjusting the alpha for text and it works. Strangely though, the images remain 50% alpha all the time, even when I set the alpha value to 0 - causing the text to disappear of course. For some reason adjusting the alpha value only works for text and not images. Is there a solution to this? ED...
by CryoNox
Mon Jun 29, 2009 4:06 pm
Forum: Support and Development
Topic: Memory Control?
Replies: 5
Views: 1108

Re: Memory Control?

Zorbatron: Yup, I was thinking along the lines of loading screens between levels :)

Tenoch: Thanks so much for your reply :D
by CryoNox
Mon Jun 29, 2009 3:54 pm
Forum: Support and Development
Topic: No blend mode.
Replies: 19
Views: 5713

Re: No blend mode.

rude: I tried that already: function MenuState:draw() local oldcolor = love.graphics.getColor() love.graphics.setBlendMode(love.color_modulate) love.graphics.setColor(255, 255, 255, 0) love.graphics.draw( img["loveBG"], love.graphics.getWidth()*0.5, love.graphics.getHeight()*0.5) love.graphics.setCo...
by CryoNox
Mon Jun 29, 2009 9:04 am
Forum: Support and Development
Topic: No blend mode.
Replies: 19
Views: 5713

Re: No blend mode.

Jake: your avatar is hardly visible ^^ Everyone: I've been trying to alpha blend my images too: local oldcolor = love.graphics.getColor() love.graphics.setColor(255, 255, 255, 128) love.graphics.draw( img["loveBG"], love.graphics.getWidth()*0.5, love.graphics.getHeight()*0.5) love.graphics.setColor(...